Bug 234254

Summary: knetworkmanagement plasmoid crashes on setting network while not connected completely
Product: Network Management Reporter: Rohan Garg <rohan>
Component: Plasma WidgetAssignee: Will Stephenson <wstephenson>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra, sebas
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Rohan Garg 2010-04-13 15:07:45 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-19-generic x86_64
Distribution: Ubuntu lucid (development branch)

-- Information about the crash:
Hi
When i try to set my preferred network via the plasmoid and my modem is still connecting to my ISP,the plasmoid crashes bringing down the whole of plasma-desktop with it,i have 2 entries in the plasmoid,one with everything as auto eth0 and the other is my home network with the google DNS servers in the DNS fields 

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc2966ae760 (LWP 1890))]

Thread 3 (Thread 0x7fc26e2c6710 (LWP 1893)):
#0  0x00007fc2936a1f93 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc2900674a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fc2900678fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fc294ca9566 in QEventDispatcherGlib::processEvents (this=0x1765b80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fc294c7e992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fc294c7ed6c in QEventLoop::exec (this=0x7fc26e2c5db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fc294b88d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fc294c5f178 in QInotifyFileSystemWatcherEngine::run (this=0x17bc510) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc294b8b775 in QThreadPrivate::start (arg=0x17bc510) at thread/qthread_unix.cpp:248
#9  0x00007fc2948fb9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fc2936ae6dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fc2633f2710 (LWP 1901)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fc294b8c72b in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x14fcd00, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x14fcd00, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007fc27381e1d3 in ?? () from /usr/lib/pymodules/python2.6/PyQt4/QtCore.so
#4  0x00007fc274472030 in call_function (f=
    Frame 0x28997f0, for file /home/shadeslayer/.kde/share/apps/plasma/wallpapers/clock/contents/code/wallpaperrenderer.py, line 73, in run (self=<WallpaperRenderer(job=<StackJob(color=<QColor at remote 0x2af4a78>, renderThread=None, jobId=1, images=[<QImage at remote 0x2af4ce8>, u'/home/shadeslayer/.kde/share/apps/plasma/clockwallpapers/plasma-desktopUt2004/minute20.png'], method=<ResizeMethod at remote 0x2d84f80>, size=<QSize at remote 0x2af4600>) at remote 0x2edd488>, abort=False, mutex=<QMutex at remote 0x1bbe870>, restart=False, condition=<QWaitCondition at remote 0x1fed328>) at remote 0x2d7b738>, job=None), throwflag=<value optimized out>) at ../Python/ceval.c:3750
#5  PyEval_EvalFrameEx (f=
    Frame 0x28997f0, for file /home/shadeslayer/.kde/share/apps/plasma/wallpapers/clock/contents/code/wallpaperrenderer.py, line 73, in run (self=<WallpaperRenderer(job=<StackJob(color=<QColor at remote 0x2af4a78>, renderThread=None, jobId=1, images=[<QImage at remote 0x2af4ce8>, u'/home/shadeslayer/.kde/share/apps/plasma/clockwallpapers/plasma-desktopUt2004/minute20.png'], method=<ResizeMethod at remote 0x2d84f80>, size=<QSize at remote 0x2af4600>) at remote 0x2edd488>, abort=False, mutex=<QMutex at remote 0x1bbe870>, restart=False, condition=<QWaitCondition at remote 0x1fed328>) at remote 0x2d7b738>, job=None), throwflag=<value optimized out>) at ../Python/ceval.c:2412
#6  0x00007fc274473d60 in PyEval_EvalCodeEx (co=0x2d75828, globals=<value optimized out>, locals=<value optimized out>, args=0x1, argcount=<value optimized out>, kws=<value optimized out>, 
    kwcount=0, defs=0x0, defcount=0, closure=0x0) at ../Python/ceval.c:3000
#7  0x00007fc2743f9d60 in function_call (func=<function at remote 0x2d7d668>, arg=
    (<WallpaperRenderer(job=<StackJob(color=<QColor at remote 0x2af4a78>, renderThread=None, jobId=1, images=[<QImage at remote 0x2af4ce8>, u'/home/shadeslayer/.kde/share/apps/plasma/clockwallpapers/plasma-desktopUt2004/minute20.png'], method=<ResizeMethod at remote 0x2d84f80>, size=<QSize at remote 0x2af4600>) at remote 0x2edd488>, abort=False, mutex=<QMutex at remote 0x1bbe870>, restart=False, condition=<QWaitCondition at remote 0x1fed328>) at remote 0x2d7b738>,), kw=0x0) at ../Objects/funcobject.c:524
#8  0x00007fc2743cc2e3 in PyObject_Call (func=<function at remote 0x2d7d668>, arg=<unknown at remote 0x80>, kw=<unknown at remote 0x5>) at ../Objects/abstract.c:2492
#9  0x00007fc2743ddcef in instancemethod_call (func=<function at remote 0x2d7d668>, arg=
    (<WallpaperRenderer(job=<StackJob(color=<QColor at remote 0x2af4a78>, renderThread=None, jobId=1, images=[<QImage at remote 0x2af4ce8>, u'/home/shadeslayer/.kde/share/apps/plasma/clockwallpapers/plasma-desktopUt2004/minute20.png'], method=<ResizeMethod at remote 0x2d84f80>, size=<QSize at remote 0x2af4600>) at remote 0x2edd488>, abort=False, mutex=<QMutex at remote 0x1bbe870>, restart=False, condition=<QWaitCondition at remote 0x1fed328>) at remote 0x2d7b738>,), kw=0x0) at ../Objects/classobject.c:2579
#10 0x00007fc2743cc2e3 in PyObject_Call (func=<instancemethod at remote 0x1b708c0>, arg=<unknown at remote 0x80>, kw=<unknown at remote 0x5>) at ../Objects/abstract.c:2492
#11 0x00007fc27446c193 in PyEval_CallObjectWithKeywords (func=<instancemethod at remote 0x1b708c0>, arg=(), kw=<unknown at remote 0x5>) at ../Python/ceval.c:3619
#12 0x00007fc273565d3b in ?? () from /usr/lib/pymodules/python2.6/sip.so
#13 0x00007fc27380d468 in ?? () from /usr/lib/pymodules/python2.6/PyQt4/QtCore.so
#14 0x00007fc27383d630 in ?? () from /usr/lib/pymodules/python2.6/PyQt4/QtCore.so
#15 0x00007fc294b8b775 in QThreadPrivate::start (arg=0x2d40c80) at thread/qthread_unix.cpp:248
#16 0x00007fc2948fb9ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#17 0x00007fc2936ae6dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#18 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc2966ae760 (LWP 1890)):
[KCrash Handler]
#5  0x00007fc294c964f1 in QObject::disconnect (sender=0x23eefc0, signal=<value optimized out>, receiver=0x2589680, method=<value optimized out>) at kernel/qobject.cpp:2764
#6  0x00007fc26d281128 in QObject::disconnect (this=0x23eefc0) at /usr/include/qt4/QtCore/qobject.h:229
#7  InterfaceItem::currentConnectionChanged (this=0x23eefc0) at ../../applet/interfaceitem.cpp:276
#8  0x00007fc26d281ae6 in InterfaceItem::connectionStateChanged (this=0x23eefc0, state=1324507488) at ../../applet/interfaceitem.cpp:390
#9  0x00007fc26d277c21 in InterfaceItem::qt_metacall (this=0x23eefc0, _c=<value optimized out>, _id=<value optimized out>, _a=0x7fff4ef26320) at moc_interfaceitem.cpp:112
#10 0x00007fc294c92e3f in QMetaObject::activate (sender=0x2409a80, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x2225ca8) at kernel/qobject.cpp:3293
#11 0x00007fc277cd72fd in Solid::Control::NetworkInterface::connectionStateChanged(int, int, int) () from /usr/lib/libsolidcontrol.so.4
#12 0x00007fc277cd7410 in Solid::Control::NetworkInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libsolidcontrol.so.4
#13 0x00007fc277cd9b40 in Solid::Control::WiredNetworkInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libsolidcontrol.so.4
#14 0x00007fc294c92e3f in QMetaObject::activate (sender=0x232e460, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x2225ca8) at kernel/qobject.cpp:3293
#15 0x00007fc26c9e9bed in NMNetworkInterface::connectionStateChanged(int, int, int) () from /usr/lib/kde4/solid_networkmanager07.so
#16 0x00007fc26c9eaa6c in NMNetworkInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#17 0x00007fc26c9ed365 in NMWiredNetworkInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#18 0x00007fc294c92e3f in QMetaObject::activate (sender=0x239afb0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x2225ca8) at kernel/qobject.cpp:3293
#19 0x00007fc26c9f339a in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#20 0x00007fc26c9f33f3 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#21 0x00007fc293045486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#22 0x00007fc29305005f in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#23 0x00007fc294c8fd49 in QObject::event (this=0x239afb0, e=0x153b790) at kernel/qobject.cpp:1248
#24 0x00007fc293e1c22c in QApplicationPrivate::notify_helper (this=0x1331070, receiver=0x239afb0, e=0x153b790) at kernel/qapplication.cpp:4300
#25 0x00007fc293e226fb in QApplication::notify (this=0x131ab40, receiver=0x239afb0, e=0x153b790) at kernel/qapplication.cpp:4183
#26 0x00007fc2951c7526 in KApplication::notify (this=0x131ab40, receiver=0x239afb0, event=0x153b790) at ../../kdeui/kernel/kapplication.cpp:302
#27 0x00007fc294c8006c in QCoreApplication::notifyInternal (this=0x131ab40, receiver=0x239afb0, event=0x153b790) at kernel/qcoreapplication.cpp:704
#28 0x00007fc294c827e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x12a7c30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#29 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x12a7c30) at kernel/qcoreapplication.cpp:1345
#30 0x00007fc294ca99d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#31 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#32 0x00007fc2900638c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#33 0x00007fc290067748 in ?? () from /lib/libglib-2.0.so.0
#34 0x00007fc2900678fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#35 0x00007fc294ca9513 in QEventDispatcherGlib::processEvents (this=0x12a9140, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#36 0x00007fc293ecc46e in QGuiEventDispatcherGlib::processEvents (this=0x2589680, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#37 0x00007fc294c7e992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#38 0x00007fc294c7ed6c in QEventLoop::exec (this=0x7fff4ef27480, flags=) at kernel/qeventloop.cpp:201
#39 0x00007fc294c82aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#40 0x00007fc289ccdfb2 in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#41 0x00000000004070f3 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a4f9 "0") at ../../kinit/kinit.cpp:717
#42 0x0000000000407cb0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#43 0x000000000040823a in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#44 0x0000000000408e22 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1845

Reported using DrKonqi
Comment 1 Rohan Garg 2010-04-14 08:36:13 UTC
I might be wrong about the knetworkmanagement crash though.. it could have been a wallpaperclock crash too,but im not sure.
Comment 2 Sebastian K├╝gler 2010-04-14 10:14:23 UTC
This looks like a bug I fixed a couple of days ago. Is your SVN snapshot of the network management plasmoid up to date?
Comment 3 Rohan Garg 2010-04-14 16:24:22 UTC
Hi Sebastian
Actually im using a binary package from the kubuntu experimental PPA,here are the details : 

plasma-widget-networkmanagement:
  Installed: 0.9~svn1112085-0ubuntu1
  Candidate: 0.9~svn1112085-0ubuntu1
  Version table:
 *** 0.9~svn1112085-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     0.9~svn1112085-0ubuntu1~ppar1 0
        500 http://ppa.launchpad.net/kubuntu-ppa/experimental/ubuntu/ lucid/main Packages
Comment 4 Dario Andres 2010-11-17 13:19:14 UTC
[Comment from a bug triager]
Actually, similar bugs (crash when there is a change in a wired connection) are being tracked at bug 240285. Merging. Thanks

*** This bug has been marked as a duplicate of bug 240285 ***