Bug 232973

Summary: icons disappeared almost everywhere on plasma
Product: plasma4 Reporter: Nikita Melnichenko <open-development>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED NOT A BUG    
Severity: normal CC: andresbajotierra, asraniel, notmart, open-development, pragma, rolf, zdenek.koprivik
Priority: NOR    
Version: 4.5 and older   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: screenshot
New crash information added by DrKonqi

Description Nikita Melnichenko 2010-04-01 16:04:30 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

I'm using 4.4.2 release, not SVN version (no choice in bugzilla yet). Icons just disappeared, I doesn't do anything, just came back to my computer and noted that. Restart of plasma-desktop helped. That didn't occur when I used KDE SC 4.4.1.

I'll try to find out what was the reason. Screenshot in the next post...
Comment 1 Nikita Melnichenko 2010-04-01 16:05:11 UTC
Created attachment 42426 [details]
screenshot

no icons
Comment 2 Dario Andres 2010-04-01 16:33:23 UTC
The Pixmap cache had some problems lately.. may be you could try cleaning that cache (empty the folder "/var/tmp/kde-USERNAME/kpc")
Comment 3 Nikita Melnichenko 2010-04-01 17:08:51 UTC
Well, I deleted everything in this dir 30 minutes ago. Doesn't help cause issue has fired again (5 minutes ago). Additional note: my clocks show a UTC time, not a local time now. According to my screenshot that it was so at the first time I got it.
Comment 4 Nikita Melnichenko 2010-04-01 17:14:00 UTC
Created attachment 42427 [details]
New crash information added by DrKonqi

I tried reload plasma-desktop after these events. Crashed.

Command was:

$ kquitapp plasma-desktop
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
<unknown program name>(29066)/: "Quitting application plasma-desktop failed. Error reported was:

     org.freedesktop.DBus.Error.NoReply : Message did not receive a reply (timeout by message bus)" 

I hope it could help.
Comment 5 Beat Wolf 2010-04-30 20:31:12 UTC
what GPU do you use? somebody told me that this is a problem with an older nvidia driver. i have seen the bug to, using a nvidia with kubuntu 9.10
Comment 6 Nikita Melnichenko 2010-05-02 11:43:17 UTC
No, this bug is definitely concerned with the bug#234781 (too much files are opened so Plasma can't open icon files). On the one hand it's a specific plasmoid issue, on the other hand that plasmoid is completely scripted (javascript, python), so it's a Plasma issue anyway.

I gave a simplified example of that crash (100% reproducible) but no one is interested. :(
Comment 7 Szymon Stefanek 2010-05-24 20:44:31 UTC
I also have this bug. All the icons in KMenu are disappeared and the clock shows UTC time (but clock settings correctly show local time).

My plasma-desktop process has 1259 open files. 

# lsof -p <pid-of-plasma-desktop> | wc -l
1259

The limit reported by ulimit seems to be 1024 but I suppose that the binaries used to create the in-memory image aren't accounted for.
There are ~1000 entries similar to the following:

plasma-de 2935 pragma 26u REG 8,3 0 9118907 /tmp/kde-pragma/plasma-desktopGa2935.tmpHR2935.new (deleted)

Restarting the plasma-desktop process fixes the problem (the open files drop to ~200).
Comment 8 KOPRajs 2010-05-26 17:01:02 UTC
I can confirm this bug. Icons disappear, clock shows time in UTC and plasma-desktop is CPU hungry (about 10%).
Screenshot: http://jf-web.wz.cz/kubuntu_missing_icons.png
I watched the number of plasma-desktop's opened files and noticed that a new zombie file entry (/tmp/kde-koprajs/plasma-desktopwE3504.tmpkA3504.new (deleted)) appears for every new notification in notify area.
So e.g. having Kopete connected to account with many contacts 24/7 and online notifications turned on kills the plasma-desktop in one day.

P.S. I'm on Kubuntu Lucid with KDE 4.4.2 and using ATI Mobility Radeon with Catalyst driver.

P.P.S. Those who experience this bug please vote for it and also for #234781 to get some attention from the developers.
Comment 9 KOPRajs 2010-05-27 13:01:46 UTC
Correction:
The new zombie file descriptor does not appear for every new notification but appears when you delete (close) a notification from the "Recent notifications" list.
Comment 10 Beat Wolf 2010-05-27 13:03:20 UTC
I think in that case it's usefull to CC notmart
Comment 11 Marco Martin 2010-05-27 13:41:09 UTC
looks like a graphics driver bug
or x pixmap never being freed, so it runs out of graphics memory
at least, we had both of those problems in the past
Comment 12 Rolf Martin-Hoster 2010-07-21 12:05:53 UTC
Both my coworker and I are experiencing the same issue in 4.4.2. Icons disappear and clock resets to GMT?
Comment 13 Myriam Schweingruber 2012-05-17 14:02:57 UTC
Closing for lack of feedback. Please feel free to reopen this report if you can still reproduce this with KDE 4.8.3 or later.