Bug 232773

Summary: KMail does not see any updates to address book since update to 4.4
Product: kmail Reporter: Luke Plant <L.Plant.98>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED UNMAINTAINED    
Severity: normal    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Luke Plant 2010-03-31 00:05:49 UTC
Version:            (using KDE 4.4.1)
OS:                Linux
Installed from:    Ubuntu Packages

I recently updated from KDE 4.3.? (Ubuntu Karmic packages) to KDE 4.4.1 (Ubuntu Karmic backports).

I opened the new KDE Address Book manager, and went through the process to add a "KDE Address Book (traditional)".  I added the file "/home/luke/.kde/share/apps/kabc/std.vcf".

However, in KMail, when I type names in a "To" field, the entries that appear do not reflect any changes I make in that address book.  My address book is stuck in the state that it was in before the upgrade.

On investigation, I find that the changes I make in the address book (whether new contacts or changing existing data etc) are not stored in the actual file.

I'm not sure how many bugs this counts as:  
1) The properties for the address book say that it is stored in "/home/luke/.kde/share/apps/kabc/std.vcf", but it clearly is not.  Somehow the data is being stored elsewhere.  This is a serious bug, since I expect to be able to back up my address book my backing up that file.  This has already caused me some confusion and data loss I think.  
2) Wherever the data is being stored, it is not being picked up by KMail.

I noticed that when I add other Akonadi address book resources (e.g. Google contacts) are also not shown in KMail.
Comment 1 Luke Plant 2010-04-03 15:36:00 UTC
I have upgraded to 4.4.2 and can no longer reproduce this - the data appears in the std.vcf file after a short delay.

KMail still does not see any other contacts apart from the ones in std.vcf, whether from Google Contacts or if I add an Akonadi resource to a local VCF file.
Comment 2 Luke Plant 2010-06-10 19:58:16 UTC
I'm seeing this again, KDE 4.4.4. Normally, the data appears in std.vcf after a few seconds delay, and is then accessible to KMail.  But sometimes it is hours - it is just unreliable.  I have data right now that is visible in KAddressBook that I added hours ago, but isn't in the std.vcf.

As mentioned before, this can easily cause data loss - you put data into your address book, but there is no way to ensure that it is flushed to the file system.
Comment 3 Luke Plant 2010-06-14 15:46:38 UTC
4 days later, after reboots, multiple suspend/resume cycles, restarting Akonadi several times etc, and the data still has not appeared in std.vcf, though it still appears in KAddressBook. This is crazy.
Comment 4 Laurent Montel 2015-04-12 09:46:22 UTC
Thank you for taking the time to file a bug report.

KMail2 was released in 2011, and the entire code base went through significant changes. We are currently in the process of porting to Qt5 and KF5. It is unlikely that these bugs are still valid in KMail2.

We welcome you to try out KMail 2 with the KDE 4.14 release and give your feedback.