Bug 230325

Summary: Konqueror crashed adding a recension in a PDF
Product: konqueror Reporter: Phisss <phissica>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Phisss 2010-03-11 15:56:29 UTC
Application: konqueror (4.4.1 (KDE 4.4.1))
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.31-20-generic x86_64
Distribution: Ubuntu 9.10

-- Information about the crash:
I had opened several tabs with PDF's stored on the Computer. I use the Okular Plugin. So, when I was trying to select TOOLS>RECENSION (in German: Extras>Rezession), Konqueror crashed.

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x00007f481f516027 in QString (this=0x28, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#6  KIconEffect::fingerprint (this=0x28, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#7  0x00007f481f522ac8 in KIconLoader::loadIcon (this=0x35dc6a0, _name=..., group=<value optimized out>, size=32, state=<value optimized out>, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#8  0x00007f481f51a5dd in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:119
#9  0x00007f481e2630b5 in QIcon::pixmap (this=<value optimized out>, size=..., mode=QIcon::Normal, state=7274607) at image/qicon.cpp:669
#10 0x00007f481e4c279f in QCommonStyle::drawControl (this=0xb41110, element=<value optimized out>, opt=0x7fff51784800, p=0x7fff51784de0, widget=0x2cd37d0) at styles/qcommonstyle.cpp:1597
#11 0x00007f481f56be22 in KStyle::drawControl (this=0xb41110, element=QStyle::CE_ToolButtonLabel, option=0x7fff51784800, p=<value optimized out>, widget=0x2cd37d0)
    at ../../kdeui/kernel/kstyle.cpp:2508
#12 0x00007f48129070cd in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#13 0x00007f481f56971c in KStyle::drawComplexControl (this=0xb41110, cc=<value optimized out>, opt=0x7fff51784d60, p=<value optimized out>, w=0x2cd37d0) at ../../kdeui/kernel/kstyle.cpp:3473
#14 0x00007f48129024ea in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#15 0x00007f481e635548 in QStylePainter::drawComplexControl (this=0x2cd37d0) at ../../include/QtGui/../../src/gui/painting/qstylepainter.h:94
#16 QToolButton::paintEvent (this=0x2cd37d0) at widgets/qtoolbutton.cpp:556
#17 0x00007f481e2070e2 in QWidget::event (this=0x2cd37d0, event=0x7fff517855f0) at kernel/qwidget.cpp:8144
#18 0x00007f481e1b112c in QApplicationPrivate::notify_helper (this=0xb00230, receiver=0x2cd37d0, e=0x7fff517855f0) at kernel/qapplication.cpp:4300
#19 0x00007f481e1b771b in QApplication::notify (this=0x7fff5178a4b0, receiver=0x2cd37d0, e=0x7fff517855f0) at kernel/qapplication.cpp:4183
#20 0x00007f481f55ad76 in KApplication::notify (this=0x7fff5178a4b0, receiver=0x2cd37d0, event=0x7fff517855f0) at ../../kdeui/kernel/kapplication.cpp:302
#21 0x00007f481f012e0c in QCoreApplication::notifyInternal (this=0x7fff5178a4b0, receiver=0x2cd37d0, event=0x7fff517855f0) at kernel/qcoreapplication.cpp:704
#22 0x00007f481e20f75d in QCoreApplication::sendSpontaneousEvent (this=0x2a71f80, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 QWidgetPrivate::drawWidget (this=0x2a71f80, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, backingStore=0x10038d0)
    at kernel/qwidget.cpp:5339
#24 0x00007f481e2103f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=1, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5452
#25 0x00007f481e210229 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5439
#26 0x00007f481e210229 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=3, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5439
#27 0x00007f481e210229 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=4, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5439
#28 0x00007f481e210229 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=5, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5439
#29 0x00007f481e210229 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=6, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5439
#30 0x00007f481e210229 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=7, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5439
#31 0x00007f481e210229 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=8, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5439
#32 0x00007f481e210229 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=9, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5439
#33 0x00007f481e20f4ba in QWidgetPrivate::drawWidget (this=0x20b60c0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at kernel/qwidget.cpp:5388
#34 0x00007f481e2103f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2355, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5452
#35 0x00007f481e20f4ba in QWidgetPrivate::drawWidget (this=0x1bfdd90, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at kernel/qwidget.cpp:5388
#36 0x00007f481e2103f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=3, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5452
#37 0x00007f481e20f4ba in QWidgetPrivate::drawWidget (this=0x1be84f0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at kernel/qwidget.cpp:5388
#38 0x00007f481e2103f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=0, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5452
#39 0x00007f481e20f4ba in QWidgetPrivate::drawWidget (this=0x1b6e170, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at kernel/qwidget.cpp:5388
#40 0x00007f481e2103f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=2, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5452
#41 0x00007f481e20f4ba in QWidgetPrivate::drawWidget (this=0x1b68420, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at kernel/qwidget.cpp:5388
#42 0x00007f481e2103f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=1, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5452
#43 0x00007f481e20f4ba in QWidgetPrivate::drawWidget (this=0x1b5a700, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at kernel/qwidget.cpp:5388
#44 0x00007f481e2103f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=7, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5452
#45 0x00007f481e20f4ba in QWidgetPrivate::drawWidget (this=0x10b60c0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at kernel/qwidget.cpp:5388
#46 0x00007f481e2103f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=0, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5452
#47 0x00007f481e210229 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=1, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5439
#48 0x00007f481e20f4ba in QWidgetPrivate::drawWidget (this=0x10b5a50, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at kernel/qwidget.cpp:5388
#49 0x00007f481e2103f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=0, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5452
#50 0x00007f481e20f4ba in QWidgetPrivate::drawWidget (this=0x100d960, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at kernel/qwidget.cpp:5388
#51 0x00007f481e2103f8 in QWidgetPrivate::paintSiblingsRecursive (this=<value optimized out>, pdev=<value optimized out>, siblings=..., index=48, rgn=<value optimized out>, 
    offset=<value optimized out>, flags=4, sharedPainter=0x0, backingStore=0x10038d0) at kernel/qwidget.cpp:5452
#52 0x00007f481e20f4ba in QWidgetPrivate::drawWidget (this=0xbebfd0, pdev=<value optimized out>, rgn=..., offset=<value optimized out>, flags=<value optimized out>, sharedPainter=0x0, 
    backingStore=0x10038d0) at kernel/qwidget.cpp:5388
#53 0x00007f481e3c8c95 in QWidgetBackingStore::sync (this=0x10038d0) at painting/qbackingstore.cpp:1291
#54 0x00007f481e201050 in QWidgetPrivate::syncBackingStore (this=0xbebfd0) at kernel/qwidget.cpp:1672
#55 0x00007f481e2077e5 in QWidget::event (this=0xbebc40, event=0x1b50170) at kernel/qwidget.cpp:8291
#56 0x00007f481e5c910b in QMainWindow::event (this=0xbebc40, event=0x1b50170) at widgets/qmainwindow.cpp:1433
#57 0x00007f481f6723d3 in KXmlGuiWindow::event (this=0x7fff517828f0, ev=0x28) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:131
#58 0x00007f4813cae2dc in ?? () from /usr/lib/libkdeinit4_konqueror.so
#59 0x00007f481e1b112c in QApplicationPrivate::notify_helper (this=0xb00230, receiver=0xbebc40, e=0x1b50170) at kernel/qapplication.cpp:4300
#60 0x00007f481e1b771b in QApplication::notify (this=0x7fff5178a4b0, receiver=0xbebc40, e=0x1b50170) at kernel/qapplication.cpp:4183
#61 0x00007f481f55ad76 in KApplication::notify (this=0x7fff5178a4b0, receiver=0xbebc40, event=0x1b50170) at ../../kdeui/kernel/kapplication.cpp:302
#62 0x00007f481f012e0c in QCoreApplication::notifyInternal (this=0x7fff5178a4b0, receiver=0xbebc40, event=0x1b50170) at kernel/qcoreapplication.cpp:704
#63 0x00007f481f015587 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xa852e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xa852e0) at kernel/qcoreapplication.cpp:1345
#65 0x00007f481f03c7f3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#66 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#67 0x00007f481a21dbce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#68 0x00007f481a221598 in ?? () from /lib/libglib-2.0.so.0
#69 0x00007f481a2216c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#70 0x00007f481f03c333 in QEventDispatcherGlib::processEvents (this=0xa867f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#71 0x00007f481e260f0e in QGuiEventDispatcherGlib::processEvents (this=0x7fff517828f0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#72 0x00007f481f011732 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#73 0x00007f481f011b0c in QEventLoop::exec (this=0x7fff5178a1b0, flags=) at kernel/qeventloop.cpp:201
#74 0x00007f481f01584b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#75 0x00007f4813cd4716 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#76 0x0000000000406fb8 in launch (argc=3, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=24, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a499 "0") at ../../kinit/kinit.cpp:717
#77 0x0000000000407c70 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#78 0x0000000000408121 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1402
#79 0x0000000000408df2 in main (argc=4, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1841

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-22 02:27:30 UTC
Merging with bug 226596. Thanks

*** This bug has been marked as a duplicate of bug 226596 ***