Bug 228401

Summary: Something crashed, and there was no info about what program crashed other than a trace
Product: [Frameworks and Libraries] kdelibs Reporter: Steve Kelem <steve>
Component: kdedAssignee: David Faure <faure>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Steve Kelem 2010-02-25 02:03:32 UTC
Application that crashed: kded4
Version of the application: $Id: kded.cpp 1031638 2009-10-05 16:59:11Z lunakl $
KDE Version: 4.3.5 (KDE 4.3.5)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-19-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I had a few apps up and was typing in emacs.
Something crashed and put up the crash reporting assistant.
I slogged through the traces, downloaded the debug versions of the libs that didn't have debug info.

NOTHING IN THE TRACES TELL WHAT CRASHED! HOW USEFUL IS THAT?

 -- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  QString::size (this=<value optimized out>, other=...) at ../../include/QtCore/../../src/corelib/tools/qstring.h:104
#6  QString::operator== (this=<value optimized out>, other=...) at tools/qstring.cpp:1912
#7  0x00007f86415dc06b in KDirWatchPrivate::Entry::findSubEntry (this=0x1f8e480) at ../../kio/kio/kdirwatch_p.h:157
#8  KDirWatchPrivate::inotifyEventReceived (this=0x1f8e480) at ../../kio/kio/kdirwatch.cpp:297
#9  0x00007f86415dd6c4 in KDirWatchPrivate::qt_metacall (this=0x1f8e480, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff7d4d8c0) at ./kdirwatch_p.moc:75
#10 0x00007f86424d7ddc in QMetaObject::activate (sender=0x1f1fc30, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3113
#11 0x00007f864250de9e in QSocketNotifier::activated (this=0x1d0, _t1=9) at .moc/release-shared/moc_qsocketnotifier.cpp:83
#12 0x00007f86424dc773 in QSocketNotifier::event (this=0x1f1fc30, e=0x7ffff7d4de00) at kernel/qsocketnotifier.cpp:316
#13 0x00007f864046cefc in QApplicationPrivate::notify_helper (this=0x1f573d0, receiver=0x1f1fc30, e=0x7ffff7d4de00) at kernel/qapplication.cpp:4056
#14 0x00007f86404741ce in QApplication::notify (this=0x7ffff7d4e110, receiver=0x1f1fc30, e=0x7ffff7d4de00) at kernel/qapplication.cpp:4021
#15 0x00007f86410a3f46 in KApplication::notify (this=0x7ffff7d4e110, receiver=0x1f1fc30, event=0x7ffff7d4de00) at ../../kdeui/kernel/kapplication.cpp:302
#16 0x00007f86424c2c2c in QCoreApplication::notifyInternal (this=0x7ffff7d4e110, receiver=0x1f1fc30, event=0x7ffff7d4de00) at kernel/qcoreapplication.cpp:610
#17 0x00007f86424eb42a in QCoreApplication::sendEvent (source=0x1f61e90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#18 socketNotifierSourceDispatch (source=0x1f61e90) at kernel/qeventdispatcher_glib.cpp:110
#19 0x00007f863f39dbce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#20 0x00007f863f3a1598 in ?? () from /lib/libglib-2.0.so.0
#21 0x00007f863f3a16c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#22 0x00007f86424eb1a6 in QEventDispatcherGlib::processEvents (this=0x1ede040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#23 0x00007f86405014be in QGuiEventDispatcherGlib::processEvents (this=0x1d0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#24 0x00007f86424c1532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#25 0x00007f86424c1904 in QEventLoop::exec (this=0x7ffff7d4e060, flags=) at kernel/qeventloop.cpp:201
#26 0x00007f86424c3ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#27 0x00007f863a0d4cfb in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kded/kded.cpp:936
#28 0x0000000000406da8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a299 "0") at ../../kinit/kinit.cpp:677
#29 0x0000000000408cc0 in main (argc=<value optimized out>, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1740

Reported using DrKonqi
Comment 1 Steve Kelem 2010-02-25 02:05:48 UTC
The reporting assistant claims to have restarted whatever crashed, but I don't see any new windows.
Comment 2 Christoph Feck 2010-02-25 02:18:24 UTC
Thanks Steve for the bug report. Even if you do not understand the crash reports fully, they are useful for developers.

The kded4 daemon is not really an application, but it sometimes might display windows, such as system notifications.

*** This bug has been marked as a duplicate of bug 165548 ***