Bug 224215

Summary: On bugzilla mails, please indicate which Product the bug is for
Product: bugs.kde.org Reporter: Dotan Cohen <kde-2011.08>
Component: generalAssignee: Matt Rogers <mattr>
Status: RESOLVED DUPLICATE    
Severity: wishlist CC: dhillonv10, kde-2011.08
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Unspecified   
Latest Commit: Version Fixed In:

Description Dotan Cohen 2010-01-25 20:07:22 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Please add the Component field to bugzilla emails. Sometime it is not clear from the Title. Thanks.
Comment 1 Lydia Pintscher 2010-01-26 09:53:34 UTC
Component is listed in bugzilla emails here.
Comment 2 Dotan Cohen 2010-01-26 16:53:52 UTC
The mail I get looks like this:
"""
https://bugs.kde.org/show_bug.cgi?id=224215

Lydia Pintscher <lydia@kde.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |WORKSFORME

--- Comment #1 from Lydia Pintscher <lydia kde org>  2010-01-26 09:53:34 ---
Component is listed in bugzilla emails here.

-- Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You reported the bug.
"""

There is no component listed. Furthermore, going through the options there does not seem to be an option to add it. Perhaps you see when a component is changed, but I need the component to be shown in all emails.
Comment 3 Dotan Cohen 2010-01-26 16:54:53 UTC
Changing the bug's title: it is actually the Product that I meant, not component.
Comment 4 Vikram Dhillon 2010-01-27 02:20:26 UTC
This is right to some extent, when the bug is first reported, let's say this one, following is what I got in the email, it mentions everything. Bugzilla assumes that you keep the first email somewhere stored, and if you are using a threaded reader, it shouldn't be hard to keep up with that mail. But in subsequent messages you don't get any of that stuff, so I will talk about that to the mailing list, but doesn't seem like much of an issue :)

https://bugs.kde.org/show_bug.cgi?id=224215

          Summary: On bugzilla mails, please indicate which component the
                   bug is for
          Product: www.kde.org
          Version: unspecified
         Platform: Compiled Sources
       OS/Version: unspecified
           Status: NEW
         Severity: wishlist
         Priority: NOR
        Component: general
       AssignedTo: kde-www@kde.org
       ReportedBy: kde-51@dotancohen.com


Version:            (using Devel)
Installed from:    Compiled sources

Please add the Component field to bugzilla emails. Sometime it is not clear
from the Title. Thanks.
Comment 5 Felix Miata 2010-01-27 02:56:06 UTC
FWIW, Mandriva's Bugzilla includes the entire content of the original bugmail generated from the bug filing as a footer to each subsequent bugmail. In addition, on bugmail subsequent to triage assignment of an applicable RPM package, the rpm package name is included in the subject line. I find these Mandriva features quite handy.

I can't imagine saving all bugmail I get. All I save is bugmail generated by my own comments.

OTOH, when more generally subscribed to bugmail, that generated by others can much more quickly be scanned for possible interest when rpm name or product are part of the subject line, making the reporter's request a good idea for general interest subscribers or account watchers.
Comment 6 Vikram Dhillon 2010-01-27 03:08:54 UTC
@ Felix Miata:
Interesting, that something we could possibly port over to our bugzilla, but it would require a little more time and discussion and design before we can do that, thanks for the pointer though.
Comment 7 Dotan Cohen 2010-01-27 07:12:59 UTC
The Launchpad bugtracker sends all the info as well. It is great for users like me who contribute by triaging other people's bugs. I am subscribed to over 1200 bugs, in almost every KDE product, almost none of them my own personal issues. So knowing which component is being discussed in a mail from a bug that I triaged 18 months ago is critical.
Comment 8 Dotan Cohen 2011-09-22 06:39:04 UTC
*** Bug 194969 has been marked as a duplicate of this bug. ***
Comment 9 Dotan Cohen 2011-09-22 15:23:48 UTC

*** This bug has been marked as a duplicate of bug 194969 ***