Bug 223121

Summary: Spell checker settings does not display enchant dictionaries properly
Product: [Frameworks and Libraries] kdelibs Reporter: Harri Pitkänen <hatapitk>
Component: kspellAssignee: Zack Rusin <zack>
Status: RESOLVED WORKSFORME    
Severity: normal CC: anssi.hannula, tlikonen, vpvainio
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Debian testing   
OS: Linux   
Latest Commit: Version Fixed In:

Description Harri Pitkänen 2010-01-17 13:02:22 UTC
Version:            (using KDE 4.3.4)
OS:                Linux
Installed from:    Debian testing/unstable Packages

I use Enchant (with Voikko plugin) for spell checking Finnish in KDE. The actual spell checking works correctly, but in system settings (and other places where available dictionaries are listed) Finnish is not listed unless I create a fake hunspell dictionary for Finnish under /usr/share/hunspell/

This should not be needed. Enchant is able to list all the languages it supports. The list can be retrieved with command

 enchant-lsmod -list-dicts

and the same functionality is available through Enchant API.
Comment 1 Andrew Crouthamel 2018-11-02 22:55:19 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 2 Andrew Crouthamel 2018-11-16 02:48:41 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version?

Thank you for helping us make KDE software even better for everyone!
Comment 3 Justin Zobel 2022-12-13 02:54:14 UTC
Thank you for reporting this issue in KDE software. As it was reported on an older version, can we please ask you to see if you cazn reproduce the issue with a more recent software version?  
  
If you can confirm this issue still exists in a recent version, please change the version field and the status to "REPORTED" when replying. Thank you!
Comment 4 Teemu Likonen 2022-12-13 05:38:20 UTC
I am not the original submitter but it seems to me that Enchant dictionaries do show in the dictionary list. I am seeing "suomi (Suomi)" (i.e. the Finnish language) in the list and the language is available only through Enchant.
Comment 5 Teemu Likonen 2022-12-13 05:41:25 UTC
(In reply to Teemu Likonen from comment #4)
> I am not the original submitter but it seems to me that Enchant dictionaries
> do show in the dictionary list. I am seeing "suomi (Suomi)" (i.e. the
> Finnish language) in the list and the language is available only through
> Enchant.

That is in KDE Plasma version 5.20.5 (packaged by Debian).
Comment 6 Bug Janitor Service 2022-12-28 05:24:45 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Bug Janitor Service 2023-01-12 05:17:42 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!