Bug 222994

Summary: Crash while loading gpx file
Product: marble Reporter: Simon Schmeisser <mail_to_wrt>
Component: generalAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra, nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: 0.8 (KDE 4.3)   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description Simon Schmeisser 2010-01-16 17:05:27 UTC
Application that crashed: marble
Version of the application: 0.10.0 SVN
KDE Version: 4.3.4 (KDE 4.3.4) "release 2"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.8-0.1-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

What I was doing when the application crashed:
When I try to load a .gpx file into marble it often crashes. Since this doesn't always happen I suspect threading issues. If you can not reproduce try continuing to load different files, for me it happened with the 3. file at latest. Running it in gdb reduces the propability of a crash.

I'm copilling trunk, Revision 1075715.

 -- Backtrace:
Application: Marble-Schreibtischglobus (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1716e84750 (LWP 16424))]

Thread 3 (Thread 0x7f170642a910 (LWP 16426)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f1706429d20 in ?? ()
#2  0x00007fff7bf78782 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f17053e2910 (LWP 16442)):
#0  0x00007f1714e93d52 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f170f09e54a in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f170f09e8d0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f17152133f6 in QEventDispatcherGlib::processEvents (this=0x886340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:409
#4  0x00007f17151e9712 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f17151e9ae4 in QEventLoop::exec (this=0x7f17053e2010, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f171510271b in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f171655e5a8 in Marble::FileStorageWatcher::run (this=0x8508b0) at /home/schmeisser/kde/src/marble/src/lib/FileStorageWatcher.cpp:400
#8  0x00007f1715105485 in QThreadPrivate::start (arg=0x8508b0) at thread/qthread_unix.cpp:188
#9  0x00007f1714e9165d in start_thread () from /lib64/libpthread.so.0
#10 0x00007f17118e614d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1716e84750 (LWP 16424)):
[KCrash Handler]
#4  QSortFilterProxyModelPrivate::proxy_to_source (this=0x89bdc0, proxy_index=...) at itemviews/qsortfilterproxymodel.cpp:320
#5  0x00007f17149da12d in QSortFilterProxyModel::mapToSource (this=<value optimized out>, proxyIndex=...) at itemviews/qsortfilterproxymodel.cpp:2383
#6  0x00007f17149d3c36 in QSortFilterProxyModel::data (this=0x89bdc0, index=..., role=0) at itemviews/qsortfilterproxymodel.cpp:1608
#7  0x00007f17164fd491 in QModelIndex::data (this=<value optimized out>, arole=<value optimized out>) at /usr/include/QtCore/qabstractitemmodel.h:378
#8  0x00007f17165483cb in Marble::VisiblePlacemark::symbolPixmap (this=0x32914e0) at /home/schmeisser/kde/src/marble/src/lib/VisiblePlacemark.cpp:41
#9  0x00007f171654c040 in Marble::PlacemarkLayout::whichPlacemarkAt (this=<value optimized out>, curpos=...) at /home/schmeisser/kde/src/marble/src/lib/PlacemarkLayout.cpp:139
#10 0x00007f17164ff331 in Marble::MarbleModel::whichFeatureAt (this=<value optimized out>, curpos=...) at /home/schmeisser/kde/src/marble/src/lib/MarbleModel.cpp:743
#11 0x00007f1716516de8 in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0x8b54f0, o=<value optimized out>, e=<value optimized out>)
    at /home/schmeisser/kde/src/marble/src/lib/MarbleWidgetInputHandler.cpp:577
#12 0x00007f17151ea127 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x8ef0c0, event=0x7fff7be2cf60) at kernel/qcoreapplication.cpp:726
#13 0x00007f171449a27c in QApplicationPrivate::notify_helper (this=0x686110, receiver=0x8ef0c0, e=0x7fff7be2cf60) at kernel/qapplication.cpp:4061
#14 0x00007f17144a13c1 in QApplication::notify (this=<value optimized out>, receiver=0x8ef0c0, e=0x7fff7be2cf60) at kernel/qapplication.cpp:3767
#15 0x00007f1715b68f26 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#16 0x00007f17151eaddc in QCoreApplication::notifyInternal (this=0x7fff7be2ee60, receiver=0x8ef0c0, event=0x7fff7be2cf60) at kernel/qcoreapplication.cpp:610
#17 0x00007f17144a0c90 in sendSpontaneousEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:216
#18 QApplicationPrivate::sendMouseEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qapplication.cpp:2924
#19 0x00007f1714506cfe in QETWidget::translateMouseEvent (this=0x7dc3e0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4409
#20 0x00007f1714505d9a in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff7be2ea90) at kernel/qapplication_x11.cpp:3550
#21 0x00007f171452db6c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#22 0x00007f170f09adde in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f170f09e7a8 in ?? () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f170f09e8d0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f17152133a3 in QEventDispatcherGlib::processEvents (this=0x661d10, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#26 0x00007f171452d31e in QGuiEventDispatcherGlib::processEvents (this=0x1dd, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007f17151e9712 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f17151e9ae4 in QEventLoop::exec (this=0x7fff7be2edc0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f17151ebc99 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x00000000004153d5 in main (argc=<value optimized out>, argv=<value optimized out>) at /home/schmeisser/kde/src/marble/src/kdemain.cpp:293

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-18 01:33:50 UTC
This could be related to bug 193824. Regards
Comment 2 Dennis Nienhüser 2010-01-27 21:45:02 UTC

*** This bug has been marked as a duplicate of bug 193824 ***