Bug 219851

Summary: KNotify4 crashes on start (Xine accessing SMB, libsmbclient failing on malloc()) (related to bug 215532)
Product: [Frameworks and Libraries] Phonon Reporter: gabilari
Component: Xine backendAssignee: Matthias Kretz <kretz>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra, mannequinZOD, martin.sandsmark
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description gabilari 2009-12-23 17:41:28 UTC
Application that crashed: knotify4
Version of the application: 4.0
KDE Version: 4.3.1 (KDE 4.3.1) "release 6"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.5-0.1-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

 -- Backtrace:
Application: KNotify (knotify4), signal: Aborted
[Current thread is 1 (Thread 0x7f7daedf1750 (LWP 1579))]

Thread 9 (Thread 0x7f7d9dbdd910 (LWP 1757)):
#0  0x00007f7dac2432cd in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7da4161621 in metronom_sync_loop () from /usr/lib64/libxine.so.1
#2  0x00007f7dac23e65d in start_thread () from /lib64/libpthread.so.0
#3  0x00007f7dac77d14d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f7d9be53910 (LWP 1761)):
[KCrash Handler]
#5  0x00007f7dac6de4e5 in raise () from /lib64/libc.so.6
#6  0x00007f7dac6df9b0 in abort () from /lib64/libc.so.6
#7  0x00007f7dac71966d in ?? () from /lib64/libc.so.6
#8  0x00007f7dac71ec76 in ?? () from /lib64/libc.so.6
#9  0x00007f7dac721d0e in ?? () from /lib64/libc.so.6
#10 0x00007f7dac723a59 in malloc () from /lib64/libc.so.6
#11 0x00007f7dac79322b in __vasprintf_chk () from /lib64/libc.so.6
#12 0x00007f7d94c62b29 in vasprintf (__ap=<value optimized out>, __fmt=<value optimized out>, __ptr=<value optimized out>) at /usr/include/bits/stdio2.h:199
#13 dbgtext (__ap=<value optimized out>, __fmt=<value optimized out>, __ptr=<value optimized out>) at lib/debug.c:1087
#14 0x00007f7d94c65a94 in load_interfaces () at lib/interface.c:526
#15 0x00007f7d94c1e44f in smbc_init_context (context=0xde9a40) at libsmb/libsmb_context.c:518
#16 0x00007f7d94c1e031 in smbc_init (fn=0x7f7d952b1080 <smb_auth>, debug=<value optimized out>) at libsmb/libsmb_compat.c:129
#17 0x00007f7d952b10aa in init_input_class () from /usr/lib64/xine/plugins/1.27/xineplug_inp_smb.so
#18 0x00007f7da41655dc in _load_plugin_class () from /usr/lib64/libxine.so.1
#19 0x00007f7da4168761 in _x_find_input_plugin () from /usr/lib64/libxine.so.1
#20 0x00007f7da415ef02 in xine_open () from /usr/lib64/libxine.so.1
#21 0x00007f7da43c1aad in Phonon::MediaSource::type() const () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#22 0x00007f7da43c3a6c in Phonon::MediaSource::type() const () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#23 0x00007f7daceb32ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#24 0x00007f7daceba57e in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#25 0x00007f7dae8158d6 in KApplication::notify (this=0x7fff2aaf5670, receiver=0x75ec80, event=0x731850) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#26 0x00007f7dad9e7ddc in QCoreApplication::notifyInternal (this=0x7fff2aaf5670, receiver=0x75ec80, event=0x731850) at kernel/qcoreapplication.cpp:610
#27 0x00007f7dad9e89ea in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:213
#28 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.cpp:1247
#29 0x00007f7dada10803 in sendPostedEvents () at kernel/qcoreapplication.h:218
#30 postEventSourceDispatch () at kernel/qeventdispatcher_glib.cpp:276
#31 0x00007f7da99c5dde in g_main_dispatch (context=<value optimized out>) at gmain.c:1960
#32 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
#33 0x00007f7da99c97a8 in g_main_context_iterate (context=0x761470, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#34 0x00007f7da99c98d0 in IA__g_main_context_iteration (context=0x761470, may_block=1) at gmain.c:2654
#35 0x00007f7dada103a3 in QEventDispatcherGlib::processEvents (this=0x761cf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#36 0x00007f7dad9e6712 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#37 0x00007f7dad9e6ae4 in QEventLoop::exec (this=0x7f7d9be53000, flags=) at kernel/qeventloop.cpp:201
#38 0x00007f7dad8ff71b in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#39 0x00007f7da43bc3f4 in Phonon::MediaSource::type() const () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#40 0x00007f7dad902485 in QThreadPrivate::start (arg=0x6fddc0) at thread/qthread_unix.cpp:188
#41 0x00007f7dac23e65d in start_thread () from /lib64/libpthread.so.0
#42 0x00007f7dac77d14d in clone () from /lib64/libc.so.6
#43 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f7d9b448910 (LWP 1784)):
#0  0x00007f7dac774033 in poll () from /lib64/libc.so.6
#1  0x00007f7d9b44ec4e in ao_alsa_handle_event_thread () from /usr/lib64/xine/plugins/1.27/xineplug_ao_out_alsa.so
#2  0x00007f7dac23e65d in start_thread () from /lib64/libpthread.so.0
#3  0x00007f7dac77d14d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f7d9ac47910 (LWP 1785)):
#0  0x00007f7dac243049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7da4172673 in ao_loop () from /usr/lib64/libxine.so.1
#2  0x00007f7dac23e65d in start_thread () from /lib64/libpthread.so.0
#3  0x00007f7dac77d14d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f7d99e21910 (LWP 1786)):
#0  0x00007f7dac2432cd in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7da416ce19 in interruptable_sleep () from /usr/lib64/libxine.so.1
#2  0x00007f7da416f581 in video_out_loop () from /usr/lib64/libxine.so.1
#3  0x00007f7dac23e65d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f7dac77d14d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f7d99237910 (LWP 1787)):
#0  0x00007f7dac243049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7da4164eeb in fifo_buffer_get () from /usr/lib64/libxine.so.1
#2  0x00007f7da416af7d in video_decoder_loop () from /usr/lib64/libxine.so.1
#3  0x00007f7dac23e65d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f7dac77d14d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f7d98869910 (LWP 1788)):
#0  0x00007f7dac243049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7da4164eeb in fifo_buffer_get () from /usr/lib64/libxine.so.1
#2  0x00007f7da416c005 in audio_decoder_loop () from /usr/lib64/libxine.so.1
#3  0x00007f7dac23e65d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f7dac77d14d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7d98068910 (LWP 1789)):
#0  0x00007f7dac243049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7da417573b in xine_event_wait () from /usr/lib64/libxine.so.1
#2  0x00007f7da41757ae in listener_loop () from /usr/lib64/libxine.so.1
#3  0x00007f7dac23e65d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f7dac77d14d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7daedf1750 (LWP 1579)):
#0  0x00007f7dac78a31e in ?? () from /lib64/libc.so.6
#1  0x00007f7dac725599 in ?? () from /lib64/libc.so.6
#2  0x00007f7dac723961 in free () from /lib64/libc.so.6
#3  0x00007f7dabb24be2 in process_responses (dpy=0x64c350, wait_for_first_event=<value optimized out>, current_error=<value optimized out>, current_request=0) at xcb_io.c:223
#4  0x00007f7dabb25547 in _XEventsQueued (dpy=0x64c350, mode=<value optimized out>) at xcb_io.c:256
#5  0x00007f7dabb0e24b in XEventsQueued (dpy=0x64c350, mode=2) at Pending.c:44
#6  0x00007f7dacf46547 in ?? () from /usr/lib64/libQtGui.so.4
#7  0x00007f7da99c8fca in IA__g_main_context_prepare (context=0x651520, priority=<value optimized out>) at gmain.c:2280
#8  0x00007f7da99c93a1 in g_main_context_iterate (context=0x651520, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2571
#9  0x00007f7da99c98d0 in IA__g_main_context_iteration (context=0x651520, may_block=1) at gmain.c:2654
#10 0x00007f7dada103f6 in QEventDispatcherGlib::processEvents (this=0x626230, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:409
#11 0x00007f7dacf4631e in ?? () from /usr/lib64/libQtGui.so.4
#12 0x00007f7dad9e6712 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#13 0x00007f7dad9e6ae4 in QEventLoop::exec (this=0x7fff2aaf5590, flags=) at kernel/qeventloop.cpp:201
#14 0x00007f7dad9e8c99 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#15 0x000000000040772f in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-23 18:04:35 UTC
This looks related to bug 215532 and some of its duplicates.
- Do you have some Samba/Windows share ? - Have you tried disabling it ?
- Is some process (may be knotify4) using too much memory ?
Regards
Comment 2 gabilari 2009-12-23 20:37:55 UTC
I have certainly enough memory. I have never done something about Samba/Windows. But I don't understand what it would 
be. 
Regards

----Urspr√ľngliche Nachricht----
Von: andresbajotierra@gmail.com
Datum: 23.12.2009 18:04
An: <gabilari@bluemail.ch>
Betreff: [Bug 219851] sudden crash, firefox and kile were in use. After Restart notice that KNotify4 had crashed, 
happened already over 5 times!


https://bugs.kde.org/show_bug.cgi?id=219851



Dario Andres <andresbajotierra@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |andresbajotierra@gmail.com




--- Comment #1 from Dario Andres <andresbajotierra gmail com>  2009-12-23 18:04:35 ---
This looks related to bug 215532 and some of its duplicates.
- Do you have some Samba/Windows share ? - Have you tried disabling it ?
- Is some process (may be knotify4) using too much memory ?
Regards
Comment 3 Dario Andres 2009-12-29 19:06:50 UTC
A full backtrace from some of the duplicates:
---
Thread 8 (Thread 0x7f9df7317910 (LWP 1788)):
[KCrash Handler]
#5  0x00007f9e07ba44e5 in raise (sig=<value optimized out>) at
../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007f9e07ba59b0 in abort () at abort.c:88
#7  0x00007f9e07bdf66d in __libc_message (do_abort=2, fmt=
    0x7f9df7315840 "-p 00000000 08:02 656265", ' ' <repeats 21 times>,
"/usr/lib/locale/de_DE.utf8/LC_TELEPHONE\n7f9e0a2e4000-7f9e0a2e5000 r--p
00000000 08:02 265486", ' ' <repeats 21 times>,
"/usr/lib/locale/de_DE.utf8/LC_MEASUREMENT\n"...) at
../sysdeps/unix/sysv/linux/libc_fatal.c:170
#8  0x00007f9e07be4c76 in malloc_printerr (action=3, str=0x7f9e07c91a52
"malloc(): memory corruption", ptr=<value optimized out>) at malloc.c:6239
#9  0x00007f9e07be7d0e in _int_malloc (av=0x7f9e07ec8e60, bytes=<value
optimized out>) at malloc.c:4383
#10 0x00007f9e07be9a59 in __libc_malloc (bytes=100) at malloc.c:3660
#11 0x00007f9e07c5922b in __vasprintf_chk (result_ptr=0x7f9df73161b8,
flags=1788, format=0x6 <Address 0x6 out of bounds>, args=0xffffffffffffffff) at
vasprintf_chk.c:50
#12 0x00007f9df0126b29 in vasprintf (__ap=<value optimized out>, __fmt=<value
optimized out>, __ptr=<value optimized out>) at /usr/include/bits/stdio2.h:199
#13 dbgtext (__ap=<value optimized out>, __fmt=<value optimized out>,
__ptr=<value optimized out>) at lib/debug.c:1087
#14 0x00007f9df0129a94 in load_interfaces () at lib/interface.c:526
#15 0x00007f9df00e244f in smbc_init_context (context=0xde9c30) at
libsmb/libsmb_context.c:518
#16 0x00007f9df00e2031 in smbc_init (fn=0x7f9df0775080 <smb_auth>, debug=<value
optimized out>) at libsmb/libsmb_compat.c:129
#17 0x00007f9df07750aa in init_input_class () from
/usr/lib64/xine/plugins/1.27/xineplug_inp_smb.so
#18 0x00007f9dff6295dc in _load_plugin_class () from /usr/lib64/libxine.so.1
#19 0x00007f9dff62c761 in _x_find_input_plugin () from /usr/lib64/libxine.so.1
#20 0x00007f9dff622f02 in xine_open () from /usr/lib64/libxine.so.1
#21 0x00007f9dff885aad in Phonon::Xine::XineStream::xineOpen (this=0x700c90,
newstate=StoppedState) at /usr/src/debug/phonon-4.3.1/xine/xinestream.cpp:262
#22 0x00007f9dff887a6c in Phonon::Xine::XineStream::event (this=0x700c90,
ev=0x7591b0) at /usr/src/debug/phonon-4.3.1/xine/xinestream.cpp:1255
#23 0x00007f9e083792ac in QApplicationPrivate::notify_helper(QObject*, QEvent*)
() from /usr/lib64/libQtGui.so.4
Comment 4 Dario Andres 2009-12-29 19:07:28 UTC
*** Bug 220539 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2009-12-29 19:07:31 UTC
*** Bug 220474 has been marked as a duplicate of this bug. ***
Comment 6 Dario Andres 2009-12-30 17:05:55 UTC
This is likely to be an OpenSuse issue...
Comment 7 Christoph Feck 2009-12-31 14:31:30 UTC
*** Bug 220799 has been marked as a duplicate of this bug. ***
Comment 8 Myriam Schweingruber 2010-02-10 00:01:46 UTC

*** This bug has been marked as a duplicate of bug 215532 ***