Bug 217045

Summary: after failed attempts to rename a directory, then copy the directory -> crash
Product: [Plasma] plasma4 Reporter: birki456
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: asraniel
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description birki456 2009-12-02 11:14:05 UTC
Version:           plasma version 0.3 as reported by "plasma-desktop --version" (using KDE 4.3.1)
OS:                Linux
Installed from:    openSUSE RPMs

i'm using folder view.
steps to reproduce:
 1 create a directory and place it at the bottom of the desktop so that if you right-click it the menu opens above the mouse position.
 2 open a window, place it above the directory that you created so that if you right-click your directory, the menu is displayed above the window you opened
 3 right click the directory and select "rename". The file will flicker into rename-mode for a fraction of a second then abort the rename (note: you might have to enable window-focus catching on-mouseover, my settings: 500ms delay to bring window to front, no delay for window activation).
 4 after repeating steps 2-3 several times, move your window so that you can rename the file, then rename it.
 5 then drag your directory into the window (which was konqueror in my example), select "move here"
 6 -> crash (not always..)

expected behaviour: be able to use right-click->rename even if a window steals the focus because it is directly below it and set to auto-focus; don't crash (randomly)

Backtrace:
Application: Plasma-Arbeitsfläche (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f866386a750 (LWP 5239))]

Thread 2 (Thread 0x7f8643ce4910 (LWP 5243)):
#0  0x00007f866303e049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f86632ae53b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f865f7879ec in ?? () from /usr/lib64/libQtNetwork.so.4
#3  0x00007f86632ad485 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f866303965d in start_thread () from /lib64/libpthread.so.0
#5  0x00007f8660a4d14d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f866386a750 (LWP 5239)):
[KCrash Handler]
#5  0x00007f86622a7c23 in KFileItem::isDir() const () from /usr/lib64/libkio.so.5
#6  0x00007f86622956e8 in ?? () from /usr/lib64/libkio.so.5
#7  0x00007f86622965fb in ?? () from /usr/lib64/libkio.so.5
#8  0x00007f86622980d2 in KDirModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkio.so.5
#9  0x00007f86633a7fbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#10 0x00007f866227bda5 in KDirLister::itemsDeleted(KFileItemList const&) () from /usr/lib64/libkio.so.5
#11 0x00007f866227cae1 in KDirLister::Private::emitItemsDeleted(KFileItemList const&) () from /usr/lib64/libkio.so.5
#12 0x00007f866228babe in ?? () from /usr/lib64/libkio.so.5
#13 0x00007f866228d51a in ?? () from /usr/lib64/libkio.so.5
#14 0x00007f866228d9a4 in ?? () from /usr/lib64/libkio.so.5
#15 0x00007f866228e300 in ?? () from /usr/lib64/libkio.so.5
#16 0x00007f86633a7fbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#17 0x00007f8662299665 in OrgKdeKDirNotifyInterface::FilesRemoved(QStringList const&) () from /usr/lib64/libkio.so.5
#18 0x00007f86622997e0 in OrgKdeKDirNotifyInterface::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkio.so.5
#19 0x00007f865f4bcb78 in ?? () from /usr/lib64/libQtDBus.so.4
#20 0x00007f865f4c416f in ?? () from /usr/lib64/libQtDBus.so.4
#21 0x00007f86633a22d9 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#22 0x00007f86611832ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#23 0x00007f866118a57e in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#24 0x00007f8661d7d8d6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#25 0x00007f8663392ddc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#26 0x00007f86633939ea in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#27 0x00007f86633bb803 in ?? () from /usr/lib64/libQtCore.so.4
#28 0x00007f86600ccdde in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#29 0x00007f86600d07a8 in ?? () from /usr/lib64/libglib-2.0.so.0
#30 0x00007f86600d08d0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f86633bb3a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#32 0x00007f866121631e in ?? () from /usr/lib64/libQtGui.so.4
#33 0x00007f8663391712 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#34 0x00007f8663391ae4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#35 0x00007f8663393c99 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#36 0x00007f8657936d6f in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#37 0x0000000000406f88 in _start ()
Comment 1 Beat Wolf 2010-01-02 18:40:08 UTC

*** This bug has been marked as a duplicate of bug 196695 ***