Bug 215402

Summary: playlist layout editor drag&drop broken in CZ locale
Product: amarok Reporter: Stan Holenda <stanislav.holenda>
Component: Playlist/Playlist Layout EditorAssignee: Amarok Developers <amarok-bugs-dist>
Status: RESOLVED FIXED    
Severity: normal CC: ctibor.brancik, mkyral, nhn, teo, tulak.dan, wirthmi
Priority: NOR    
Version: 2.4-GIT   
Target Milestone: 2.4.0   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In: 2.6

Description Stan Holenda 2009-11-20 11:47:25 UTC
Version:            (using KDE 4.3.3)
OS:                Linux
Installed from:    Archlinux Packages

Description:
Can't drag & drop any items in Playlist Layout Editor. Always get "not allowed" icon, when trying to drop. The issue is also described in this forum:

http://forum.kde.org/viewtopic.php?f=115&t=82657

Note that this is due to locale settings (Czech in my case). If I start amarok with default EN locale, everything works as expected.

Steps to reproduce:
1. Run amarok with Czech (cs_CZ) locale
2. try dropping anything (Length, Comment, Rating, ...) into Header or Body in Playlist Layout Editor
Comment 1 Mikko C. 2009-11-20 11:53:00 UTC
you forgot to set amarok version.
Comment 2 Stan Holenda 2009-11-20 19:31:17 UTC
amarok2 Version 2.2.1
Using KDE 4.3.3 (KDE 4.3.3)
Comment 3 Myriam Schweingruber 2009-11-20 22:22:54 UTC
Hm, might be a problem in the translation files? Is it only the icon that is wrong or does the drop itself not work?
Comment 4 Stan Holenda 2009-11-20 23:00:43 UTC
The drop is broken. I can REMOVE any item(s) from Header, Body and Single sections, but dropping anything is not allowed. (i.e. after releasing mouse button cursor turns back to pointer and nothing gets dropped).
Comment 5 Michal Wirth 2010-01-06 13:29:29 UTC
Same problem occurs on my laptop (with Debian testing ... Amarok version 2.2.1 & KDE version 4.3.2). Starting Amarok with changed locales (using command: LANG=en_US amarok) solves this problem. I can layout the playlist then.
Comment 6 Myriam Schweingruber 2010-01-06 18:35:51 UTC
Setting status to confirmed. No idea what is particular about the CZ locale that triggers that, though.
Could you both please try with Amarok 2.2.2 final, to be released in a few days and report back?
Comment 7 Michal Wirth 2010-01-06 19:12:04 UTC
ok, i'll try it with 2.2.2 version ASAP, thanks
Comment 8 Michal Wirth 2010-01-12 15:10:58 UTC
I've just installed (from Debian's experimental branch) new Amarok 2.2.2. Now I'm using KDE 4.3.4.

Unfortunately, mentioned problem still exists in the current version of Amarok. Changing application's localization to US (from Menu or by setting LANG variable) solves this problem. The only problem in CZ mutation is adding new items into layout. Moving items within layout or removing items works just fine (at least for me).

Do you need any other informations?
Comment 9 Myriam Schweingruber 2010-01-12 16:15:06 UTC
This seems to be translation specific, reassigning.
Comment 10 Albert Astals Cid 2010-01-12 21:46:06 UTC
Yes, you should improve handling of i18n in your app.
Comment 11 Michal Wirth 2010-01-12 22:08:45 UTC
Sorry, but I've no idea how to do this. Can you help me? Can you tell me more specific instructions? Thanks ...
Comment 12 Myriam Schweingruber 2010-01-13 00:35:56 UTC
(In reply to comment #11)
> Sorry, but I've no idea how to do this. Can you help me? Can you tell me more
> specific instructions? Thanks ...

How to do what exactly? I did reassign the bug, they just sent it back.

Nikolaj, could you have a look at this, please?
Comment 13 Myriam Schweingruber 2010-02-07 14:25:54 UTC
Setting correct version and component.
Comment 14 Sven Krohlas 2010-03-21 19:48:01 UTC
reporter: Is this still a problem in 2.3.0?
Comment 15 Michal Wirth 2010-03-22 08:51:52 UTC
i'm running currently Amarok 2.3.0 and KDE 4.3.4 (again both are installed from Debian repositories) and i'm still experiencing the same problem, new version of Amarok did not fix that
Comment 16 Michal Wirth 2010-08-10 20:43:05 UTC
just for your information ... i've still problem with this in Amarok 2.3.1 @ KDE 4.4.3 installed from Debian repositories
Comment 17 tulak.dan 2010-08-18 14:04:16 UTC
Same problem like description, I found it with amarok 2.0.2 and now with Amarok 2.3.1 is always same problem, can't drag & drop any items in Playlist Layout Editor. Actualy KDE 4.5, (cs_CZ) locale.
Comment 18 Michal Wirth 2010-09-23 13:03:13 UTC
just for your information ... still the same problem with Amarok 2.3.2 @ KDE 4.4.5
Comment 19 tulak.dan 2011-05-16 18:59:29 UTC
just for your information ... i've still problem with this in Amarok 2.4.1 
KDE KDE 4.6.3 installed from Ubuntu repositories
Comment 20 Ctibor Brančík 2011-12-06 12:39:32 UTC
Long time Amarok user, but I have encountered this bug recently with Amarok 2.4.90 and KDE 4.7.80. I am on gentoo.
Comment 21 Matěj Laitl 2012-04-29 21:26:42 UTC
Git commit 1fc23fc0622b1970565051f132fdd8a813eb0c9f by Matěj Laitl.
Committed on 29/04/2012 at 23:12.
Pushed by laitl into branch 'master'.

Fix drag & drop in playlist layout editor, filter editor etc. in non-english locales

The implementation relies on custom mime-type specified in .ui files.
However, the strings weren't marked as non-translatable, so language
teams that decided to translate application/x-amarok-tag-token effectively
broke drag & drop for their users. (the blame goes to Amarok team, of
course)

Myriam, more than 2-year-old bug fixed in a couple of hours, don't you
like your GSoC student? :-)

BUGFIXES:
 * Fix drag & drop in playlist layout editor, filename layout editor,
   filter editor for non-english locales. (BR 215402)
FIXED-IN: 2.6

M  +2    -0    ChangeLog
M  +1    -1    src/dialogs/EditFilterDialog.ui
M  +1    -1    src/dialogs/FilenameLayoutDialog.ui
M  +1    -1    src/playlist/layouts/PlaylistLayoutEditDialog.ui

http://commits.kde.org/amarok/1fc23fc0622b1970565051f132fdd8a813eb0c9f
Comment 22 Stan Holenda 2012-04-29 23:18:34 UTC
Heh, dobra prace...:D

Skoda, ze treba ja uz skoro 2 roky spokojene pouzivam Clementine.

-------- Původní zpráva -------
Od: Matěj Laitl <matej@laitl.cz>
Komu: stanislav.holenda@tiscali.cz
Předmět: [Bug 215402] playlist layout editor drag&drop broken in CZ locale
Datum: 29.04.2012 23:50
---------------------------------------
> https://bugs.kde.org/show_bug.cgi?id=215402
> 
> Matěj Laitl <matej@laitl.cz> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|NEW                         |RESOLVED
>    Version Fixed In|                            |2.6
>          Resolution|---                         |FIXED
>       Latest Commit|                            |http://commits.kde.org/amar
>                    |                            |ok/1fc23fc0622b1970565051f1
>                    |                            |32fdd8a813eb0c9f
> 
> --- Comment #21 from Matěj Laitl <matej@laitl.cz> ---
> Git commit 1fc23fc0622b1970565051f132fdd8a813eb0c9f by Matěj Laitl.
> Committed on 29/04/2012 at 23:12.
> Pushed by laitl into branch 'master'
> 
> Fix drag & drop in playlist layout editor, filter editor etc in non-english
> locales
> 
> The implementation relies on custom mime-type specified in .ui files.
> However, the strings weren't marked as non-translatable, so language
> teams that decided to translate application/x-amarok-tag-token effectively
> broke drag & drop for their users. (the blame goes to Amarok team, of
> course)
> 
> Myriam, more than 2-year-old bug fixed in a couple of hours, don't you
> like your GSoC student? :-)
> 
> BUGFIXES:
>  * Fix drag & drop in playlist layout editor, filename layout editor,
>    filter editor for non-english locales. (BR 215402)
> FIXED-IN: 2.6
> 
> M  +2    -0    ChangeLog
> M  +1    -1    src/dialogs/EditFilterDialog.ui
> M  +1    -1    src/dialogs/FilenameLayoutDialog.ui
> M  +1    -1    src/playlist/layouts/PlaylistLayoutEditDialog.ui
> 
> http://commitskde.org/amarok/1fc23fc0622b1970565051f132fdd8a813eb0c9f
> 
> -- 
> You are receiving this mail because:
> You reported the bug.=