Bug 202869

Summary: Konqueror crashes after closing it with several tabs
Product: konqueror Reporter: Alexey Chernov <4ernov>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alexey Chernov 2009-08-06 22:09:37 UTC
Application that crashed: konqueror
Version of the application: 4.3.00 (KDE 4.3.0)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30 x86_64

What I was doing when the application crashed:
Konqueror crashes when closing its window with multiple tabs. Close dialog appeared, I've set "Don't show again" checkbox and pushed Quit. After this it crashed.

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
Using host libthread_db library "/lib/libthread_db.so.1".
[KCrash Handler]
#5  0x00007f210626799b in raise () from /lib/libc.so.6
#6  0x00007f2106268d4e in abort () from /lib/libc.so.6
#7  0x00007f2106260cef in __assert_fail () from /lib/libc.so.6
#8  0x00007f20f355c15f in KHTMLGlobal::finalCheck () at /usr/src/packages/kde4/4.3.0/kdelibs-4.3.0/khtml/khtml_global.cpp:258
#9  0x00007f20f1c39796 in ~KHTMLFactory (this=0x1cbea60) at /usr/src/packages/kde4/4.3.0/kdelibs-4.3.0/khtml/khtml_factory.cpp:35
#10 0x00007f2109477c54 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x1cb32a0}, end={i = 0x1971970}) at /usr/include/QtCore/qalgorithms.h:350
#11 0x00007f2109477c9d in qDeleteAll<FactoryHash> (c=@0x1ca9d20) at /usr/include/QtCore/qalgorithms.h:358
#12 0x00007f2109477eb3 in ~FactoryHash (this=0x1ca9d20) at /usr/src/packages/kde4/4.3.0/kdelibs-4.3.0/kdecore/util/klibrary.cpp:93
#13 0x00007f2109476e19 in destroy () at /usr/src/packages/kde4/4.3.0/kdelibs-4.3.0/kdecore/util/klibrary.cpp:97
#14 0x00007f210934f1e5 in ~KCleanUpGlobalStatic (this=0x7f21097395c0) at /usr/src/packages/kde4/4.3.0/kdelibs-4.3.0/kdecore/kernel/kglobal.h:62
#15 0x00007f210626a389 in exit () from /lib/libc.so.6
#16 0x00000000004075b8 in launch (argc=2, _name=0x18e5608 "/usr/bin/konqueror", args=0x18e5624 "", cwd=0x0, envc=0, envs=0x18e562c "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x18e5634 "aclex;1249588801;906988;6646_TIME24624906") at /usr/src/packages/kde4/4.3.0/kdelibs-4.3.0/kinit/kinit.cpp:676
#17 0x0000000000407dd3 in handle_launcher_request (sock=7, who=0x40b904 "launcher") at /usr/src/packages/kde4/4.3.0/kdelibs-4.3.0/kinit/kinit.cpp:1168
#18 0x0000000000408713 in handle_requests (waitForPid=0) at /usr/src/packages/kde4/4.3.0/kdelibs-4.3.0/kinit/kinit.cpp:1361
#19 0x0000000000409070 in main (argc=2, argv=0x7fff1d1299b8, envp=0x7fff1d1299d0) at /usr/src/packages/kde4/4.3.0/kdelibs-4.3.0/kinit/kinit.cpp:1788

Reported using DrKonqi
Comment 1 Alexey Chernov 2009-08-06 22:11:10 UTC
UPD: it happens on every closing, not necessary with tabs. every time.
Comment 2 Dario Andres 2009-08-07 19:43:39 UTC
Merging with bug 151453. Thanks

*** This bug has been marked as a duplicate of bug 151453 ***