Bug 191372

Summary: Konqueror bypasses tor/privoxy when DNS resolving
Product: konqueror Reporter: Christian Apeltauer <christian.apeltauer>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: adawit, aspotashev
Priority: NOR    
Version: 4.2.2   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Christian Apeltauer 2009-05-02 20:01:48 UTC
Version:            (using KDE 4.2.2)
Compiler:          gcc (Gentoo 4.3.3-r2 p1.1, pie-10.1.5) 4.3.3
 
OS:                Linux
Installed from:    Gentoo Packages

I use Konqueror with a combination of privoxy/tor as http proxy. While other browsers (Firefox 3.0.10; Arora 0.6; links 2.2) with the same proxy configuration resolve DNS names via privoxy/tor, konqueror resolves domain names via the DNS servers listed in /etc/resolv.conf.
If I make all entries in /etc/resolv.conf invalid (so that regular domain name resolution does not work any more on my system), konqueror is still able to connect to web pages via privoxy/tor. That is name resulotion via privoxy/tor works for konqueror, but is not use normally.
If I start konqueror via tsocks (that is
$ tsocks konqueror
) the DNS leak does not appear.
Comment 1 Christian Apeltauer 2009-05-02 20:16:30 UTC
Just in case: Rediecting http traffic via privoxy/tor works; there's no problem that my proxy setting are generally ignored.
Comment 2 Dawit Alemayehu 2011-05-07 08:57:56 UTC
See comment #1 at bug# 207550 and the discussion at bug# 162600 after it was re-opened.
Comment 3 Dawit Alemayehu 2011-05-28 03:44:40 UTC

*** This bug has been marked as a duplicate of bug 207550 ***