Bug 189420

Summary: klipper actions are not triggered if the url is copied into the clipboard in Firefox
Product: klipper Reporter: m.wege
Component: generalAssignee: Esben Mose Hansen <kde>
Status: RESOLVED NOT A BUG    
Severity: normal CC: dimsuz, karaluh, mail
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Unspecified   
Latest Commit: Version Fixed In:

Description m.wege 2009-04-12 01:46:14 UTC
Version:            (using KDE 4.2.2)
Installed from:    Ubuntu Packages

klipper actions are not triggered if the url is copied into the clipboard in Firfox. Means: When I copy an url into the clippboard, klipper actions are not triggered like it happens when I do the same elsewher ein KDe
Comment 1 m.wege 2009-04-13 22:44:02 UTC
I can confirm this.
Comment 2 Sebastian Sauer 2009-07-13 01:02:06 UTC
Probably result of http://www.qtsoftware.com/developer/task-tracker/index_html?method=entry&id=250555 which is fixed in Qt 4.6.0
Comment 3 karaluh 2009-08-11 14:17:55 UTC
For the record it doesn't work properly in konqueror too.
Comment 4 Esben Mose Hansen 2009-09-22 14:10:43 UTC
It is because actions has been explicitly disabled for those apps. To reenable it, go to Klipper->Configure->Actions->Advanced and remove the apps in question.

Please confirm :)
Comment 5 karaluh 2009-09-22 14:39:52 UTC
The fix does seem to work for konqueror, but not for firefox.
Comment 6 Esben Mose Hansen 2009-09-22 15:51:46 UTC
I just tested it, and it works fine for me. Using xprop, I get the following WM_CLASS for firefox (well, iceweasel here)

WM_CLASS(STRING) = "Navigator", "Iceweasel"

Iceweasel was not on the list, but Navigator was. Removing Navigator from the list made the action list popup when copying a link. 

Does this not work for you? 

(Resetting status, didn't me to close it before)
Comment 7 karaluh 2009-09-23 08:42:40 UTC
Yes, "Navigator" removal did the trick. Why are actions for those apps disabled by default?
Comment 8 Esben Mose Hansen 2009-09-23 13:07:38 UTC
Because these apps selects the web address when you click on the address bar, I think, thus triggering the actions under certain circumstances.

In this case, Klipper works as coded, and I don't believe there is a better solution.
Comment 9 m.wege 2009-09-23 16:59:53 UTC
Does this mean general fix of this bug depends on having qt 4.6? Are there any packages ready for that?
Comment 10 Esben Mose Hansen 2009-09-23 19:07:51 UTC
@m.wege: No, the "fix" is to configure Klipper to accept Firefox/Konqueror for actions, by removing them from the blacklist under Actions->Advanced. For firefox, remove Navigator, too. The problem here is that some people want behaviour A and some B and A&B are incompatible.

Now, if someone tells me that "actions should only be blocked for selection, not clipboard"... fine, we can implement that no problem. I think.