Bug 186930

Summary: KWrite can't open files with non-English characters in names (probably a regression)
Product: kdelibs Reporter: Danila Sentiabov <dsent.zen>
Component: generalAssignee: kdelibs bugs <kdelibs-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: echidnaman, konst.hex
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Danila Sentiabov 2009-03-12 09:30:48 UTC
Version:           4.2.1 (using KDE 4.2.1)
OS:                Linux
Installed from:    SuSE RPMs

First of all, sorry for the wrong "program" field. This bug affects many KDE programs (I can confirm Kate, Kwrite and Okular). I just didn't find an item named "General problem" so I've selected a random application affected by the bug.

After one of recent updates (maybe Qt update to 4.5.0), Kwrite and kate refuse to open files with Russian names because of strange encoding conversion (UTF-8 encoded name is treated as ISO-8859-1). Kwrite opens up a empty file with name like "ÑеÑÑ.txt" instead of "тест.txt" (Okular shows a error message "file not found").

Locale settings don't matter. On my machine all locale variables set to "en_US.UTF-8" except for LC_CTYPE which is set to "ru_RU.UTF-8". I tried setting all to "en_US.UTF-8" and "ru_RU.UTF-8" with no success.

This happens only if I open files by clicking in Dolphin or Krusader (or via "Open with"). Opening with other programs (OpenOffice.org, Kate/Kwrite from KDE3) works as usual. Opening through "Open file" menu item in Kate/Kwrite works. Opening via F3 in Krusader (which uses Katepart) works.

Everything worked OK with KDE 4.1.3 and 4.2.0 (with Qt 4.4).
Comment 1 Matthew Woehlke 2009-03-12 17:03:03 UTC
"General problems" are usually problems in kdelibs. This in particular sounds like a problem with how applications are being launched, probably how we do "%u" encoding.
Comment 2 Konstantin Kucher 2009-03-12 21:13:38 UTC
This is perhaps the most disturbing bug for users who have non-Latin directory/file names.

I can confirm this bug with at least these programs: Dolphin, Konqueror, Kate, KWrite, Gwenview, Umbrello. At the same time such Qt4-based programs as Smplayer and Avidemux work flawlessly. So it is definitely KDE4 libs bug.
Comment 3 Marian Kyral 2009-03-12 21:41:47 UTC
All known issues with KDE 4.2.1 and Qt 4.5 were already solved: https://bugs.kde.org/show_bug.cgi?id=186038
Comment 4 Jonathan Thomas 2009-03-13 01:02:58 UTC

*** This bug has been marked as a duplicate of bug 186038 ***