Bug 186798

Summary: encoding broken for qt 4.5.0 (not rc)
Product: kdelibs Reporter: Konstantin <ria.freelander>
Component: generalAssignee: kdelibs bugs <kdelibs-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: echidnaman
Priority: NOR    
Version: 4.2   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Broken encoding in systemsettings window
Dolphin sent incorrect filename to Gwenview
Konqueror opened file correctly
Test file (which cause bug)

Description Konstantin 2009-03-10 17:54:17 UTC
Version:           неизвестная (using 4.2.1 (KDE 4.2.1), Arch Linux)
Compiler:          gcc
OS:                Linux (i686) release 2.6.28-ARCH

If Qt builds with USE=iconv, then non-Latin encoding files cannot opened correctly, and systemsettings also sometimes contains a broken encoding
Comment 1 Konstantin 2009-03-10 17:54:56 UTC
qt dialogs works as well
Comment 2 Konstantin 2009-03-10 17:56:22 UTC
Created attachment 31999 [details]
Broken encoding in systemsettings window
Comment 3 Konstantin 2009-03-10 18:03:51 UTC
Created attachment 32001 [details]
Dolphin sent incorrect filename to Gwenview
Comment 4 Konstantin 2009-03-10 18:05:51 UTC
Created attachment 32002 [details]
Konqueror opened file correctly
Comment 5 Konstantin 2009-03-10 18:07:40 UTC
file in attachment 3 [details] is same than in attachment 2 [details]
Comment 6 Konstantin 2009-03-10 18:09:36 UTC
sorry for numbers. Testfile in attachment 31999 [details] and attachment 32002 [details] is same
Comment 7 Konstantin 2009-03-10 18:10:39 UTC
Created attachment 32004 [details]
Test file (which cause bug)
Comment 8 Konstantin 2009-03-10 18:18:59 UTC
Internal application dialogs and drag and drop works as well, bug causes only if Dolpin or Konqueror send filename to external KDE application
Comment 9 Jonathan Thomas 2009-03-10 21:30:09 UTC

*** This bug has been marked as a duplicate of bug 186038 ***