Bug 186246

Summary: Umlauts in directory name cause okular loading error
Product: kdelibs Reporter: Christopher Bräuer <christopher.m.braeuer>
Component: generalAssignee: kdelibs bugs <kdelibs-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: christopher.m.braeuer, echidnaman
Priority: NOR    
Version: 4.2   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Christopher Bräuer 2009-03-05 18:23:00 UTC
Version:           0.8.1 (using 4.2.1 (KDE 4.2.1) "release 108", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.27.7-9-default

I got a directory which was called "Präsentationen". When I wanted to open a pdf-document with okular, an error was show, that it could not open the document.
When I renamed the directory to "Praesentationen", it worked.
Seems to be a bug in handling directorys with german Umlauts. I noticed that bug only in okular.
Comment 1 Pino Toscano 2009-03-05 18:32:35 UTC
Either kdelibs or Qt issue.
Comment 2 Brad Hards 2009-03-05 21:33:07 UTC
I tried to reproduce this, and couldn't.
[bradh@conferta ~]$ mkdir Präsentationen
[bradh@conferta ~]$ cp specs/Ecma\ TC45\ OOXML\ Standard\ -\ Draft\ 1.3.pdf Präsentationen/

It then opened fine both on the command line and using the File->Open dialog:
[bradh@conferta ~]$ okular Präsentationen/Ecma\ TC45\ OOXML\ Standard\ -\ Draft\ 1.3.pdf
okular(6273): Attempt to use QAction "bookmark_action_0" with KXMLGUIFactory!
[bradh@conferta ~]$ okular
okular(6281): Attempt to use QAction "bookmark_action_0" with KXMLGUIFactory!
Comment 3 Christopher Bräuer 2009-03-06 11:58:43 UTC
This is strange. I also tried both of the ways you did, Brad. I got the same output on the console "Attempt to use QAction "bookmark_action_0" with KXMLGUIFactory!" but when the directory name includes the umlauts, it does not open the document. But no error is show on the console, only a KDE-Dialog.
I use ext3 as filesystem, could this be the reason?
When it is a kdelibs or Qt issue, like Pino wrote, how can I check this out? Until now, only okular has shown this error.
Comment 4 Jonathan Thomas 2009-03-06 16:56:01 UTC

*** This bug has been marked as a duplicate of bug 186038 ***