Bug 184989

Summary: crash on close (assertion failed: "!s_refcnt" in khtml_global.cpp)
Product: konqueror Reporter: Marcel Partap <mpartap>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: frank78ac
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Marcel Partap 2009-02-20 02:23:10 UTC
Version:           4.2.63 (KDE 4.2.63 (KDE 4.3 >= 20090212)) (using 4.2.63 (KDE 4.2.63 (KDE 4.3 >= 20090212)), Gentoo)
Compiler:          x86_64-pc-linux-gnu-gcc
OS:                Linux (x86_64) release 2.6.28-gentoo-r2

Well this has been happening since some time so reporting it this time :)
It does not happen always but after opening many tabs, closing them one by one (which only frees little memory, much less than allocated in the first place). Finally closing the window crashes producing following bt:

Application: Konqueror (konqueror), signal SIGABRT
0x00007f8fe12f8901 in nanosleep () from /lib/libc.so.6
Current language:  auto; currently c
[Current thread is 0 (LWP 18550)]

Thread 2 (Thread 0x7f8fcaacf950 (LWP 21137)):
#0  0x00007f8fe1322682 in select () from /lib/libc.so.6
#1  0x00007f8fe3d77095 in QProcessManager::run (this=0x61e9b0) at io/qprocess_unix.cpp:300
#2  0x00007f8fe3cb6a89 in QThreadPrivate::start (arg=0x61e9b0) at thread/qthread_unix.cpp:184
#3  0x00007f8fe3a42007 in start_thread () from /lib/libpthread.so.0
#4  0x00007f8fe1328f7d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8fe670c750 (LWP 18550)):
[KCrash Handler]
#5  0x00007f8fe128b1e5 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007f8fe128c703 in *__GI_abort () at abort.c:88
#7  0x00007f8fe1284229 in *__GI___assert_fail (assertion=0x7f8fd899a9e1 "!s_refcnt", file=0x7f8fd899a938 "/mnt/sda3/var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/khtml/khtml_global.cpp", 
    line=258, function=0x7f8fd899ab60 "static void KHTMLGlobal::finalCheck()") at assert.c:78
#8  0x00007f8fd8677312 in KHTMLGlobal::finalCheck () at /mnt/sda3/var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/khtml/khtml_global.cpp:258
#9  0x00007f8fd11a7855 in ~KHTMLFactory (this=0x52cac80) at /mnt/sda3/var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/khtml/khtml_factory.cpp:35
#10 0x00007f8fe4470021 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x52d6120}, end={i = 0x4ff34e0}) at /usr/include/qt4/QtCore/qalgorithms.h:345
#11 0x00007f8fe4470249 in ~FactoryHash (this=0x4876) at /mnt/sda3/var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/kdecore/util/klibrary.cpp:93
#12 0x00007f8fe446f392 in destroy () at /mnt/sda3/var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/kdecore/util/klibrary.cpp:97
#13 0x00007f8fe128dd8d in *__GI_exit (status=0) at exit.c:75
#14 0x00007f8fe12775cd in __libc_start_main (main=0x4009d0 <main>, argc=1, ubp_av=0x7fffee763688, init=0x400a00 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fffee763678) at libc-start.c:258
#15 0x0000000000400909 in _start () at ../sysdeps/x86_64/elf/start.S:113
Comment 1 Frank Reininghaus 2009-02-20 03:09:41 UTC
Thanks for the bug report! Probably a duplicate of bug 151453. Please reopen if I'm wrong...

*** This bug has been marked as a duplicate of bug 151453 ***