Bug 184261

Summary: Kate session name encoding error when opened with "Kate Session Applet" Plasmoid
Product: plasma4 Reporter: Matija Šuklje <matija>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Matija Šuklje 2009-02-13 23:31:28 UTC
Version:           3.2.0 (using KDE 4.2.0)
OS:                Linux
Installed from:    Gentoo Packages

I'm using UTF-8 encoding in locale and also in KDE settings, yet I still get this problem. I suspect it's a problem with the "Kate Session Applet" Plasmoid, because using Kate's own session management works as expected.

Steps of reproduction:
1) Open Kate
2) Save a session using non-ASCII characters in its name (e.g. "Članki")
3) Close Kate
4) Click on the "Kate Session Applet" Plasmoid and select that session

Results:
* It opens up an empty session with wrongly encoded name (e.g. "Älanki")
* Even if you don't save that new faulty session, it shows in the Kate session list (in the Plasmoid and Kate itself)

Extra "fun": Now open the new wrongly saved Kate session from the Plasmoid (e.g. "Älanki") — the result is that an even more garbled session opens up (e.g. "ÃÂlanki"). You can do this pretty much ad infinitum (e.g. "Članki" -> "Älanki" -> "ÃÂlanki" -> "ÃÂÃÂlanki" -> "ÃÂÃÂÃÂÃÂÃÂÃÂÃÂÃÂlanki" -> ...)

Expected results:
* Just opening the session using the appropriate encoding

P.S. This is similar to Bug #140929, but I'm opening it as a new bug, because now the Kate Session Applet is a Plasmoid and not a Kicker widget.
Comment 1 Matija Šuklje 2009-02-18 18:39:30 UTC
The same happens when using the Kate Sessions KRunner.
Comment 2 Matija Šuklje 2009-03-08 22:56:22 UTC
Te bug still persists in KDE 4.2.1 (Gentoo sources).
Comment 3 Matija Šuklje 2009-03-28 14:24:08 UTC

*** This bug has been marked as a duplicate of bug 186038 ***