Bug 184112

Summary: Konqueror crash after end of download
Product: konqueror Reporter: Carlos Alvarado <charles_del_cch_naucalpan>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Carlos Alvarado 2009-02-12 07:25:59 UTC
Version:           4.2.00 (using KDE 4.2.0)
Compiler:          cmake 2.6.2 
OS:                Linux
Installed from:    Compiled From Sources

I read in the list of bugs, an other similar bugs but this is in Konqueror of KDE 4.2.00 and the crash occur after closing de the windows of Konqueror, but with a download in curse, using a new tool used in KDE 4.2.0, but when finishing  the download, the windows of backtrace was opened inicating a crash of Konqueror

this is the backtrace:

Aplicación: Konqueror (konqueror), señal SIGABRT
[?1034h[Thread debugging using libthread_db enabled]
[Current thread is 1 (Thread 0xb5e91700 (LWP 19127))]

Thread 2 (Thread 0xb13aab90 (LWP 19389)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb64e2411 in select () from /lib/libc.so.6
#2  0xb725ddc7 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb718e85e in ?? () from /usr/lib/libQtCore.so.4
#4  0xb712c1b5 in start_thread () from /lib/libpthread.so.0
#5  0xb64e93be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5e91700 (LWP 19127)):
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb6442990 in raise () from /lib/libc.so.6
#8  0xb64442c8 in abort () from /lib/libc.so.6
#9  0xb643b78e in __assert_fail () from /lib/libc.so.6
#10 0xb3c1e277 in KHTMLGlobal::finalCheck () at /opt/kde/src/kdelibs-4.2.0/khtml/khtml_global.cpp:258
#11 0xb1c91330 in ~KHTMLFactory (this=0x8b700f0) at /opt/kde/src/kdelibs-4.2.0/khtml/khtml_factory.cpp:35
#12 0xb75bcb87 in destroy () at /usr/include/QtCore/qalgorithms.h:346
#13 0xb745c9ab in ~KCleanUpGlobalStatic (this=0xb7614144) at /opt/kde/src/kdelibs-4.2.0/kdecore/kernel/kglobal.h:62
#14 0xb64459b1 in exit () from /lib/libc.so.6
#15 0xb642e70d in __libc_start_main () from /lib/libc.so.6
#16 0x080486c1 in _start () at ../sysdeps/i386/elf/start.S:119
Comment 1 Maksim Orlovich 2009-02-21 23:20:20 UTC

*** This bug has been marked as a duplicate of bug 151453 ***