Bug 181074

Summary: with high processing ktorrent crash
Product: ktorrent Reporter: Juliano Timm <juliano.timm>
Component: generalAssignee: Joris Guisson <joris.guisson>
Status: RESOLVED DUPLICATE    
Severity: normal CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Juliano Timm 2009-01-17 15:35:20 UTC
Version:           3.1.2 (using 4.1.3 (KDE 4.1.3), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.27-9-generic

This occurred twice. A while installing the updates of the kubuntu packages and another when my computer was slow. I'm downloading files in the following file systems: ext3, NTFS, FAT32, and reiserfs. I am downloading torrents and 24 seed of 42. I hope help.



Aplicativo: KTorrent (ktorrent), sinal SIGSEGV
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5dc46c0 (LWP 5909)]
[New Thread 0xb0f0ab90 (LWP 6039)]
[New Thread 0xb4485b90 (LWP 6038)]
[KCrash handler]
#6  0xb7be53de in ?? () from /usr/lib/libbtcore.so.7
#7  0xb70f94bd in ?? () from /usr/lib/libQtGui.so.4
#8  0xb70f95a3 in QSortFilterProxyModel::mapFromSource ()
   from /usr/lib/libQtGui.so.4
#9  0xb70f31f2 in QSortFilterProxyModel::parent () from /usr/lib/libQtGui.so.4
#10 0xb70aa568 in QTreeView::indexRowSizeHint () from /usr/lib/libQtGui.so.4
#11 0xb70aac62 in ?? () from /usr/lib/libQtGui.so.4
#12 0xb70afc6a in QTreeView::verticalOffset () from /usr/lib/libQtGui.so.4
#13 0xb7078540 in ?? () from /usr/lib/libQtGui.so.4
#14 0xb6bfd490 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#15 0xb6bfd8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#16 0xb6bfd7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#17 0xb6bfd7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#18 0xb6bfd7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#19 0xb6bfcd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#20 0xb6bfd8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#21 0xb6bfcd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#22 0xb6bfd8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#23 0xb6bfd7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#24 0xb6bfcd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#25 0xb6bfd8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#26 0xb6bfcd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#27 0xb6bfd8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#28 0xb6bfcd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#29 0xb6bfd8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#30 0xb6bfd7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#31 0xb6bfd7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#32 0xb6bfcd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#33 0xb6bfd8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#34 0xb6bfcd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#35 0xb6bfd8b2 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#36 0xb6bfd7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#37 0xb6bfd7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#38 0xb6bfd7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#39 0xb6bfd7be in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#40 0xb6bfcd88 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#41 0xb6d6cfae in ?? () from /usr/lib/libQtGui.so.4
#42 0xb6d6d4a7 in ?? () from /usr/lib/libQtGui.so.4
#43 0xb6bfe576 in QWidget::event () from /usr/lib/libQtGui.so.4
#44 0xb6f52517 in QMainWindow::event () from /usr/lib/libQtGui.so.4
#45 0xb7ac6958 in KMainWindow::event (this=0x8599248, ev=0x9bcba30)
    at /build/buildd/kde4libs-4.1.3/kdeui/widgets/kmainwindow.cpp:1073
#46 0xb7b0a15c in KXmlGuiWindow::event (this=0x8599248, ev=0x9bcba30)
    at /build/buildd/kde4libs-4.1.3/kdeui/xmlgui/kxmlguiwindow.cpp:133
#47 0xb6ba68ec in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#48 0xb6bae7fa in QApplication::notify () from /usr/lib/libQtGui.so.4
#49 0xb79f4b2d in KApplication::notify (this=0xbf9be14c, receiver=0x8599248, 
    event=0x9bcba30)
    at /build/buildd/kde4libs-4.1.3/kdeui/kernel/kapplication.cpp:311
#50 0xb74b5e61 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#51 0xb74b6ae5 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#52 0xb74b6cdd in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#53 0xb74e082f in ?? () from /usr/lib/libQtCore.so.4
#54 0xb61a26f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#55 0xb61a5da3 in ?? () from /usr/lib/libglib-2.0.so.0
#56 0xb61a5f61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#57 0xb74e0478 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#58 0xb6c40ea5 in ?? () from /usr/lib/libQtGui.so.4
#59 0xb74b452a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#60 0xb74b46ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#61 0xb74b6da5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#62 0xb6ba6767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#63 0x0806441b in _start ()
#0  0xb7fbe430 in __kernel_vsyscall ()
Comment 1 Dario Andres 2009-01-17 23:03:32 UTC
Please, the fix should be in the 3.1.5 version. Thanks :)

*** This bug has been marked as a duplicate of bug 172198 ***