Bug 180738

Summary: Email drag&drop is not unfolding folders
Product: kmail Reporter: Jurian Sluiman <subscribe>
Component: new folder treeAssignee: Szymon Stefanek <pragma>
Status: RESOLVED DUPLICATE    
Severity: wishlist CC: coucouf, kde
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Unspecified   
Latest Commit: Version Fixed In:

Description Jurian Sluiman 2009-01-14 22:59:15 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Already posted on the kdepim-users list, but here a copy/paste of the message:

I thought Kmail used to open the folder when I drag an email to it. Now it doesn't anymore. Is there a reason? I couldn't find a preference for it, so I'm asking it here.
 

Next, if it's going to reimplemented, I have a feature request. ;)
 I have many folders and always unfolded some, but not all of them. It was really annoying if I dragged an email towards a folder, the folder unfolded and stayed unfolded. I'd rather see the folders, which expanded on hover, will fold again when drag&drop is finished. Is this possible?
Comment 1 Thomas McGuire 2009-01-20 14:26:04 UTC
Actually, folder unfolding was disabled because it did both collapsing and expanding, and I tried dragging mails around, and because of collapsing folders, it became really difficult, because it all scrolls and jumps a lot.
Unfortunately, Qt provides no way to only expand folders on hover, but not collapse them.
Comment 2 Aurélien COUDERC 2009-02-22 14:55:43 UTC
This bug is a duplicate of bug 179711.
Comment 3 Christophe Giboudeaux 2009-11-18 22:02:03 UTC

*** This bug has been marked as a duplicate of bug 179711 ***