Bug 179690

Summary: PNG gamma correction doesn't work (bug 61829)
Product: kdelibs Reporter: Arseny Solokha <asolokha>
Component: kimgioAssignee: kdelibs bugs <kdelibs-bugs>
Status: RESOLVED UPSTREAM    
Severity: normal CC: andresbajotierra, sami
Priority: NOR    
Version: 4.1   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Arseny Solokha 2009-01-05 09:39:11 UTC
Version:            (using KDE 4.1.3)
Compiler:          gcc 4.3.2 
OS:                Linux
Installed from:    Gentoo Packages

In fact this bug is duplicate for bug 61829.
There are no differences between images from http://www.christian-seiler.de/temp/gamma.html with any KDE application, while left image should be much brighter.

The following information may be useless, but:
this bug is also reproducible with feh 1.3.4 and showimage that comes with sdl-image 1.2.7;
this bug is not reproducible with display that comes with 6.4.5.

Let me know if I should file this bug in Qt's bugzilla.
Comment 1 Arseny Solokha 2009-01-05 09:41:15 UTC
(In reply to comment #0)
> with display that comes with 6.4.5.

"display" that comes with ImageMagick 6.4.5.
Comment 2 Dario Andres 2009-05-17 01:44:46 UTC
Here using:

Qt: 4.5.1 (qt-copy  958974)
KDE: 4.2.86 (KDE 4.2.86 (KDE 4.3 >= 20090514))
kdelibs svn rev. 968443 / kdebase svn rev. 968445
on ArchLinux i686 - Kernel 2.6.29.3

I can confirm that the bug is still present. Thanks
Comment 3 Arseny Solokha 2009-05-17 09:56:39 UTC
I'm not so sure now that my bug report is correct. I've just tested it with Arora, light-weight Qt-based browser (arora-browser.org), and it shows no differences too. So problem seems to be Qt-specific.

Qt 4.5.1, Arora 0.6.1, both installed from Gentoo Portage.
Comment 4 Dario Andres 2009-05-31 01:09:12 UTC
OK, I just sent a new report request to the QtSoftware tracker. I will post the bug number if they accept it. Regards
Comment 5 Dario Andres 2009-06-08 14:09:52 UTC
Ok, they sent me the confirmation email: The track number is "Issue N255492".
They still need to check the bug.

Regards
Comment 6 Christoph Feck 2009-12-09 20:53:26 UTC
http://bugreports.qt.nokia.com/browse/QTBUG-4266
Comment 7 Sami Boukortt 2013-06-11 19:44:16 UTC
New URL for the upstream report: https://bugreports.qt-project.org/browse/QTBUG-4266