Bug 177429

Summary: kTorrent message - a fatal error occurred
Product: ktorrent Reporter: Vince Radice <computerpro>
Component: generalAssignee: Joris Guisson <joris.guisson>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Vince Radice 2008-12-10 22:36:06 UTC
Version:            (using KDE 4.1.3)
OS:                Linux
Installed from:    I Don't Know

Vince Radice
I was downloading Fedora 10 and kTorrent crashed

Output from KDE Crash Handler

Application: KTorrent (ktorrent), signal SIGSEGV
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb80be770 (LWP 2683)]
[New Thread 0xb5c23b90 (LWP 2691)]
[New Thread 0xb684ab90 (LWP 2690)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x01455c8a in ?? () from /usr/lib/libQtGui.so.4
#7  0x01455d73 in QSortFilterProxyModel::mapFromSource ()
   from /usr/lib/libQtGui.so.4
#8  0x0144fa42 in QSortFilterProxyModel::parent () from /usr/lib/libQtGui.so.4
#9  0x01406c14 in QTreeView::indexRowSizeHint () from /usr/lib/libQtGui.so.4
#10 0x01407342 in ?? () from /usr/lib/libQtGui.so.4
#11 0x0140c35a in QTreeView::verticalOffset () from /usr/lib/libQtGui.so.4
#12 0x013d4b50 in ?? () from /usr/lib/libQtGui.so.4
#13 0x00f59d00 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#14 0x00f5a12c in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#15 0x00f5a032 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#16 0x00f5a032 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#17 0x00f595f8 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#18 0x00f5a12c in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#19 0x00f595f8 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#20 0x00f5a12c in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#21 0x00f595f8 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#22 0x00f5a12c in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#23 0x00f595f8 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#24 0x00f5a12c in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#25 0x00f595f8 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#26 0x00f5a12c in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#27 0x00f5a032 in QWidgetPrivate::paintSiblingsRecursive ()
   from /usr/lib/libQtGui.so.4
#28 0x00f595f8 in QWidgetPrivate::drawWidget () from /usr/lib/libQtGui.so.4
#29 0x010c87fe in ?? () from /usr/lib/libQtGui.so.4
#30 0x010c8cf7 in ?? () from /usr/lib/libQtGui.so.4
#31 0x00f5ade6 in QWidget::event () from /usr/lib/libQtGui.so.4
#32 0x012ae217 in QMainWindow::event () from /usr/lib/libQtGui.so.4
#33 0x04da7b78 in KMainWindow::event () from /usr/lib/libkdeui.so.5
#34 0x04de95bc in KXmlGuiWindow::event () from /usr/lib/libkdeui.so.5
#35 0x00f02f8c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#36 0x00f0aefa in QApplication::notify () from /usr/lib/libQtGui.so.4
#37 0x04ce289d in KApplication::notify () from /usr/lib/libkdeui.so.5
#38 0x005c5c51 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#39 0x005c68c5 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#40 0x005c6add in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#41 0x005f074f in ?? () from /usr/lib/libQtCore.so.4
#42 0x05273e38 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#43 0x052774e3 in ?? () from /lib/libglib-2.0.so.0
#44 0x052776a1 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#45 0x005f0398 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#46 0x00f9c105 in ?? () from /usr/lib/libQtGui.so.4
#47 0x005c433a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#48 0x005c44fa in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#49 0x005c6ba5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#50 0x00f02e07 in QApplication::exec () from /usr/lib/libQtGui.so.4
#51 0x08062231 in _start ()
Comment 1 Joris Guisson 2008-12-11 08:10:08 UTC
Dupe

*** This bug has been marked as a duplicate of bug 172198 ***