Bug 174884

Summary: kwin chrashed on kde logout
Product: [Plasma] kwin Reporter: albert <alberthilbert>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Unspecified   
Latest Commit: Version Fixed In:

Description albert 2008-11-11 17:48:56 UTC
Version:            (using KDE 4.1.2)
Installed from:    Ubuntu Packages

kwin chrashed on kde logout.
The backtrace is:

Applicazione: KWin (kwin), segnale SIGSEGV
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb65266c0 (LWP 5215)]
[KCrash handler]
#6  0xb71226f4 in ?? () from /usr/lib/libQtGui.so.4
#7  0xb71231bd in ?? () from /usr/lib/libQtGui.so.4
#8  0xb71179ed in QPixmap::deref () from /usr/lib/libQtGui.so.4
#9  0xb711a2b0 in QPixmap::~QPixmap () from /usr/lib/libQtGui.so.4
#10 0xb4ec88cf in ?? () from /usr/lib/kde4/kwin3_ozone.so
#11 0xb4ec8b15 in ?? () from /usr/lib/kde4/kwin3_ozone.so
#12 0xb4ecb36b in ?? () from /usr/lib/kde4/kwin3_ozone.so
#13 0xb7de5d69 in exit () from /lib/tls/i686/cmov/libc.so.6
#14 0xb791c501 in _IceDefaultIOErrorHandler () from /usr/lib/libICE.so.6
#15 0xb7924273 in _IceWrite () from /usr/lib/libICE.so.6
#16 0xb79242b2 in IceFlush () from /usr/lib/libICE.so.6
#17 0xb79312b1 in SmcCloseConnection () from /usr/lib/libSM.so.6
#18 0xb70af47a in QSessionManager::~QSessionManager ()
   from /usr/lib/libQtGui.so.4
#19 0xb705a927 in QApplication::~QApplication () from /usr/lib/libQtGui.so.4
#20 0xb6c8c36e in ~KApplication (this=0xbfff2114)
    at /build/buildd/kde4libs-4.1.2/kdeui/kernel/kapplication.cpp:955
#21 0xb7f49c0e in ?? () from /usr/lib/libkdeinit4_kwin.so
#22 0xb7f4d927 in kdemain () from /usr/lib/libkdeinit4_kwin.so
#23 0x080485a2 in _start ()
#0  0xb7ff2430 in __kernel_vsyscall ()
Comment 1 Pino Toscano 2008-11-11 21:46:25 UTC
Hi albert,

unfortunately, the backtrace you posted is not much useful.
You can get a more detailed one by following the instructions on the following page:
http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports

Thanks!
Comment 2 lucas 2008-11-12 03:15:31 UTC

*** This bug has been marked as a duplicate of bug 163538 ***