Bug 174588

Summary: application KTorrent (ktorrent) crashed and caused signal 11 (SIGSEGV)
Product: ktorrent Reporter: Elijah J. Riedlinger <psiberstorm>
Component: generalAssignee: Joris Guisson <joris.guisson>
Status: RESOLVED DUPLICATE    
Severity: crash CC: ppiermario, zohn.joidberg
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: crash report

Description Elijah J. Riedlinger 2008-11-08 00:50:35 UTC
Version:            (using KDE 4.1.2)
OS:                Linux
Installed from:    I Don't Know

I just upgraded to Mandriva 2009.0 last night...  I tried running the new version of ktorrent today...  KTorrent loaded all my former torrents from my old version of ktorrent (nearly 170 of them of various sizes) and recreated a few formerly completed torrents that I had formerly deleted to clear up some disk space...  Then the main ktorrent window came up showing which torrents it was processing...  I left that window up on top for a few minutes as I was reviewing the torrents...  Then I proceeded to remove one or two columns (like leachers) from the download tab and re-order the columns...  When I moved the seeders column to the left, it went too far (to the complete left), so I attempted to drag it to the right, then ktorrent crashed...  I don't know what SIGSEGV means, but I suspect the problem may be linked to not enough disk space to complete downloading all torrents and/or not enough memory to process all the torrents...  It would be better if torrents be automatically stopped or not started than for ktorrent to crash if it runs out of disk space or memory...
Comment 1 Joris Guisson 2008-11-08 10:50:10 UTC
Version ? Have you got a backtrace ?

This has nothing to do with diskspace or memory, it is probably a Qt bug, which we have already found a workaround for.

Comment 2 Joris Guisson 2008-11-14 14:01:19 UTC
This is a dupe of 172198

*** This bug has been marked as a duplicate of bug 172198 ***
Comment 3 zohn.joidberg 2009-04-24 14:50:28 UTC
Created attachment 33060 [details]
crash report
Comment 4 zohn.joidberg 2009-04-24 14:51:11 UTC
Same problem for me on OpenSUSE 11.1 with KDE v3.5.10 and ktorrent v3.1.5.

I attached the crash handler info.