Bug 171642

Summary: Clicking on systray icon does not show/hide the main window
Product: [Applications] akregator Reporter: András Manţia <amantia>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Severity: normal CC: alex.merry, droebuck, gekylafas, krishna.ggk, mattia.milleri, rasasi78, schwarzer, uwolfer, wrar, zeratul
Priority: NOR    
Version: SVN   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Toggles the Akregator::Part visibility between hide and show when system tray icon is clicked.
Toggles the Akregator::Part visibility between hide and show when system tray icon is clicked.

Description András Manţia 2008-09-25 10:32:24 UTC
Summary tells it all. Happens since a few days in trunk.
Comment 1 Urs Wolfer 2008-10-02 20:24:56 UTC
*** Bug 172039 has been marked as a duplicate of this bug. ***
Comment 2 Gopala Krishna A 2008-10-09 16:58:23 UTC
Created attachment 27761 [details]
Toggles the Akregator::Part visibility between hide and show when system tray icon is clicked.

This is my first ever patch to akregator, so please correct me if something is wrong.

This patch adds a new slot called slotToggleVisibility to MainWindow and is invoked on signal toggleShowPart from Akregator::Part.

Note: showPart is refactored to toggleShowPart everywhere to reflect this change.
Comment 3 Gopala Krishna A 2008-10-09 17:02:42 UTC
Created attachment 27764 [details]
Toggles the Akregator::Part visibility between hide and show when system tray icon is clicked.

Also renamed TrayIcon showPart signal as toggleShowPart.
This patch is btw, wrt to the trunk (revision #869633)
Comment 4 Gopala Krishna A 2008-10-09 17:14:43 UTC
Added me to cc list (sorry for 3 separate mails)
Comment 5 Urs Wolfer 2008-10-09 20:02:47 UTC
Patch looks good to me.
Comment 6 Urs Wolfer 2008-10-12 12:12:07 UTC
SVN commit 870288 by uwolfer:

Fix: Clicking on systray icon does not show/hide the main window.
Patch by Gopala Krishna A.
(Not needed to backport to 4.1, as it is not broken there IIRC.)

 M  +1 -1      akregator_part.cpp
 M  +1 -1      akregator_part.h
 M  +7 -2      mainwindow.cpp
 M  +1 -0      mainwindow.h
 M  +2 -2      trayicon.cpp
 M  +1 -1      trayicon.h
Comment 7 Andrey Rakhmatullin 2008-10-12 12:14:36 UTC
It IS broken in 4.1.2 because of r864309
Comment 8 Urs Wolfer 2008-10-12 12:43:10 UTC
I do not feel comfortable to backport, because the patch does not cleanly apply to 4.1 branch and I cannot try build.

Alex: you have committed r864309 which broke things according to comment above. Could you please check?
Comment 9 Alex Merry 2008-10-12 12:54:24 UTC
winterz backported my fix (r860909) from trunk (which was really only half a fix - it makes the tray icon show the window, but not hide it, and this is what Gopala Krishna A changed).  So I can't really comment on what it does to the branch, other than that it will probably prevent Akregator from being hidden by clicking the tray icon if it worked before.
Comment 10 Andrey Rakhmatullin 2008-10-12 12:58:23 UTC
Akregator from 4.1.2 shows the window when clicking, but doesn't hide it. I thought this bug is entirely about this behavior.
Comment 11 Alex Merry 2008-10-13 20:23:51 UTC
It's not obvious from the title, and the report is no help (hint to submitter: please include "what it does" and "what you expect it to do" in the report).

If it worked properly before r864309, it should be reverted.  If not, r870288 (ie: the patch attached to this bug) should be backported.  I don't have any way of testing which scenario is true.
Comment 12 Γιώργος Κυλάφας (Giorgos Kylafas) 2008-10-21 00:12:32 UTC
There is relevant report in Kubuntu about the branch bug: https://bugs.launchpad.net/ubuntu/+source/kdepim/+bug/276880
Comment 13 Urs Wolfer 2008-10-22 19:37:24 UTC
SVN commit 874882 by uwolfer:

Revert r864309, which was not necessary to backport (breaks things as confirmed multiple times; please retest now)

 M  +0 -2      mainwindow.cpp  

WebSVN link: http://websvn.kde.org/?view=rev&revision=874882
Comment 14 Andrey Rakhmatullin 2008-11-11 21:21:58 UTC
Verified for 4.1.3.
Comment 15 Darryl 2008-11-14 08:42:07 UTC
I'm using 4.1.3, clicking on the icon still doesn't show or hide, but I can  right click and I can fetch, configure or quit. I read that it's fixed for kubuntu (https://bugs.launchpad.net/ubuntu/+source/kdepim/+bug/276880), but I'm currently using opensuse. 
Comment 16 Mark Purcell 2009-04-19 12:30:47 UTC
Also seen in Debian
Comment 17 Mattia Milleri 2009-04-23 18:16:05 UTC
KDE Version 	1.4.2 (KDE 4.2.2 (KDE 4.2.2), Kubuntu packages)
Application 	KDE feed aggregator
Operating System 	Linux (i686) release 2.6.28-11-generic
Compiler 	cc

I can still report this happening with the new Kubuntu 9.04 release.