Bug 171447

Summary: Konqueror crashes when closed via KWin's "X" in the window bar, not via Strg-Q
Product: konqueror Reporter: Andreas Hermann Braml <andreas>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: h.habighorst, maksim
Priority: NOR    
Version: 4.1.1   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Unspecified   
Latest Commit: Version Fixed In:

Description Andreas Hermann Braml 2008-09-22 13:40:56 UTC
Version:            (using KDE 4.1.1)
Installed from:    Ubuntu Packages

When I visit, ironically, http://www.workswithu.com/2008/09/21/attention-microsoft-im-a-pc-running-ubuntu-linux/ , Konqueror crashes when I close it with the "X" in the Window bar after the page has finished loading. It doesn't crash when closed via Strg-Q resp. clicking File->Quit.

Reproducible: Always

I use the PPA packages for Hardy i386.

Backtrace:

Anwendung: Konqueror (konqueror), Signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb6015940 (LWP 6804)]
[New Thread 0xb215fb90 (LWP 7013)]
[KCrash handler]
#6  0xb7eee410 in __kernel_vsyscall ()
#7  0xb7cdd085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb7cdea01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb7cd610e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb4071032 in KHTMLGlobal::finalCheck ()
    at /build/buildd/kde4libs-4.1.1+really4.1.1/khtml/khtml_global.cpp:247
#11 0xb44501fc in ~KHTMLFactory (this=0x874d8f0)
    at /build/buildd/kde4libs-4.1.1+really4.1.1/khtml/khtml_factory.cpp:35
#12 0xb7439e4f in QObjectCleanupHandler::clear (this=0x865c560)
    at kernel/qobjectcleanuphandler.cpp:142
#13 0xb7439ec0 in ~QObjectCleanupHandler (this=0x865c560)
    at kernel/qobjectcleanuphandler.cpp:88
#14 0xb76b295d in destroy ()
    at /build/buildd/kde4libs-4.1.1+really4.1.1/kdecore/util/kpluginfactory.cpp:29
#15 0xb75a0d0b in ~KCleanUpGlobalStatic (this=0xb76e88f4)
    at /build/buildd/kde4libs-4.1.1+really4.1.1/kdecore/kernel/kglobal.h:67
#16 0xb7ce0084 in exit () from /lib/tls/i686/cmov/libc.so.6
#17 0xb7cc8458 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#18 0x080484f1 in _start ()
#0  0xb7eee410 in __kernel_vsyscall ()
Comment 1 H.Habighorst 2008-10-02 10:23:26 UTC
I cannot reproduce this on my 4.1.1 system ( Gentoo KDE Overlay ).

Tried opening it, then pressing the X button...

Also tried it with tabs opened / STRG + Q / File -> Exit.

So it could be something PPA specific.

Comment 2 Maksim Orlovich 2008-10-05 19:57:16 UTC

*** This bug has been marked as a duplicate of bug 151453 ***