Bug 171309

Summary: Kopete crashes while connecting to MSN in HTTP method
Product: [Applications] kopete Reporter: Andreas J. Gjellesvik <agjell>
Component: generalAssignee: Kopete Developers <kopete-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: finex, h.habighorst
Priority: NOR    
Version: 0.60.1   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Andreas J. Gjellesvik 2008-09-19 10:21:54 UTC
Version:           0.60.1 (using KDE 4.1.1)
Compiler:          Installed through adept in Kubuntu 
OS:                Linux
Installed from:    Ubuntu Packages

Brand new install of Kubuntu, upgraded to KDE 4.1.1. Just tried to connect to MSN using HTTP method. Normal method does not work at my work because of our firewall. Works fine in Pidgin.

Application: Kopete (kopete), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5963940 (LWP 6009)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7ef6410 in __kernel_vsyscall ()
#7  0xb63d0085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb63d1a01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb745b367 in qt_message_output () from /usr/lib/libQtCore.so.4
#10 0xb745b458 in qFatal () from /usr/lib/libQtCore.so.4
#11 0xb745b505 in qt_assert () from /usr/lib/libQtCore.so.4
#12 0xb3b7ebe0 in ?? () from /usr/lib/kde4/lib/libkopete_msn_shared.so.4
#13 0xb3b796c8 in MSNSocket::WebResponse::WebResponse ()
   from /usr/lib/kde4/lib/libkopete_msn_shared.so.4
#14 0xb3b7c61c in MSNSocket::slotDataReceived ()
   from /usr/lib/kde4/lib/libkopete_msn_shared.so.4
#15 0xb3b7e0fa in MSNSocket::qt_metacall ()
   from /usr/lib/kde4/lib/libkopete_msn_shared.so.4
#16 0xb3b8bb1a in ?? () from /usr/lib/kde4/lib/libkopete_msn_shared.so.4
#17 0xb7563f79 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#18 0xb7564642 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#19 0xb759f997 in QIODevice::readyRead () from /usr/lib/libQtCore.so.4
#20 0xb77e1286 in KNetwork::KClientSocketBase::slotReadActivity ()
   from /usr/lib/kde4/lib/libkdecore.so.5
#21 0xb77df899 in KNetwork::KBufferedSocket::slotReadActivity ()
   from /usr/lib/kde4/lib/libkdecore.so.5
#22 0xb77df446 in KNetwork::KBufferedSocket::qt_metacall ()
   from /usr/lib/kde4/lib/libkdecore.so.5
#23 0xb7563f79 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#24 0xb7564642 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#25 0xb75a16b3 in QSocketNotifier::activated () from /usr/lib/libQtCore.so.4
#26 0xb756a60f in QSocketNotifier::event () from /usr/lib/libQtCore.so.4
#27 0xb6a25f9c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#28 0xb6a2abf9 in QApplication::notify () from /usr/lib/libQtGui.so.4
#29 0xb7a3b1c3 in KApplication::notify () from /usr/lib/kde4/lib/libkdeui.so.5
#30 0xb754f0b9 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#31 0xb757a883 in ?? () from /usr/lib/libQtCore.so.4
#32 0xb5f39dd6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb5f3d193 in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb5f3d74e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb757a9f8 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#36 0xb6ab9a25 in ?? () from /usr/lib/libQtGui.so.4
#37 0xb754e33d in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#38 0xb754e4cd in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#39 0xb755074d in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#40 0xb6a25897 in QApplication::exec () from /usr/lib/libQtGui.so.4
#41 0x08087efb in ?? ()
#42 0xb63bb450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#43 0x080644b1 in _start ()
#0  0xb7ef6410 in __kernel_vsyscall ()
Comment 1 H.Habighorst 2008-09-28 17:03:41 UTC
On Gentoo with the Gentoo KDE Overlay it works...
Did the following steps ( ICQ and MSN Account ) :

1) Changed in the settings to override the standard server information and to use http.
2) Set everything to offline, and then online
- Nothing happens -
3) Quit the program and restarted it, going on, off, on and again offline.
- Nothing happens -

KDE 4.1.1 , Kopete 0.60.1 , GCC 4.3.2

Comment 2 FiNeX 2008-11-05 23:47:05 UTC

*** This bug has been marked as a duplicate of bug 153630 ***