Bug 165608

Summary: kopete crash on logout
Product: [Applications] kopete Reporter: Ritesh Raj Sarraf <kde-bugs>
Component: generalAssignee: Kopete Developers <kopete-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Debian testing   
OS: Linux   
Latest Commit: Version Fixed In:

Description Ritesh Raj Sarraf 2008-07-03 04:16:14 UTC
Version:            (using KDE 4.0.83)
Installed from:    Debian testing/unstable Packages
OS:                Linux

kopete crashed on logout of kde.
while this is not always reproducible, i'm filing the bug because i have the backtrace.
Comment 1 Ritesh Raj Sarraf 2008-07-03 04:17:33 UTC
Application: Kopete (kopete), signal SIGSEGV
Using host libthread_db library "/lib/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0xb5890940 (LWP 4643)]
[KCrash handler]
#6  0xb6816f5c in QX11PixmapData::release (this=0xaf38bf8)
    at image/qpixmap_x11.cpp:1181
#7  0xb6817a1d in ~QX11PixmapData (this=0xaf38bf8)
    at image/qpixmap_x11.cpp:1160
#8  0xb680c22d in QPixmap::deref (this=0xabb8410) at image/qpixmap.cpp:1260
#9  0xb680eae0 in ~QPixmap (this=0xabb8410) at image/qpixmap.cpp:321
#10 0xb7ec8a71 in ~OnlineStatusManager (this=0xb7f19d00)
    at /tmp/buildd/kdenetwork-4.0.84/kopete/libkopete/kopeteonlinestatusmanager.cpp:69
#11 0xb6363ef4 in exit () from /lib/i686/cmov/libc.so.6
#12 0xb6f4c424 in qt_message_output (msgType=QtFatalMsg, 
    buf=0xbf876470 "Fatal Error: Accessed global static 'KWalletDLauncher *walletLauncher()' after destruction. Defined at /tmp/buildd/kde4libs-4.0.84/kdeui/util/kwallet.cpp:128") at global/qglobal.cpp:2060
#13 0xb6f4c4f6 in qFatal (
    msg=0xb783e608 "Fatal Error: Accessed global static '%s *%s()' after destruction. Defined at %s:%d") at global/qglobal.cpp:2260
#14 0xb77775ec in operator-> (this=0xb7884370)
    at /tmp/buildd/kde4libs-4.0.84/kdeui/util/kwallet.cpp:128
#15 0xb777fd63 in ~Wallet (this=0x9c8e3b8)
    at /tmp/buildd/kde4libs-4.0.84/kdeui/util/kwallet.cpp:156
#16 0xb7ee64cb in Kopete::WalletManager::closeWallet (this=0xb7f19d68)
    at /tmp/buildd/kdenetwork-4.0.84/kopete/libkopete/kopetewalletmanager.cpp:167
#17 0xb7ee68a0 in ~WalletManager (this=0xb7f19d68)
    at /tmp/buildd/kdenetwork-4.0.84/kopete/libkopete/kopetewalletmanager.cpp:60
#18 0xb6363ef4 in exit () from /lib/i686/cmov/libc.so.6
#19 0xb5f1a391 in _IceDefaultIOErrorHandler () from /usr/lib/libICE.so.6
#20 0xb5f21c54 in _IceWrite () from /usr/lib/libICE.so.6
#21 0xb5f21c92 in IceFlush () from /usr/lib/libICE.so.6
#22 0xb5f2e1e1 in SmcCloseConnection () from /usr/lib/libSM.so.6
#23 0xb67a4aca in ~QSessionManager (this=0x979b230)
    at kernel/qapplication_x11.cpp:5421
#24 0xb67505f7 in ~QApplication (this=0xbf8787ac)
    at kernel/qapplication.cpp:1025
#25 0xb76f68ce in ~KApplication (this=0xbf8787ac)
    at /tmp/buildd/kde4libs-4.0.84/kdeui/kernel/kapplication.cpp:946
#26 0xb76fdf28 in ~KUniqueApplication (this=0xbf8787ac)
    at /tmp/buildd/kde4libs-4.0.84/kdeui/kernel/kuniqueapplication.cpp:358
#27 0x0808c1df in ~KopeteApplication (this=0xbf8787ac)
    at /tmp/buildd/kdenetwork-4.0.84/kopete/kopete/kopeteapplication.cpp:108
#28 0x0808aa89 in main (argc=3, argv=0xbf878b94)
    at /tmp/buildd/kdenetwork-4.0.84/kopete/kopete/main.cpp:102
#29 0xb634c450 in __libc_start_main () from /lib/i686/cmov/libc.so.6
#30 0x08063c71 in _start ()
#0  0xb7f5f424 in __kernel_vsyscall ()
Comment 2 Christophe Marin 2008-07-03 10:52:29 UTC

*** This bug has been marked as a duplicate of 165079 ***
Comment 3 Pino Toscano 2008-09-05 21:36:55 UTC
(Wrong DUPE bug, reopening and marking wrt the correct one.)
Comment 4 Pino Toscano 2008-09-05 21:37:08 UTC

*** This bug has been marked as a duplicate of bug 163538 ***