Bug 161009

Summary: Multi-key shortcuts are broken in KDE4
Product: [Applications] systemsettings Reporter: Vedran Furač <vedran.furac>
Component: kcm_keysAssignee: Michael Jansen <kde>
Severity: wishlist CC: 1i5t5.duncan, adam, ashark, bluedzins, etienne.hilson, kde, mail4ilia, mailto, mrudolf
Priority: NOR    
Version: 4.2.0   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Vedran Furač 2008-04-19 13:35:06 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Multi-key shortcuts does not work in KDE4. If I assign for example alt+space,x to some action, it is triggered on alt+space.
I also don't get that nice menu top left which lists multi-key shortcut after typing first part of a multi-key shortcut.
Comment 1 Vedran Furač 2008-07-23 15:05:58 UTC
Multi-key shortcuts actuality work in applications, but they do not work in khotkeys, kwin and other components. 
Comment 2 Bram Schoenmakers 2008-07-29 19:02:49 UTC
> Multi-key shortcuts actuality work in applications

How are they supposed to be entered then? I can't find a way to do this.
Comment 3 Vedran Furač 2008-07-29 20:22:36 UTC
For Ctrl+A,C: hold ctrl and press A and then C while holding Ctrl.
For A,B,C: just press them consecutively fast.
It's less intuitive then before, I know :-( 
Comment 4 Etienne Hilson 2008-12-01 12:41:15 UTC
Hi, I would like to have some information to be sure to understand correctly :

Single and Multi-key shortcuts are working only inside apps.
It means that we cannot "launch" an application using a multi shortcut ?

Will this functionality be added in the future ?

I was used with my CTRL-ALT-R + [A-Z] to launch all my apps, so now I must use my mouse... Eeeeeek ;-) 
Comment 5 Etienne Hilson 2008-12-01 12:48:02 UTC
Is the following behaviour linked to the same bug ?

I can now assign a single/multi-key shortcut to one menu element (application) (thank you for the multi-key one, because it is new for me) but it does not work neither.

I guess that it is the same problem : kwin does not catch it ?
Comment 6 xavy94 2008-12-29 10:57:54 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Michael Jansen 2009-02-05 00:50:08 UTC
@Etienne Hilson: kwin shortcuts are global shortcuts - always afaik

@all: global shortcuts can only be single shortcuts for now. with kde 4.2 you are no longer able to record a multi key shortcut because we can't support them - currently?.

@all: multi key application shortcuts should work nicely in kde 4.2 - shameless plug: http://michael-jansen.biz/blog/mike/2008-11-23/kde-42-changes-kkeysequencewidget .

So only the wish for multi key global shortcuts should be left from the initial bug report. right?

please reopen a wish for that one. i will close this bug if noone disagrees.

Comment 8 Vedran Furač 2009-02-05 02:08:58 UTC
Well, when I reported this I mostly had global shortcuts on my mind because I currently use multi key shortcuts only with global shortcuts. I don't see any sense in closing this and opening another one which would have only one word added in the title (Multi-key *global* shortcuts are broken in KDE4).

Also note this part:

"I also don't get that nice menu top left which lists multi-key shortcut after typing first part of a multi-key shortcut."
Comment 9 Michael Jansen 2009-02-16 01:13:19 UTC
*** Bug 182507 has been marked as a duplicate of this bug. ***
Comment 10 Duncan 2009-07-15 13:52:38 UTC
This is currently a blocker for kde4 migration for me.  I use khotkeys multi-key shortcuts HEAVILY in 3.5.  My only other alternative, which I'm investigating, would be switching to a non-kde hotkey applet.
Comment 11 L_V 2009-07-26 11:37:04 UTC
Just a comment: it seems KDE4 tries to reinvent the wheel for things which never raised any problem.
Developers usually love reinventing the wheel, much more than users.
Assigning the Meta key as shortcut is now a nightmare, sometimes works, sometimes not.
Sometimes needs "xmodmap -e 'keycode 133=Menu'" in .baschrc, sometimes not.
(Meta key was code 115, now 133, for the same keyboard, don't know why).
It's now time to nail down such basic issues, at least for people who expect to switch one day from KDE3 to KDE4.
Keyboard settings are spread in so different places that it became unmanagable, to not say unusable, unreliable.
(using KDE4.3RC3)
Comment 12 Duncan 2009-07-26 17:33:56 UTC
Re comment #10, FWIW, I worked around the blocker, at least temporarily, by remapping most of my multi-key sequentials to multi-key-modifiered (using meta as the modifier, since it's the one still generally free of application, etc usage).  But that's a workaround not a permanent solution.

Re comment #11:

Comment 7 says they are unable to support global multi-key, at least presently.  It doesn't say why, I wish it did, but it sounds to me like it's a qt issue and therefore the trolls (umm... nokies? LOL! Just realized that nick actually fits if qt4's the problem, no-keys!), in which case the KDE devs would have little to do with it except having to deal with the complaints due to the very real regression and its effects on people who really did actually use and depend on global multikey functionality on their kde desktop.

Regardless, the fact is it's still a regression from kde3.  Something worked.  Now it doesn't.  That's a regression.  And ther'e people that are going to consider kde4 broken until the feature works again as they've come to depend on, because until it's fixed, kde4 IS broken for those users in that regard, and no "I'm tired of hearing how broken kde4 is, let's all party and pretend it's working great", is going to fix it.  A case of the emperor has no clothes, anyone?

Meanwhile, on the meta key thing, if you upgraded to kde4 by upgrading distributions as most do (IOW, unliess you DID install kde4 on the same base platform including xorg that you had, previously, no updates, in particular no X updates or keyboard to evdev driver switches at the same time), the keycode remapping is very likely a combination of upstream xorg and your distribution switching to xorg's evdev driver from the previous keyboard driver.  Unfortunately, the evdev developer apparently had a serious case of not-invented-here and couldn't simply take the existing codes from the keyboard driver, so whenever distributions and their end users switch to evdev, it causes issues such as you mention.

Unfortunately that's not the first time X has broken keyboard mappings, either, especially for the "extra" keys common on media/internet/etc keyboards, which seem to get remapped or renamed in /some/ form or another, every few releases. Every time, I have to spend time finding a model name that xev and khotkeys actually detects the hotkeys on, all over again, then remapping all my hotkeys to the new names.  As you said, it's a nightmare, but that bit isn't kde's nightmare, and unlike kde4's entirely broken global multikey hotkeys,  with some reconfig it always works again.

Unfortunately, that still leaves people scrambling to find a workaround (because there's no fix anywhere in sight) to something that shouldn't have been a regression in the first place, at least not by the time kde4 was declared fit for normal usage, which with 4.2, it was.

So does anyone have any suggestions about non-kde solutions?  What about xbindkeys?  What about xhotkeys?  Others?

(FWIW, a google finds manpages for the above, which suggest that xhotkeys, like khotkeys4, only understands multiple-modifiers-single-key.  xbindkeys, OTOH, appears to be very extensible as it uses the guile scheme interpreter for scripted extensions.  I've not looked into it far enough yet to know whether that makes base configuration too complex for those who can at least manage an ordinary text config file, or not, but it does look like at least the ability to edit plain text config files will be needed for "non-trivial" actions such as (modifier)-double-click and timed-click mouse actions, or key combinations, as specifically mentioned in the manpage.)
Comment 13 Christoph Feck 2009-12-02 09:24:59 UTC
*** Bug 216369 has been marked as a duplicate of this bug. ***
Comment 14 mrudolf 2009-12-02 10:09:44 UTC
For me current behavior qualifies as a bug, not a wish: I am able to enter multiple key combination for global action, but it is lost when saving. This at least *looks* as a bug.
Comment 15 mrudolf 2009-12-08 09:14:01 UTC
I readded this as a wish: Bug 217833.
Comment 16 David Edmundson 2015-02-08 13:32:49 UTC

*** This bug has been marked as a duplicate of bug 217833 ***
Comment 17 Andrew Shark 2024-02-15 20:13:31 UTC

*** This bug has been marked as a duplicate of bug 480304 ***