Bug 155415

Summary: PRINT : white lines in preview and output
Product: digikam Reporter: hans de faber <hans.defaber>
Component: Plugin-Editor-PrintAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: anaselli, caulier.gilles, realdiskdoc
Priority: NOR    
Version: 3.4.0   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In: 4.3.0

Description hans de faber 2008-01-10 19:55:16 UTC
Version:           9.3 (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs
OS:                Linux

One or more (3) horizontal (landscape format) or vertical(portrait) white lines in the print preview and also in the printout. For a given combination picture/papersize the lines are always at the same position. If I take 1/2 size paper there are less lines and the first line is at a lower position in the picture.
Comment 1 hans de faber 2008-01-10 20:47:56 UTC
Pictures are 9.1 Mpixel.
Large papersizes (a4) have always lines.
Small papersizes 10x15cm have sometimes lines.
Comment 2 caulier.gilles 2008-01-10 21:14:03 UTC
Hans,

Are you print from image editor or from PrintWizzard kipi plugin ?

Gilles Caulier
Comment 3 hans de faber 2008-01-10 22:08:12 UTC
Gilles Caulier schreef::
[bugs.kde.org quoted mail]
No I don't use the printwizard.
I print from within the image editor ( File, Print Image)
Most of the time I want borderless printouts, the printwizzard has only some
predefined picturesizes.
Comment 4 Angelo Naselli 2008-01-10 23:51:29 UTC
> Most of the time I want borderless printouts, the printwizzard has only some
> predefined picturesizes.

But it can print bordless, if you use a hp printer you must set fullbleed mode
from driver settings though.
Comment 5 hans de faber 2008-01-11 10:42:39 UTC
printing with the printwizzard or from within the image editor give both white lines. No difference.
Comment 6 Angelo Naselli 2008-01-12 14:01:21 UTC
Just out of curiosity, which is your printer? 
Comment 7 hans de faber 2008-01-13 09:54:14 UTC
Angelo Naselli schreef::
[bugs.kde.org quoted mail]
Canon IP3300 (because it has easy refillable cartridges and good printquality)
The printer (not supported) is used is mainly used with Turboprint.
Additional I have a printque configured as "canon bjc7100 cups+gutenprint v5.01
Simplified" for this printer.
If I select this config (the supported bjc7100) I get also white lines.
You see I deed some investigation to figure out if the problem is inside or
outside digikam.
Have a nice day,Hans
Comment 8 Angelo Naselli 2008-01-13 15:29:36 UTC
> You see I deed some investigation to figure out if the problem is inside or
> outside digikam.

No doubt ;) I'm trying to understand what happens though :)
Can you please try to print forcing the driver to the maximum dpi your printer 
can have configured (from kdeprint dialog before printing) with photo quality?
Comment 9 hans de faber 2008-01-13 16:28:47 UTC
Angelo Naselli schreef::
[bugs.kde.org quoted mail]
I configured a special printque for photo it at maximum dpi which is 4800.
I did some investigation to reproducebility of the bug.

1. If I print a picture as is on smal paper I have never white lines.
2. If I print a picture as is on size A4 with "scale image to fit" i have
sometimes white lines.
3. If I print a picture and I had changed something like the paper position
from "top left" to "central" and print it size A4  with "scale image to fit" I
have always white lines.
4. There are more possibilities to get white lines I think they are all induced
by changes in the picture. The change as mentioned in 3 is the simplest.

Hans
Comment 10 Angelo Naselli 2008-01-13 17:29:30 UTC
domenica 13 gennaio 2008, hans de faber ha scritto:
> 3. If I print a picture and I had changed something like the paper position
> from "top left" to "central" and print it size A4  with "scale image to fit" I
> have always white lines.


Well I'll start from this point ans see if i can replicate it, thanks for your tests.

Angelo
Comment 11 caulier.gilles 2008-03-18 12:48:43 UTC
Angelo,

What news about this file ? It still valid ? It's a bug from printer driver ?

Gilles Caulier
Comment 12 Angelo Naselli 2008-03-18 14:23:15 UTC
> What news about this file ? It still valid ? It's a bug from printer driver ?

Well the state is i need to make the tests yet, unfortunately i've forgot it :(
Comment 13 hans de faber 2008-03-19 09:23:46 UTC
Angelo Naselli schreef:
[bugs.kde.org quoted mail]
I send you a picture to test.
With this problem I can only print small pictures.
I have to use now the combination "wine heliconfilter"but this has other 
problems but it prints perfect.
I prefer a native linux solution, and digikam is the best I've found.
Comment 14 Spiros G. 2008-06-22 09:42:32 UTC
Same problem here with digikam 0.9.3 using kde 3.5.9 on debian lenny.
I think that the problem started after the distribution upgraded to ghostscript 8.62 but maybe this is irrelevant. 
Verified that other programs (gimp, krita) print without the empty line problem.
Comment 15 caulier.gilles 2008-12-04 20:42:17 UTC
What's news for this report. It still valid using digiKam 0.9.4 ?

Gilles Caulier
Comment 16 caulier.gilles 2008-12-08 16:16:46 UTC
Private message from Hans:

------------------------------------------------

At the moment digikam 0.9.4 is available for suse 11.0 or 11.1 I test it
At the moment,using version 0.9.3, I can't print without missing lines.

Hans de Faber

------------------------------------------------

Hans, please give me a feedback when you have tested using digiKam 0.9.4.

Thanks in advance

Gilles Caulier
Comment 17 caulier.gilles 2009-06-19 08:08:37 UTC
Hans,

Are you tried digiKam 0.10.0 with KDE4 ?

Gilles Caulier
Comment 18 hans de faber 2009-06-19 11:58:23 UTC
Gilles Caulier schreef:
> https://bugs.kde.org/show_bug.cgi?id=155415
> 
> 
> 
> 
> 
> --- Comment #17 from Gilles Caulier <caulier gilles gmail com>  2009-06-19 08:08:37 ---
> Hans,
> 
> Are you tried digiKam 0.10.0 with KDE4 ?
> 
> Gilles Caulier
> 

Sorry, I stopped for the moment with digikam.
I have now digikam 0.10.0.beta9 along with kde4.1.3.
The problem is "File, Print image, or ctrl p doesn't give any reaction" so I
can't print at all.

Reinstalling Digikam_kde4 does not solve the problem.
Starting digikam in a new and empty user-account gives also no print action.

I will give digikam a net try with the next release of OpenSuse.

Sorry, Hans
Comment 19 caulier.gilles 2011-12-18 17:18:28 UTC
Hans,

This file still valid using digiKam 2.4 ?

Gilles Caulier
Comment 20 realdiskdoc 2014-01-20 08:52:07 UTC
Sadly, the bug remains. With Digiam 3.4.0 on Ubuntu 13.10, if I try to print a picture filling an A4 page, I get 1-3 white horizontal lines too. I can see at least one of them if I print to a .ps file and inspect it with maximum zoom in the viewer.
Comment 21 caulier.gilles 2014-08-29 13:16:53 UTC
Hans,

What's news about this file using last digiKam 4.2.0 and a more recent release of KDE/Qt ?

Gilles Caulier
Comment 22 hans de faber 2014-08-29 14:48:03 UTC
Thanks for questioning.
Problem has disapeared, because everything is changed in the mean time.
opensuse version,digikam version, printerdrivers and printer.
Recently printed photographs are perfect.
Thanks for an exellent Digikam, Hans

On 29/08/14 15:16, Gilles Caulier wrote:
> https://bugs.kde.org/show_bug.cgi?id=155415
>
> Gilles Caulier <caulier.gilles@gmail.com> changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Summary|white lines in printpreview |PRINT : white lines in
>                     |& printout                  |preview and output
>
> --- Comment #21 from Gilles Caulier <caulier.gilles@gmail.com> ---
> Hans,
>
> What's news about this file using last digiKam 4.2.0 and a more recent release
> of KDE/Qt ?
>
> Gilles Caulier
>