Bug 146857

Summary: Suggestion for tagging images
Product: digikam Reporter: Gandalf Lechner <gandalflechner>
Component: Tags-EngineAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: wishlist CC: caulier.gilles
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In: 7.6.0

Description Gandalf Lechner 2007-06-16 11:48:39 UTC
Version:           0.9.2-beta3 (using KDE KDE 3.5.7)
Installed from:    Ubuntu Packages

When dealing with a long list of tags, dragging the picture onto the desired tag icon, or selecting the tag from a list is tiresome. I suggest to also give the user the possibility to tag the images in a different way, comparable to the way you can tell kmail to move mails to a particular folder: a hotkey (like "t" for tag) brings brings up a dialog where you can type in the name of the tag you wish to set, and the program automatically filters all matching tag names. usually, after typing very few letters you can set the desired tag, much faster than with the current system.
Comment 1 Frank Siegert 2007-06-16 13:44:49 UTC
I like this idea very much, 20 votes from me. I use kmail's move dialog quite often, and find it very convenient.
Comment 2 Arnd Baecker 2007-06-16 13:52:57 UTC
But what is different (apart from the shortcut) from using the
right side-bar  "Comments/Tags" which does have an incremental
search box, behaving precisely as described?

Best, Arnd
Comment 3 Frank Siegert 2007-06-16 14:27:08 UTC
Have you tried kmails move dialog? It needs exactly three steps:

1. Shortcut "m" ("t")
2. Typing the first letters of the movetarget (tag)
3. Hitting Enter

Even assuming an existing shortcut, I don't manage to be nearly as quick with the tag tree filter in the comments/tags side bar. But maybe I am missing something? Besides, I wouldn't want the side bar always open, while tagging my pictures.
Comment 4 Gandalf Lechner 2007-06-16 14:44:52 UTC
On Saturday 16 June 2007 13:52:57 Arnd Baecker wrote:
[bugs.kde.org quoted mail]

Well the difference is that using the sidebar, one has to switch between 
keyboard and mouse, which makes tagging much slower. Try the move mail 
command in kmail and you get the idea what would be great to have in digikam, 
too. 

Regards,

Gandalf


>
> Best, Arnd

Comment 5 Arnd Baecker 2007-06-16 15:01:03 UTC
OK, thanks a lot for the explanation!

Actually, I just realized that this has also been discussed in
http://bugs.kde.org/show_bug.cgi?id=114465
in particular #9.
So should this be considered as duplicate?

Best, Arnd
Comment 6 Gandalf Lechner 2007-06-16 15:09:42 UTC
On Saturday 16 June 2007 15:01:04 Arnd Baecker wrote:
[bugs.kde.org quoted mail]

oh yes, I didn't see that one

> So should this be considered as duplicate?
>
> Best, Arnd

Comment 7 Arnd Baecker 2007-06-16 15:18:54 UTC
OK, marked as a duplicate - please transfer your votes
to http://bugs.kde.org/show_bug.cgi?id=114465 
Also it might be worth to add the comments here to that one for completeness.

Thanks for the suggestion (and yes, it would indeed be nice if this
could get implemented ... ;-)

*** This bug has been marked as a duplicate of 114465 ***
Comment 8 caulier.gilles 2022-01-22 17:29:28 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=114465