Bug 144809

Summary: Calendar will not print in color
Product: [Applications] korganizer Reporter: Darcee <dardar>
Component: printingAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED FIXED    
Severity: normal CC: christophe
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Darcee 2007-04-29 03:29:33 UTC
Version:           1.2.4 (using KDE 3.5.6 "release 77.1" , openSUSE )
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.18.2-34-default

When printing full month view of the calendar, I can only get it to print in black and white.  I decided to try the other options, "Print Week" & "Print Day", checked the boxes on both to use colors, but still only get a black and white printout.
Comment 1 Jason 2007-05-05 03:22:47 UTC
I finally convinced my girlfriend to use KOrganizer, and now this!  :P
Comment 2 Kurt Pfeifle 2007-05-06 01:45:25 UTC
Please give details about the printer model and the printer driver you use.

Please give the output of these commands:

  rpm -qa | grep -i foomatic
  grep \*cupsFilter /etc/cups/ppd/*.ppd
  grep \*ModelName /etc/cups/ppd/*.ppd
  grep \*NickName /etc/cups/ppd/*.ppd
  lpoptions -d printer_name        # replace "printer_name" with the one you use
  lpoptions -d printer_name -l     # replace "printer_name" with the one you use
Comment 3 Darcee 2007-05-07 02:00:29 UTC
Printer is a Canon Pixma MP600 using the Canon iP4200 driver.  I also have an old IBM/Lexmark 4029-020 laser printer using a Generic PCL4 driver.

Outputs are as follows.  

rpm -qa | grep -i foomatic:
foomatic-filters-3.0.2-48

grep \*cupsFilter /etc/cups/ppd/*.ppd
/etc/cups/ppd/LaserPrinter.ppd:*cupsFilter:     "application/vnd.cups-postscript 0 foomatic-rip"
/etc/cups/ppd/mp600.ppd:*cupsFilter: "application/vnd.cups-postscript 0 pstocanonij"

grep \*ModelName /etc/cups/ppd/*.ppd
/etc/cups/ppd/LaserPrinter.ppd:*ModelName:     "Generic PCL 4 Printer"
/etc/cups/ppd/mp600.ppd:*ModelName: "Canon iP4200"

grep \*NickName /etc/cups/ppd/*.ppd
/etc/cups/ppd/LaserPrinter.ppd:*NickName:      "Generic PCL 4 Printer Foomatic/ljetplus"
/etc/cups/ppd/mp600.ppd:*NickName: "Canon iP4200 Ver.2.60"

lpoptions -d printer_name
job-sheets=none,none printer-info='Canon MP600' printer-is-accepting-jobs=1 printer-is-shared=1 printer-make-and-model='Canon iP4200 Ver.2.60' printer-state=3 printer-state-change-time=1177791521 printer-state-reasons=none printer-type=167964

lpoptions -d printer_name -l 
PageSize/Paper Size: Custom Letter Legal A5 *A4 B5 4X6 4X8 5X7 8X10 l 2l postcard postdbl envelop10p envelopdlp envj4p envj6p creditcard businesscard panorama
PageRegion/PageRegion: Letter Legal A5 A4 B5 4X6 4X8 5X7 8X10 l 2l postcard postdbl envelop10p envelopdlp envj4p envj6p creditcard businesscard panorama
MediaType/Media Type: *plain prophoto superphoto doublesidephoto matte glossypaper highres ijpostcard postcard tshirt ohp envelope otherphoto
InputSlot/Paper Feed: *switch asf cassette
Duplex/Duplex: *None DuplexNoTumble DuplexTumble
Resolution/Output Resolution: *600
ColorModel/Color Model: *rgb


On Saturday 05 May 2007, Kurt Pfeifle wrote:
[bugs.kde.org quoted mail]


<html><head><meta name="qrichtext" content="1" /></head><body style="font-size:10pt;font-family:Sans Serif">
<p><span style="color:#008000">Printer is a Canon Pixma MP600 using the Canon iP4200 driver.  I also have an old IBM/Lexmark 4029-020 laser printer using a Generic PCL4 driver.</span></p>
<p></p>
<p><span style="color:#008000">Outputs are as follows.  </span></p>
<p></p>
<p><span style="color:#008000">rpm -qa | grep -i foomatic</span>:</p>
<p>foomatic-filters-3.0.2-48</p>
<p></p>
<p><span style="color:#008000">grep \*cupsFilter /etc/cups/ppd/*.ppd</span></p>
<p>/etc/cups/ppd/LaserPrinter.ppd:*cupsFilter:     &quot;application/vnd.cups-postscript 0 foomatic-rip&quot;</p>
<p>/etc/cups/ppd/mp600.ppd:*cupsFilter: &quot;application/vnd.cups-postscript 0 pstocanonij&quot;</p>
<p></p>
<p><span style="color:#008000">grep \*ModelName /etc/cups/ppd/*.ppd</span></p>
<p>/etc/cups/ppd/LaserPrinter.ppd:*ModelName:     &quot;Generic PCL 4 Printer&quot;</p>
<p>/etc/cups/ppd/mp600.ppd:*ModelName: &quot;Canon iP4200&quot;</p>
<p></p>
<p><span style="color:#008000">grep \*NickName /etc/cups/ppd/*.ppd</span></p>
<p>/etc/cups/ppd/LaserPrinter.ppd:*NickName:      &quot;Generic PCL 4 Printer Foomatic/ljetplus&quot;</p>
<p>/etc/cups/ppd/mp600.ppd:*NickName: &quot;Canon iP4200 Ver.2.60&quot;</p>
<p></p>
<p><span style="color:#008000">lpoptions -d printer_name</span></p>
<p>job-sheets=none,none printer-info='Canon MP600' printer-is-accepting-jobs=1 printer-is-shared=1 printer-make-and-model='Canon iP4200 Ver.2.60' printer-state=3 printer-state-change-time=1177791521 printer-state-reasons=none printer-type=167964</p>
<p></p>
<p><span style="color:#008000">lpoptions -d printer_name -l </span></p>
<p>PageSize/Paper Size: Custom Letter Legal A5 *A4 B5 4X6 4X8 5X7 8X10 l 2l postcard postdbl envelop10p envelopdlp envj4p envj6p creditcard businesscard panorama</p>
<p>PageRegion/PageRegion: Letter Legal A5 A4 B5 4X6 4X8 5X7 8X10 l 2l postcard postdbl envelop10p envelopdlp envj4p envj6p creditcard businesscard panorama</p>
<p>MediaType/Media Type: *plain prophoto superphoto doublesidephoto matte glossypaper highres ijpostcard postcard tshirt ohp envelope otherphoto</p>
<p>InputSlot/Paper Feed: *switch asf cassette</p>
<p>Duplex/Duplex: *None DuplexNoTumble DuplexTumble</p>
<p>Resolution/Output Resolution: *600</p>
<p>ColorModel/Color Model: *rgb</p>
<p></p>
<p></p>
<p>On Saturday 05 May 2007, Ku<span style="color:#ff0000">rt Pfei</span>fle wrote:</p>
<p><span style="color:#008000">&gt; ------- You are receiving this mail because: -------</span></p>
<p><span style="color:#008000">&gt; You reported the bug, or are watching the reporter.</span></p>
<p><span style="color:#008000">&gt;          </span></p>
<p><span style="color:#008000">&gt; http://bugs.kde.org/show_bug.cgi?id=144809         </span></p>
<p><span style="color:#008000">&gt; </span></p>
<p><span style="color:#008000">&gt; </span></p>
<p><span style="color:#008000">&gt; </span></p>
<p><span style="color:#008000">&gt; </span></p>
<p><span style="color:#008000">&gt; ------- Additional Comments From pfeifle kde org  2007-05-06 01:45 -------</span></p>
<p><span style="color:#008000">&gt; Please give details about the printer model and the printer driver you use.</span></p>
<p><span style="color:#008000">&gt; </span></p>
<p><span style="color:#008000">&gt; Please give the output of these commands:</span></p>
<p><span style="color:#008000">&gt; </span></p>
<p><span style="color:#008000">&gt;   rpm -qa | grep -i foomatic</span></p>
<p><span style="color:#008000">&gt;   grep \*cupsFilter /etc/cups/ppd/*.ppd</span></p>
<p><span style="color:#008000">&gt;   grep \*ModelName /etc/cups/ppd/*.ppd</span></p>
<p><span style="color:#008000">&gt;   grep \*NickName /etc/cups/ppd/*.ppd</span></p>
<p><span style="color:#008000">&gt;   lpoptions -d printer_name        # replace &quot;printer_name&quot; with the one you use</span></p>
<p><span style="color:#008000">&gt;   lpoptions -d printer_name -l     # replace &quot;printer_name&quot; with the one you use</span></p>
<p><span style="color:#008000">&gt; </span></p>
<p></p>
<p></p>
<p></p>
</body></html>
Comment 4 Jason 2007-05-07 14:28:53 UTC
This does not appear to be a printer bug.  If you do a print preview, no matter what printer you're using, KOrganizer only renders the page in greyscale / black and white.
Comment 5 Peter Mühlenpfordt 2008-06-20 14:44:08 UTC
Not a bugfix, but a way to print a (colorful) month view of the calendar:
http://sourceforge.net/projects/ical2ps/
Comment 6 Christophe Giboudeaux 2008-12-06 01:26:59 UTC
Tested in KDE4, The colors chosen for the different categories are correctly printed. 

Closing this report.
Comment 7 Christophe Giboudeaux 2008-12-07 14:42:41 UTC
Note: printing colors in month view is not yet implemented. The wish report is there: bug 102473
Comment 8 Ron Goodheart 2009-01-08 05:43:41 UTC
SVN commit 907451 by rgoodheart:

These changes also address some print overflow issues that were still happening but were not reported.

GUI:
	gui changes to configuration dialogs

BUG: 102473  
	Print month does not produce color output - events now in category colors 
BUG: 144809  
	Calendar will not print in color - category colors for incidence,day,week and month 
BUG: 102598  
	Print Locations,Descriptions, etc. on Filofax week pages - additional info added  
BUG: 104731  
	include date when printing month view on paper - date now printed on the bottom of page
BUG: 167751  
	Printing jounral entries with richtext from korganizer print html-tags
	rich text is converted to plain text before printing for now on all print types rather than printing the html 

FEATURE: 71908   
	calendar-print: option to switch on lines would be great - added optional note lines
FEATURE: 83689   
	Support printing of arbitrary date ranges - day range supports arbitrary range
	(patch from David Faure incorporated  - feature in day print to print selected range on one page
FEATURE: 110690  
	Print "Month view" does not print all events - triangle printed in lower right hand side of display box if the print overflows the box and all information is not displayed 



 M  +164 -114  calprintdayconfig_base.ui  
 M  +96 -31    calprintdefaultplugins.cpp  
 M  +9 -0      calprintdefaultplugins.h  
 M  +95 -90    calprintincidenceconfig_base.ui  
 M  +48 -18    calprintmonthconfig_base.ui  
 M  +248 -106  calprintpluginbase.cpp  
 M  +45 -6     calprintpluginbase.h  
 M  +41 -13    calprinttodoconfig_base.ui  
 M  +50 -34    calprintweekconfig_base.ui  


WebSVN link: http://websvn.kde.org/?view=rev&revision=907451