Bug 143351

Summary: Kontact 1.24 crashed at startup on OpenSuse 10.2 running KDE 3.5.6
Product: [Applications] kontact Reporter: thveillon
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED NOT A BUG    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description thveillon 2007-03-22 18:33:06 UTC
Version:           1.2.4 (using KDE KDE 3.5.6)
Installed from:    SuSE RPMs
OS:                Linux

At startup ontact exits with a SIGSEGV signal. The only output in terminal is "communication problem with Kontact, it probably crashed" ...and it does !
The crash handler output follows:
Vérification au démarrage de la configuration du système désactivée.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1241192752 (LWP 15693)]
[KCrash handler]
#9  0xffffffcc in ?? ()
#10 0xb7e1d0a2 in Kontact::Plugin::part ()
   from /opt/kde3/lib/libkpinterfaces.so.1
#11 0x0805bf00 in Kontact::MainWindow::selectPlugin ()
#12 0x08059af2 in Kontact::MainWindow::loadSettings ()
#13 0x0805d922 in Kontact::MainWindow::initObject ()
#14 0x0805868f in KontactApp::newInstance ()
#15 0xb7281c4d in KUniqueApplication::processDelayed ()
   from /opt/kde3/lib/libkdecore.so.4
#16 0xb72c78a8 in KUniqueApplication::qt_invoke ()
   from /opt/kde3/lib/libkdecore.so.4
#17 0xb6c74f1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb6fb001e in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb6c90ff7 in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb6c98383 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0xb6c159c7 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb6c16791 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0xb72d6bf2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#24 0xb6c0abd3 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb6bc4c40 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb6c2c7f0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb6c2c686 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb6c1557f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x08058c59 in main ()
Comment 1 Allen Winter 2007-03-22 18:49:34 UTC
This is the classic bug caused by the basket plugin.

rpm --erase basket should fix this.  it is not a problem with kmail.

For more information, contact your distribution's bug channel.