Bug 138905

Summary: Form text boxes get filled with nonsense entries
Product: [Applications] konqueror Reporter: Nick Warne <nick>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Nick Warne 2006-12-17 09:41:27 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Compiled From Sources
Compiler:          GCC 3.4.6 -march=athlon-tbird
OS:                Linux

This is a strange one, and I am not sure it is a site code problem, or is indeed a Konq error - but this doesn't happen in Firefox 2.

Visit this page:

http://www.national-lottery.co.uk/player/gaming/drawgame/displayLottoPlayslip.do?homelotto

Note the empty form boxes on the lottery tickets on your right.

In the centre of the page (in a green line bordered box), you will see a link called 'Essential guide to Dream Number' - follow this link, and let the page load.

Now hit Konq's back button, and when back to the original page, you will see the lottery form boxes (on your right) randomly filled with nonsense.

Nick
Comment 1 Maksim Orlovich 2006-12-17 16:55:00 UTC
Code bug... The code for restoring form state gets confused when they're rearranged by DHTML stuff... Some of the stuff you see is the internal serialization for the the form state..

*** This bug has been marked as a duplicate of 56188 ***