Bug 131727

Summary: statistics: Listening since 5 weeks ago --> Listening for 5 weeks
Product: amarok Reporter: Stefan Monov <logixoul>
Component: generalAssignee: Amarok Developers <amarok-bugs-dist>
Status: RESOLVED FIXED    
Severity: wishlist    
Priority: NOR    
Version: 1.4.1   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: "Listening Since" -> "First Played"

Description Stefan Monov 2006-08-02 14:10:51 UTC
Version:           1.4.1 (using KDE 3.5.1 Level "a" , SUSE 10.1)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.16.21-0.13-default

Under Newest Items in the Statistics tool the "Listening since 5 weeks ago" should be changed to the more natural "Listening for 5 weeks".
Comment 1 Andrew Ash 2007-01-21 08:14:55 UTC
Created attachment 19364 [details]
"Listening Since" -> "First Played"

This should fix this bug, which is also mentioned at
https://launchpad.net/bugs/59346

Hopefully it's not too late for the string freeze.
Comment 2 Jeff Mitchell 2007-01-22 07:19:30 UTC
SVN commit 626091 by mitchell:

Fix awkward "Listening since" to show "First played."  Patch by Andrew Ash <ash211@gmail.com>

Translators, we're sorry about the change during string freeze, but we felt it was important.

BUG: 131727
CCMAIL: kde-i18n-doc@kde.org



 M  +2 -0      ChangeLog  
 M  +1 -1      src/statistics.cpp  


--- trunk/extragear/multimedia/amarok/ChangeLog #626090:626091
@@ -98,6 +98,8 @@
     * Amarok now saves playlists with relative paths by default.
 
   BUGFIXES:
+    * "Listening since..." has been changed to the more clear "First
+      Played..."  Patch by Andrew Ash <ash211@gmail.com>. (BR 131727)
     * Fixed regression: the DEL key no longer worked in the 
       playlist after opening the File Browser context menu. (BR 140197)
     * Smart playlists now work correctly with "is not" filters containing
--- trunk/extragear/multimedia/amarok/src/statistics.cpp #626090:626091
@@ -277,7 +277,7 @@
         firstPlay.setTime_t( a[0].toUInt() );
 
     m_newestItem = new StatisticsItem( i18n("Newest Items"), this, m_genreItem );
-    m_newestItem->setSubtext( i18n("Listening since %1").arg( Amarok::verboseTimeSince( firstPlay ) ) );
+    m_newestItem->setSubtext( i18n("First played %1").arg( Amarok::verboseTimeSince( firstPlay ) ) );
 
     m_trackItem     ->setIcon( Amarok::icon("track") );
     m_mostplayedItem->setIcon( Amarok::icon("mostplayed") );