Bug 128327

Summary: incorrect next/previous word jump
Product: [Applications] kate Reporter: Maciej Pilichowski <bluedzins>
Component: generalAssignee: KWrite Developers <kwrite-bugs-null>
Status: RESOLVED FIXED    
Severity: normal    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: example
Don't hardcode space as ' ', use QChar::isSpace()

Description Maciej Pilichowski 2006-05-30 21:45:04 UTC
Version:            (using KDE KDE 3.5.2)
Installed from:    SuSE RPMs

Load the attached file. Then using ctrl+arrows observe the behavior near words:
Parada
angielski
Comment 1 Maciej Pilichowski 2006-05-30 21:45:37 UTC
Created attachment 16364 [details]
example
Comment 2 Johannes Sixt 2006-06-01 22:19:31 UTC
What exactly is wrong? Something like in bug #56337?
Comment 3 Maciej Pilichowski 2006-06-02 08:24:12 UTC
I guess similar.

Kate doesn't consider word "parada" (in this file of course) as a word, and just skips it.
Comment 4 Johannes Sixt 2006-06-03 14:20:37 UTC
The reason is that the bytes before 'Parada' are not spaces, but 0xa0, which appearently are interpreted as letters.

(To see the problem, I'm using ISO-8859-15 encoding.)
Comment 5 Johannes Sixt 2006-06-03 15:13:19 UTC
I've analysed this, and it seems that character 0xa0 is a "space", but KateHightlight::isInWord() checks only for the usual ' '.
Comment 6 Johannes Sixt 2006-06-03 15:17:07 UTC
Created attachment 16443 [details]
Don't hardcode space as ' ', use QChar::isSpace()

Here's a fix.

isInWord(): There exist space characters other than ' ' (character code 32).

Instead of using a static QString with hard-coded characters, check for
space characters using QChar::isSpace() and check the quotes explicitly.
Comment 7 Dominik Haumann 2006-06-03 15:47:57 UTC
Patch looks good, please commit :)
Comment 8 Maciej Pilichowski 2006-06-03 16:11:23 UTC
Just two cents, 0xa0 is non-breaking space. It is nothing wrong with it.
Comment 9 Dominik Haumann 2006-06-03 16:17:21 UTC
See http://en.wikipedia.org/wiki/Non-breaking_space, patch should still be correct iiuc :)
Comment 10 Johannes Sixt 2006-06-03 21:59:22 UTC
SVN commit 547903 by jsixt:

There exist space characters other than ' ' (character code 32).

Instead of using a static QString with hard-coded characters, check for
space characters using QChar::isSpace() and check the quotes explicitly.
BUG: 128327


 M  +2 -2      katehighlight.cpp  


--- branches/KDE/3.5/kdelibs/kate/part/katehighlight.cpp #547902:547903
@@ -2080,8 +2080,8 @@
 
 bool KateHighlighting::isInWord( QChar c, int attrib ) const
 {
-  static const QString& sq = KGlobal::staticQString(" \"'");
-  return m_additionalData[ hlKeyForAttrib( attrib ) ]->deliminator.find(c) < 0 && sq.find(c) < 0;
+  return m_additionalData[ hlKeyForAttrib( attrib ) ]->deliminator.find(c) < 0
+      && !c.isSpace() && c != '"' && c != '\'';
 }
 
 bool KateHighlighting::canBreakAt( QChar c, int attrib ) const
Comment 11 Johannes Sixt 2006-06-05 11:52:37 UTC
SVN commit 548318 by jsixt:

Forward-port commit 547903:
Instead of using a static QString with hard-coded characters, check for
space characters using QChar::isSpace() and check the quotes explicitly.
CCBUG: 128327


 M  +3 -2      katehighlight.cpp  


--- trunk/KDE/kdelibs/kate/part/katehighlight.cpp #548317:548318
@@ -2070,8 +2070,9 @@
 
 bool KateHighlighting::isInWord( QChar c, int attrib ) const
 {
-  static const QString& sq = KGlobal::staticQString(" \"'");
-  return m_additionalData[ hlKeyForAttrib( attrib ) ]->deliminator.indexOf(c) < 0 && sq.indexOf(c) < 0;
+  return m_additionalData[ hlKeyForAttrib( attrib ) ]->deliminator.indexOf(c) < 0
+      && !c.isSpace()
+      && c != QChar::fromLatin1('"') && c != QChar::fromLatin1('\'');
 }
 
 bool KateHighlighting::canBreakAt( QChar c, int attrib ) const
Comment 12 Aaron J. Seigo 2006-06-06 05:35:49 UTC
SVN commit 548612 by aseigo:

Merged revisions 545193-548432 via svnmerge from 
https://aseigo@svn.kde.org/home/kde/trunk/KDE/kdelibs

........
  r545202 | rodda | 2006-05-26 20:59:04 -0600 (Fri, 26 May 2006) | 3 lines
  
  Block selection mode improvements: draw cursor beyond end of line, and
  allow navigation outside the line too (regressions c/w 3.5)
........
  r545237 | adridg | 2006-05-27 02:03:13 -0600 (Sat, 27 May 2006) | 4 lines
  
  Since Makefile.am has died in trunk, *finally* apply Matthias' patch to use Mainpage.dox instead.
  
  CCMAIL: Matthias Kretz <kretz@kde.org>
........
  r545264 | adridg | 2006-05-27 02:56:06 -0600 (Sat, 27 May 2006) | 1 line
  
  Remove the Makefile.am-based top-level ordering for processing and use REFERENCES based.
........
  r545268 | ogoffart | 2006-05-27 03:04:25 -0600 (Sat, 27 May 2006) | 2 lines
  
  add a test to test if KConfig::delete{Entry,Group} correctly works.
  Actually it fails because of a bug in KConfigBase::deleteGroup
........
  r545340 | rodda | 2006-05-27 05:10:08 -0600 (Sat, 27 May 2006) | 2 lines
  
  First functional completion feature: reorder and merge columns at will
........
  r545357 | mueller | 2006-05-27 05:40:45 -0600 (Sat, 27 May 2006) | 2 lines
  
  can't hurt to initialize stuff
........
  r545391 | mkretz | 2006-05-27 06:42:36 -0600 (Sat, 27 May 2006) | 2 lines
  
  Qt wants qint32 and qint64 registered
........
  r545392 | mkretz | 2006-05-27 06:50:53 -0600 (Sat, 27 May 2006) | 12 lines
  
  - SimplePlayer takes a category on construction now which is used for the
    AudioOutput.
  - Add MediaQueue which you can feed MediaObjects and which can be used by the
    backend to do gapless playback or crossfades with high precision. The idea is
    that the MediaQueue defines the gap between two "media streams" and if the gap
    is negative it defines the crossfade time.
    The Backend couldn't do gapless playback before because it couldn't know what
    MediaObject was supposed to be played after the current one.
  - add BrightnessControl as a simple interface to do a brightness effect on the
    video signal
  - remove the Phonon::Ui namespace
........
  r545393 | mkretz | 2006-05-27 06:51:14 -0600 (Sat, 27 May 2006) | 2 lines
  
  no Ui namespace anymore
........
  r545396 | mkretz | 2006-05-27 06:57:17 -0600 (Sat, 27 May 2006) | 2 lines
  
  test passes again after qvariant_casts are replaced with evil reinterpret_casts
........
  r545403 | adridg | 2006-05-27 07:03:19 -0600 (Sat, 27 May 2006) | 1 line
  
  Clean up pattern space(s) better.
........
  r545430 | adridg | 2006-05-27 08:12:56 -0600 (Sat, 27 May 2006) | 1 line
  
  Code consistency, wrt. closing ) and reference parameters.
........
  r545612 | cramblitt | 2006-05-27 15:15:02 -0600 (Sat, 27 May 2006) | 1 line
  
  DCOPCString does not seem to work for dcop events.  Switch to QByteArray.
........
  r545695 | mkretz | 2006-05-28 01:38:34 -0600 (Sun, 28 May 2006) | 2 lines
  
  add an Accessibility category
........
  r545738 | adridg | 2006-05-28 03:51:17 -0600 (Sun, 28 May 2006) | 1 line
  
  Check for UserData member of GifFileType so it bails with giflib (and not libgif) during compile.
........
  r545748 | ogoffart | 2006-05-28 04:11:11 -0600 (Sun, 28 May 2006) | 2 lines
  
  Fix KConfigBase::deleteGroup 
  and remove the (IMO) useless flag Recursive.
........
  r545834 | aseigo | 2006-05-28 07:42:41 -0600 (Sun, 28 May 2006) | 5 lines
  
  fix a crash tzander stumbled across (calling clear() in a slot connected
  to a triggered(..) signal)
  also be safer actionTriggered. paranoia is the best way to ensure They
  don't get you, after all.
........
  r546138 | mlaurent | 2006-05-29 03:22:21 -0600 (Mon, 29 May 2006) | 3 lines
  
  Fix load rgb.txt for xorg 7.0
  (xorg developper moved it )
........
  r546247 | rich | 2006-05-29 09:23:12 -0600 (Mon, 29 May 2006) | 1 line
  
  First cut of the docviewer example
........
  r546248 | rich | 2006-05-29 09:23:35 -0600 (Mon, 29 May 2006) | 1 line
  
  Doc fix
........
  r546296 | dfaure | 2006-05-29 11:30:12 -0600 (Mon, 29 May 2006) | 3 lines
  
  Fix breakage due to KServiceType::serviceType() not being useable for mimetypes anymore,
   as noticed by unit test (yay for unit tests!). Patch approved by Matthias Kretz.
........
  r546308 | woebbe | 2006-05-29 11:56:11 -0600 (Mon, 29 May 2006) | 1 line
  
  Qt::black/white are no QColors anymore
........
  r546312 | woebbe | 2006-05-29 12:03:47 -0600 (Mon, 29 May 2006) | 1 line
  
  removed unused variable
........
  r546487 | mlaurent | 2006-05-30 03:02:38 -0600 (Tue, 30 May 2006) | 13 lines
  
  Move cmake duplicate check here:
  -> FindTagLib: need by kdemultimedia/amarok
  -> FindPostgreSQL: need by koffice-kexi/amarok
  -> FindMySQL: need by koffice-kexi/amarok
  -> FindMusicBrainz: need by amarok/kdemultimedia
  -> FindUSB: need by kdebase/amarok
  -> FindBerkeleyDB: need by kbabel/kdevelop
  -> FindRUBY: need by koffice-kross/amarok
  
  I will remove them from kde module after new snapshot (next monday)
........
  r546660 | mojo | 2006-05-30 11:21:07 -0600 (Tue, 30 May 2006) | 3 lines
  
  Allow cmake to use the gif include dir, necessary for the check.
  
  CCMAIL: kde-buildsystem@kde.org
........
  r546777 | reed | 2006-05-30 18:10:31 -0600 (Tue, 30 May 2006) | 1 line
  
  NO_GUI != NOGUI
........
  r546826 | thiago | 2006-05-31 01:20:26 -0600 (Wed, 31 May 2006) | 7 lines
  
  Since no objections were raised in kde-core-devel, I am merging the
  kdelibs4-dbus branch back into trunk. KDELibs compiles, links and
  installs with this, but obviously all other modules will fail to
  build. Let the porting commence.
  
  CCMAIL:kde-core-devel@kde.org,kde-buildsystem@kde.org
........
  r546827 | thiago | 2006-05-31 01:22:03 -0600 (Wed, 31 May 2006) | 1 line
  
  Complement commit 546826: svn 1.3.1 cannot handle replaced files in an atomic commit. This is fixed in svn 1.4.
........
  r546830 | thiago | 2006-05-31 01:26:50 -0600 (Wed, 31 May 2006) | 1 line
  
  Complement the D-BUS merge: remove DCOP
........
  r546832 | thiago | 2006-05-31 01:31:21 -0600 (Wed, 31 May 2006) | 1 line
  
  Re-add the DONTPORT check that I had removed in my own version
........
  r546842 | mkretz | 2006-05-31 01:52:17 -0600 (Wed, 31 May 2006) | 2 lines
  
  make room for the phonon directory from branches/work/phonon-dynamicifaces
........
  r546843 | mkretz | 2006-05-31 01:52:35 -0600 (Wed, 31 May 2006) | 2 lines
  
  move work branch back to trunk
........
  r546851 | mkretz | 2006-05-31 02:06:33 -0600 (Wed, 31 May 2006) | 2 lines
  
  merge thiago's changes back in
........
  r546861 | mkretz | 2006-05-31 02:40:28 -0600 (Wed, 31 May 2006) | 2 lines
  
  this should call the private slot
........
  r546872 | mlaurent | 2006-05-31 03:19:33 -0600 (Wed, 31 May 2006) | 2 lines
  
  Fix compile/link
........
  r546882 | mlaurent | 2006-05-31 03:51:55 -0600 (Wed, 31 May 2006) | 2 lines
  
  Don't register it with dcop
........
  r546885 | mlaurent | 2006-05-31 03:56:26 -0600 (Wed, 31 May 2006) | 2 lines
  
  Don't register it with dcop
........
  r546886 | habacker | 2006-05-31 04:06:27 -0600 (Wed, 31 May 2006) | 1 line
  
  - added directx header from wine project (cvspath=wine/include date=2006-05-23) to be independent from ms directx sdk
........
  r546888 | habacker | 2006-05-31 04:08:10 -0600 (Wed, 31 May 2006) | 1 line
  
  fixed redefined message, may be there is a better place for this fix
........
  r546890 | habacker | 2006-05-31 04:14:20 -0600 (Wed, 31 May 2006) | 1 line
  
  added win32 direct sound example
........
  r546897 | adridg | 2006-05-31 04:45:17 -0600 (Wed, 31 May 2006) | 1 line
  
  Display Thiago's notes on where to get the new dependency so people aren't immediately lost if they don't remember what happened on -core-devel.
........
  r546899 | adridg | 2006-05-31 04:56:58 -0600 (Wed, 31 May 2006) | 1 line
  
  Format porting doc nicer, point to it from configure
........
  r546911 | kuemmel | 2006-05-31 05:30:37 -0600 (Wed, 31 May 2006) | 1 line
  
  add missing symbol: opterr
........
  r546913 | kuemmel | 2006-05-31 05:31:30 -0600 (Wed, 31 May 2006) | 1 line
  
  clean namespace: undef the macro interface
........
  r546922 | kuemmel | 2006-05-31 06:24:53 -0600 (Wed, 31 May 2006) | 1 line
  
  add missing symbol: opterr
........
  r546930 | kuemmel | 2006-05-31 06:49:18 -0600 (Wed, 31 May 2006) | 1 line
  
  add missing symbol: isnan
........
  r546931 | vkrause | 2006-05-31 06:52:30 -0600 (Wed, 31 May 2006) | 2 lines
  
  Add macro to generate QDBus interfaces from XML descriptions.
........
  r546937 | dfaure | 2006-05-31 07:16:27 -0600 (Wed, 31 May 2006) | 2 lines
  
  Put the vars in the cache; useful for debugging and for adding "reuse cache" to this module later on.
........
  r546939 | vkrause | 2006-05-31 07:31:48 -0600 (Wed, 31 May 2006) | 2 lines
  
  Add macros to generate adaptor code from XML and XML from a header file.
........
  r546947 | vkrause | 2006-05-31 07:51:06 -0600 (Wed, 31 May 2006) | 3 lines
  
  - fix warning when calling automoc after qdbus_add_*
  - consistent naming
........
  r546948 | dfaure | 2006-05-31 07:58:32 -0600 (Wed, 31 May 2006) | 2 lines
  
  Save 8 calls to pkg-config when reconfiguring and qtdbus is all in the cache already.
........
  r546952 | dfaure | 2006-05-31 08:01:54 -0600 (Wed, 31 May 2006) | 5 lines
  
  Move those repeated prototypes to a generated kdefakes.h file, which other modules
  will be able to use. In kdelibs I just include it in config.h since those functions are
  very much used, but maybe in more portable modules we can just include kdefakes.h directly
  in the files that need it.
........
  r546962 | thiago | 2006-05-31 08:37:29 -0600 (Wed, 31 May 2006) | 2 lines
  
  Does anyone have a brown-paper bag for me?
  Fix the annoying warning 'No such slot 'notifyKDebugConfigChanged' while connecting D-Bus'
........
  r546967 | dfaure | 2006-05-31 08:53:14 -0600 (Wed, 31 May 2006) | 2 lines
  
  Added a unit test and found a kde3 bug: by default KArchive gave directory-like permissions (040755) to files (which should use 0100644 instead)
........
  r546992 | dfaure | 2006-05-31 10:23:49 -0600 (Wed, 31 May 2006) | 3 lines
  
  Implement minimumSizeHint to match contentsRect() (and avoid contentsRect being negative, which led
  to QImage::scanLine aborting). Patch tested by Tim Beaulen (for krita's startup).
........
  r547014 | mkretz | 2006-05-31 10:49:29 -0600 (Wed, 31 May 2006) | 2 lines
  
  forwardport: the signal signature has changed long -> qint64
........
  r547031 | dfaure | 2006-05-31 11:15:28 -0600 (Wed, 31 May 2006) | 6 lines
  
  Re-enabled two tests.
  Ported test_filter to qtestlib
  Export ConfigDialog
  Ported both dialogs to KDialog
  CMakeLists.txt cleanup
........
  r547100 | lueck | 2006-05-31 14:50:08 -0600 (Wed, 31 May 2006) | 1 line
  
  changed Inhalt -> Handbuch zu
........
  r547143 | mlarouche | 2006-05-31 16:52:24 -0600 (Wed, 31 May 2006) | 1 line
  
  Remove mention of d-bus work branch
........
  r547263 | habacker | 2006-06-01 08:13:25 -0600 (Thu, 01 Jun 2006) | 1 line
  
  - added DirectShow related directx header from wine project (cvspath=wine/include date=2006-05-23) to be independent from ms directx sdk
........
  r547264 | habacker | 2006-06-01 08:15:07 -0600 (Thu, 01 Jun 2006) | 1 line
  
  - dummy header, defines from wine
........
  r547265 | habacker | 2006-06-01 08:15:23 -0600 (Thu, 01 Jun 2006) | 1 line
  
  - added DirectShow related directx header from wine project (cvspath=wine/include date=2006-05-23) to be independent from ms directx sdk
........
  r547266 | habacker | 2006-06-01 08:15:59 -0600 (Thu, 01 Jun 2006) | 1 line
  
  - generated files with widl, may be removed later, when widl is part of distribution
........
  r547267 | habacker | 2006-06-01 08:17:17 -0600 (Thu, 01 Jun 2006) | 1 line
  
  added DirectShow example, avi filepath must be changed in source 
........
  r547313 | dfaure | 2006-06-01 11:23:49 -0600 (Thu, 01 Jun 2006) | 3 lines
  
  This affects runtime (it even showed me an empty dialog), so make it a warning
   (and make it clearer where it comes from)
........
  r547314 | dfaure | 2006-06-01 11:25:15 -0600 (Thu, 01 Jun 2006) | 2 lines
  
  Moved KParts::ComponentFactory::createInstanceFromService(s) to KService; which removes some weird kparts includes from kio.
........
  r547316 | dfaure | 2006-06-01 11:40:35 -0600 (Thu, 01 Jun 2006) | 6 lines
  
  Moved KParts::ComponentFactory::createInstanceFromQuery to KServiceTypeTrader.
  Porting script:
   files=`wcgrep -r -l createInstanceFromQuery .`
   perl -pi -e 's/KParts::ComponentFactory::createInstanceFromQuery/KServiceTypeTrader::createInstanceFromQuery/g' `echo $files`
   perl -pi -e 's/kparts\/componentfactory\.h/kservicetypetrader.h/' `echo $files` 
........
  r547321 | dfaure | 2006-06-01 11:49:42 -0600 (Thu, 01 Jun 2006) | 2 lines
  
  Forgot to fix test_filter and to make it run automatically
........
  r547323 | dfaure | 2006-06-01 11:59:42 -0600 (Thu, 01 Jun 2006) | 3 lines
  
  Ported from KPluginInfo to KService to drop dependency on kio+kutils, and
  to actually make the code simpler (no need to re-query the trader just to load a plugin).
........
  r547326 | dfaure | 2006-06-01 12:09:22 -0600 (Thu, 01 Jun 2006) | 3 lines
  
  Broker -> Loader, more logical and one step closer to sonnet if we ever switch to it.
  For now I think this makes kspell2 good enough to move to kdeui and be used by ktextedit etc.
........
  r547330 | habacker | 2006-06-01 12:16:26 -0600 (Thu, 01 Jun 2006) | 1 line
  
  mingw compile fix
........
  r547332 | habacker | 2006-06-01 12:19:15 -0600 (Thu, 01 Jun 2006) | 1 line
  
  limit mingw patch 
........
  r547361 | ogoffart | 2006-06-01 14:13:50 -0600 (Thu, 01 Jun 2006) | 1 line
  
  empty group are automatically removed
........
  r547365 | ogoffart | 2006-06-01 14:39:35 -0600 (Thu, 01 Jun 2006) | 1 line
  
  how to run the daemon
........
  r547377 | mkretz | 2006-06-01 15:08:56 -0600 (Thu, 01 Jun 2006) | 3 lines
  
  q_ptr is 0 in the ctor of the private, move the creation of the
  MixerIfaceAdaptor to the ctor of AudioOutput
........
  r547394 | langkamp | 2006-06-01 16:46:48 -0600 (Thu, 01 Jun 2006) | 5 lines
  
  Reversed the value range, if orientation is horizontal. Now minimum is on the left and maximum on the right side.
  
  CCBUG:115213
........
  r547460 | mkretz | 2006-06-02 02:26:23 -0600 (Fri, 02 Jun 2006) | 2 lines
  
  register qint64 for signal/slot usage
........
  r547474 | mlaurent | 2006-06-02 03:55:34 -0600 (Fri, 02 Jun 2006) | 4 lines
  
  Fix radiobutton.
  I don't known if it's a bug but qradiobutton+Q3VButtonGroup doesn't work
  it's never exclusif
........
  r547477 | mlaurent | 2006-06-02 04:07:52 -0600 (Fri, 02 Jun 2006) | 2 lines
  
  Add macro for phononcore/phononui lib
........
  r547506 | mlaurent | 2006-06-02 05:57:09 -0600 (Fri, 02 Jun 2006) | 2 lines
  
  Fix: documentation said that ok button has focus by default
........
  r547525 | mlaurent | 2006-06-02 07:23:23 -0600 (Fri, 02 Jun 2006) | 2 lines
  
  Fix launch dialogbox when acl was not configurated
........
  r547533 | ogoffart | 2006-06-02 07:37:07 -0600 (Fri, 02 Jun 2006) | 5 lines
  
  Remove some Dialog virtual_hook
  http://lists.kde.org/?l=kde-core-devel&m=114147112602538&w=2
........
  r547549 | mojo | 2006-06-02 08:18:08 -0600 (Fri, 02 Jun 2006) | 1 line
  
  There is no io.c
........
  r547550 | ogoffart | 2006-06-02 08:19:38 -0600 (Fri, 02 Jun 2006) | 1 line
  
  fix signal connection
........
  r547556 | ogoffart | 2006-06-02 08:52:18 -0600 (Fri, 02 Jun 2006) | 4 lines
  
  Add debug area for KNotify
........
  r547571 | mlaurent | 2006-06-02 09:47:29 -0600 (Fri, 02 Jun 2006) | 2 lines
  
  Fix crash: Init widget 
........
  r547588 | mueller | 2006-06-02 10:52:53 -0600 (Fri, 02 Jun 2006) | 2 lines
  
  use KDesktopFile
........
  r547589 | mueller | 2006-06-02 10:54:15 -0600 (Fri, 02 Jun 2006) | 2 lines
  
  use KDesktopFile
........
  r547590 | mueller | 2006-06-02 10:55:03 -0600 (Fri, 02 Jun 2006) | 2 lines
  
  use KDesktopFile
........
  r547592 | mlaurent | 2006-06-02 11:11:35 -0600 (Fri, 02 Jun 2006) | 2 lines
  
  Fix crash when we write "$HOME/" pos was 0 => (pos-1) crashed
........
  r547603 | dhaumann | 2006-06-02 12:24:12 -0600 (Fri, 02 Jun 2006) | 3 lines
  
  fix crash due to access of a QList at position -2
  Someone with KXmlGui* knowledge, please review :)
........
  r547612 | mojo | 2006-06-02 12:40:45 -0600 (Fri, 02 Jun 2006) | 1 line
  
  I think this is needed because kdecore doesn't depend on dcop now.
........
  r547811 | thiago | 2006-06-03 07:42:07 -0600 (Sat, 03 Jun 2006) | 2 lines
  
  These are supposed to be slots, so move them to the slots section.
........
  r547815 | thiago | 2006-06-03 07:47:42 -0600 (Sat, 03 Jun 2006) | 10 lines
  
  Fix KUniqueApplication:
  1) use a private connection in the parent process, after the
  fork(). The D-BUS server gets more than confused if two processes
  start writing on the same socket.
  
  2) Move newInstance into an adaptor, to support the calls that contain
  a QByteArray parameter.
  
  3) Reindent the code a bit.
........
  r547847 | woebbe | 2006-06-03 09:12:00 -0600 (Sat, 03 Jun 2006) | 1 line
  
  -pedantic
........
  r548004 | rich | 2006-06-04 06:23:46 -0600 (Sun, 04 Jun 2006) | 1 line
  
  w00t, now we can document anything we can create with new
........
  r548020 | rodda | 2006-06-04 07:31:30 -0600 (Sun, 04 Jun 2006) | 4 lines
  
  Grouping of code completion items implemented
  
  The UI is mostly a placeholder (needs a lot of work)
........
  r548097 | thiago | 2006-06-04 08:58:19 -0600 (Sun, 04 Jun 2006) | 1 line
  
  Use the new function from QtDBus
........
  r548100 | rich | 2006-06-04 09:02:44 -0600 (Sun, 04 Jun 2006) | 1 line
  
  Ported the calc example to KJSE/4
........
  r548106 | rich | 2006-06-04 09:06:31 -0600 (Sun, 04 Jun 2006) | 1 line
  
  Fix minor bug (seems we need to explictly initialise this now)
........
  r548109 | rich | 2006-06-04 09:18:57 -0600 (Sun, 04 Jun 2006) | 1 line
  
  Update TODO
........
  r548112 | rich | 2006-06-04 09:35:19 -0600 (Sun, 04 Jun 2006) | 1 line
  
  Added a log of some chat about kjs encapsulation
........
  r548150 | rich | 2006-06-04 12:38:06 -0600 (Sun, 04 Jun 2006) | 1 line
  
  Add tests for QUrl (they don't show the bug I hit though...)
........
  r548192 | adridg | 2006-06-04 14:57:06 -0600 (Sun, 04 Jun 2006) | 3 lines
  
  DOX: That's how you enable APIDOX in a subdir: write a Mainpage.dox; doxygen settings show up in comments at the end.
........
  r548200 | rich | 2006-06-04 15:15:57 -0600 (Sun, 04 Jun 2006) | 1 line
  
  This is broken
........
  r548238 | rich | 2006-06-04 17:10:20 -0600 (Sun, 04 Jun 2006) | 1 line
  
  Moved the LCD number bindings and qtimer bindings from the editor example
........
  r548318 | jsixt | 2006-06-05 03:52:27 -0600 (Mon, 05 Jun 2006) | 5 lines
  
  Forward-port commit 547903:
  Instead of using a static QString with hard-coded characters, check for
  space characters using QChar::isSpace() and check the quotes explicitly.
  CCBUG: 128327
........
  r548360 | mlaurent | 2006-06-05 05:49:12 -0600 (Mon, 05 Jun 2006) | 2 lines
  
  Fix typo
........
  r548366 | thiago | 2006-06-05 05:59:31 -0600 (Mon, 05 Jun 2006) | 1 line
  
  No dcop server to be started
........
  r548369 | woebbe | 2006-06-05 06:06:52 -0600 (Mon, 05 Jun 2006) | 1 line
  
  -pedantic
........
  r548371 | thiago | 2006-06-05 06:08:38 -0600 (Mon, 05 Jun 2006) | 3 lines
  
  Export adaptors and properties at /MainApplication as well. This
  renders /UniqueApplication unnecessary.
........
  r548381 | thiago | 2006-06-05 06:45:22 -0600 (Mon, 05 Jun 2006) | 1 line
  
  Since 548371, there's no need for /UniqueApplication
........
  r548384 | woebbe | 2006-06-05 06:54:26 -0600 (Mon, 05 Jun 2006) | 1 line
  
  use arg0 in ctor
........
  r548386 | woebbe | 2006-06-05 06:56:00 -0600 (Mon, 05 Jun 2006) | 1 line
  
  -pedantic
........
  r548400 | carewolf | 2006-06-05 07:37:47 -0600 (Mon, 05 Jun 2006) | 2 lines
  
  Merge up to KDE 3.5 HEAD (548399)
........
  r548402 | thiago | 2006-06-05 07:38:35 -0600 (Mon, 05 Jun 2006) | 1 line
  
  Make ktoolinvocation.h not depend directly on dbus/qdbus.h
........


 _M            . (directory)  
 M  +5 -2      CMakeLists.txt  
 M  +9 -0      KDE4PORTING.html  
 M  +2 -1      cmake/modules/FindGIF.cmake  
 M  +18 -81    cmake/modules/FindKDE4Internal.cmake  
 M  +2 -149    config.h.cmake  
 D             dcop (directory)  
 M  +34 -67    doc/api/doxygen.sh  
 M  +2 -2      interfaces/khexedit/byteseditinterface.h  
 M  +1 -1      interfaces/kimproxy/interface/CMakeLists.txt  
 M  +5 -13     interfaces/kimproxy/library/CMakeLists.txt  
 M  +93 -108   interfaces/kimproxy/library/kimproxy.cpp  
 M  +17 -23    interfaces/kimproxy/library/kimproxy.h  
 M  +4 -7      interfaces/kmediaplayer/CMakeLists.txt  
 M  +0 -1      interfaces/kmediaplayer/kfileaudiopreview/kfileaudiopreview.cpp  
 M  +3 -5      interfaces/kmediaplayer/player.cpp  
 M  +10 -5     interfaces/kmediaplayer/player.h  
 D             interfaces/kmediaplayer/playerdcopobject.h  
 M  +2 -2      interfaces/kregexpeditor/kregexpeditorinterface.h  
 M  +41 -28    interfaces/kspeech/kspeech.h  
 M  +14 -11    interfaces/kspeech/kspeechsink.h  
 M  +6 -4      interfaces/ktexteditor/codecompletion2.h  
 M  +2 -2      kabc/CMakeLists.txt  
 M  +7 -4      kabc/addresseehelper.cpp  
 M  +6 -6      kabc/addresseehelper.h  
 M  +1 -0      kabc/ldapconfigwidget.cpp  
 M  +1 -1      kabc/vcardparser/testread.cpp  
 M  +3 -6      kate/part/CMakeLists.txt  
 M  +329 -55   kate/part/katecompletionmodel.cpp  
 M  +85 -6     kate/part/katecompletionmodel.h  
 M  +12 -3     kate/part/katecompletionwidget.cpp  
 M  +1 -0      kate/part/katecompletionwidget.h  
 M  +5 -4      kate/part/katedocument.cpp  
 M  +1 -5      kate/part/katedocument.h  
 M  +3 -2      kate/part/katehighlight.cpp  
 M  +6 -0      kate/part/katelinerange.cpp  
 M  +1 -0      kate/part/katelinerange.h  
 M  +27 -12    kate/part/katerenderer.cpp  
 M  +1 -1      kate/part/katetextlayout.cpp  
 M  +30 -7     kate/part/kateviewinternal.cpp  
 M  +2 -3      kate/tests/katetest.cpp  
 M  +1 -4      kcmshell/CMakeLists.txt  
 M  +28 -32    kcmshell/main.cpp  
 M  +10 -12    kcmshell/main.h  
 M  +8 -9      kconf_update/kconf_update.cpp  
 M  +15 -15    kdecore/CMakeLists.txt  
 D             kdecore/kappdcopiface.cpp  
 D             kdecore/kappdcopiface.h  
 M  +36 -152   kdecore/kapplication.cpp  
 M  +10 -33    kdecore/kapplication.h  
 M  +1 -1      kdecore/kconfig_compiler/CMakeLists.txt  
 D             kdecore/kdcoppropertyproxy.cpp  
 D             kdecore/kdcoppropertyproxy.h  
 M  +3 -0      kdecore/kdebug.areas  
 M  +6 -6      kdecore/kdebug.cpp  
 D             kdecore/kdebugdcopiface.cpp  
 D             kdecore/kdebugdcopiface.h  
 M  +13 -2     kdecore/kdedmodule.cpp  
 M  +10 -8     kdecore/kdedmodule.h  
 M  +8 -1      kdecore/klibloader.h  
 M  +9 -30     kdecore/knotifyclient.cpp  
 M  +3 -3      kdecore/kservice/kservice.cpp  
 M  +62 -0     kdecore/kservice/kservice.h  
 M  +4 -4      kdecore/kservice/kservicetype.h  
 M  +43 -0     kdecore/kservice/kservicetypetrader.h  
 M  +11 -11    kdecore/ksycoca.cpp  
 M  +3 -4      kdecore/ksycoca.h  
 M  +15 -0     kdecore/ktoolinvocation.cpp  
 M  +26 -26    kdecore/ktoolinvocation.h  
 M  +384 -420  kdecore/ktoolinvocation_x11.cpp  
 M  +80 -197   kdecore/kuniqueapplication.cpp  
 M  +5 -32     kdecore/kuniqueapplication.h  
 A             kdecore/kuniqueapplication_p.h   trunk/KDE/kdelibs/kdecore/kuniqueapplication_p.h#548402
 M  +7 -5      kdecore/kurl.cpp  
 M  +3 -5      kdecore/kwin.cpp  
 M  +2 -5      kdecore/kwinmodule.cpp  
 M  +11 -11    kdecore/tests/CMakeLists.txt  
 M  +10 -3     kdecore/tests/dcopkonqtest.cpp  
 M  +1 -1      kdecore/tests/kmdcodectest.cpp  
 M  +1 -1      kdecore/tests/startserviceby.cpp  
 M  +2 -0      kded/CMakeLists.txt  
 M  +16 -26    kded/kbuildsycoca.cpp  
 M  +8 -8      kded/kde-menu.cpp  
 M  +155 -199  kded/kded.cpp   [POSSIBLY UNSAFE: system]
 M  +48 -32    kded/kded.h  
 M  +6 -127    kded/khostname.cpp  
 M  +1 -1      kdefx/kdrawutil.cpp  
 M  +3 -5      kdeprint/CMakeLists.txt  
 M  +0 -1      kdeprint/cups/cupsinfos.cpp  
 M  +26 -30    kdeprint/kdeprintd.cpp  
 M  +11 -10    kdeprint/kdeprintd.h  
 M  +16 -12    kdeprint/kmfactory.cpp  
 M  +8 -11     kdeprint/kmfactory.h  
 M  +7 -37     kdeprint/kprinterimpl.cpp  
 M  +0 -104    kdesu/kcookie.cpp  
 M  +1 -26     kdesu/kcookie.h  
 M  +0 -49     kdesu/ssh.cpp  
 M  +0 -4      kdesu/ssh.h  
 M  +1 -19     kdesu/stub.cpp  
 M  +2 -28     kdesu/stub.h  
 M  +1 -5      kdeui/CMakeLists.txt  
 M  +0 -3      kdeui/kaboutdialog.cpp  
 M  +0 -2      kdeui/kaboutdialog.h  
 M  +0 -2      kdeui/kbugreport.cpp  
 M  +0 -1      kdeui/kbugreport.h  
 M  +0 -5      kdeui/kcharselect.cpp  
 M  +0 -5      kdeui/kcharselect.h  
 M  +0 -2      kdeui/kcmodule.cpp  
 M  +0 -2      kdeui/kcmodule.h  
 M  +0 -2      kdeui/kcolorbutton.cpp  
 M  +0 -2      kdeui/kcolorbutton.h  
 M  +0 -2      kdeui/kcolorcombo.cpp  
 M  +0 -2      kdeui/kcolorcombo.h  
 M  +1 -19     kdeui/kcolordialog.cpp  
 M  +0 -12     kdeui/kcolordialog.h  
 M  +0 -3      kdeui/kdatepicker.cpp  
 M  +0 -2      kdeui/kdatepicker.h  
 M  +0 -2      kdeui/kdatewidget.cpp  
 M  +0 -2      kdeui/kdatewidget.h  
 D             kdeui/kdcopactionproxy.cpp  
 D             kdeui/kdcopactionproxy.h  
 M  +0 -4      kdeui/kdetrayproxy/CMakeLists.txt  
 M  +1 -1      kdeui/kdetrayproxy/kdetrayproxy.h  
 M  +2 -2      kdeui/kdetrayproxy/module.cpp  
 M  +1 -3      kdeui/kdetrayproxy/module.h  
 M  +2 -5      kdeui/kdialog.cpp  
 M  +0 -2      kdeui/kdialog.h  
 M  +1 -4      kdeui/kdialogbase.cpp  
 M  +0 -2      kdeui/kdialogbase.h  
 M  +0 -2      kdeui/kdualcolorbutton.cpp  
 M  +0 -3      kdeui/kdualcolorbutton.h  
 M  +0 -8      kdeui/keditcl.h  
 M  +0 -12     kdeui/keditcl1.cpp  
 M  +0 -2      kdeui/keditlistbox.cpp  
 M  +0 -2      kdeui/keditlistbox.h  
 M  +0 -6      kdeui/kedittoolbar.cpp  
 M  +0 -4      kdeui/kedittoolbar.h  
 M  +0 -5      kdeui/kfontdialog.cpp  
 M  +0 -4      kdeui/kfontdialog.h  
 M  +0 -3      kdeui/khelpmenu.cpp  
 M  +0 -2      kdeui/khelpmenu.h  
 M  +0 -2      kdeui/kjanuswidget.cpp  
 M  +0 -2      kdeui/kjanuswidget.h  
 M  +0 -2      kdeui/kkeybutton.cpp  
 M  +0 -2      kdeui/kkeybutton.h  
 M  +0 -5      kdeui/kkeydialog.cpp  
 M  +0 -5      kdeui/kkeydialog.h  
 M  +18 -35    kdeui/kmainwindow.cpp  
 M  +1 -21     kdeui/kmainwindow.h  
 M  +24 -109   kdeui/kmainwindowiface.cpp  
 D             kdeui/kmainwindowiface.h  
 M  +3 -8      kdeui/knotification.cpp  
 M  +73 -76    kdeui/knotificationmanager.cpp  
 D             kdeui/knotificationmanager.h  
 M  +6 -6      kdeui/knotificationrestrictions.cpp  
 M  +0 -14     kdeui/knuminput.cpp  
 M  +0 -10     kdeui/knuminput.h  
 M  +0 -2      kdeui/kpassworddialog.cpp  
 M  +0 -2      kdeui/kpassworddialog.h  
 M  +12 -15    kdeui/kpastetextaction.cpp  
 M  +0 -3      kdeui/kprogressdialog.cpp  
 M  +0 -3      kdeui/kprogressdialog.h  
 M  +7 -12     kdeui/krootpixmap.cpp  
 M  +11 -6     kdeui/kselectaction.cpp  
 M  +13 -22    kdeui/kselector.cpp  
 M  +5 -6      kdeui/kselector.h  
 M  +0 -2      kdeui/ksystemtray.cpp  
 M  +0 -2      kdeui/ksystemtray.h  
 M  +0 -2      kdeui/ktabctl.cpp  
 M  +0 -2      kdeui/ktabctl.h  
 M  +0 -3      kdeui/ktextedit.cpp  
 M  +0 -2      kdeui/ktextedit.h  
 M  +0 -4      kdeui/ktip.cpp  
 M  +0 -2      kdeui/ktip.h  
 M  +4 -7      kdeui/kwindowlistmenu.cpp  
 M  +0 -2      kdeui/kwindowlistmenu.h  
 M  +3 -14     kdeui/kxmlguibuilder.cpp  
 M  +1 -1      kdeui/tests/kcolordlgtest.cpp  
 M  +1 -1      kdeui/tests/ktabwidgettest.cpp  
 M  +1 -1      kdoctools/customization/de/entities/help-menu.docbook  
 M  +4 -1      kdoctools/genshortcutents.cpp  
 M  +3 -3      khtml/CMakeLists.txt  
 M  +12 -1     khtml/ChangeLog  
 M  +4 -4      khtml/css/css_ruleimpl.cpp  
 M  +1 -1      khtml/css/css_ruleimpl.h  
 M  +4 -0      khtml/css/css_stylesheetimpl.h  
 M  +1 -2      khtml/css/cssstyleselector.cpp  
 M  +3 -1      khtml/css/html4.css  
 M  +12 -2     khtml/ecma/kjs_debugwin.cpp  
 M  +628 -100  khtml/html/doctypes.cpp  
 M  +41 -3     khtml/html/doctypes.gperf  
 M  +4 -1      khtml/html/dtd.cpp  
 M  +21 -23    khtml/html/html_documentimpl.cpp  
 M  +5 -1      khtml/html/html_headimpl.cpp  
 M  +1 -1      khtml/html/html_headimpl.h  
 M  +6 -0      khtml/html/html_imageimpl.cpp  
 M  +25 -2     khtml/html/htmlparser.cpp  
 M  +1 -0      khtml/java/CMakeLists.txt  
 M  +11 -13    khtml/java/kjavaappletviewer.cpp  
 M  +0 -2      khtml/khtml_iface.h  
 M  +15 -16    khtml/khtml_part.cpp  
 M  +9 -5      khtml/khtml_part.h  
 M  +32 -36    khtml/khtmlpart_p.h  
 M  +1 -0      khtml/khtmlview.cpp  
 M  +3 -1      khtml/misc/khtmllayout.h  
 M  +42 -7     khtml/misc/loader.cpp  
 M  +5 -1      khtml/misc/loader.h  
 M  +1 -1      khtml/misc/loader_client.h  
 M  +17 -15    khtml/rendering/bidi.cpp  
 M  +18 -1     khtml/rendering/font.cpp  
 M  +8 -1      khtml/rendering/font.h  
 M  +63 -37    khtml/rendering/render_block.cpp  
 M  +0 -1      khtml/rendering/render_block.h  
 M  +779 -306  khtml/rendering/render_box.cpp  
 M  +15 -4     khtml/rendering/render_box.h  
 M  +3 -1      khtml/rendering/render_canvas.cpp  
 M  +12 -17    khtml/rendering/render_object.cpp  
 M  +2 -2      khtml/rendering/render_text.cpp  
 M  +1 -1      khtml/test_regression.cpp  
 M  +1 -1      khtml/xml/dom_docimpl.cpp  
 M  +1 -1      khtml/xml/dom_docimpl.h  
 M  +2 -1      khtml/xml/dom_xmlimpl.cpp  
 M  +1 -1      khtml/xml/dom_xmlimpl.h  
 M  +3 -0      kinit/CMakeLists.txt  
 M  +0 -19     kinit/kinit.cpp  
 M  +144 -196  kinit/klauncher.cpp  
 M  +69 -44    kinit/klauncher.h  
 M  +10 -11    kinit/klauncher_main.cpp  
 M  +1 -2      kinit/tests/klaunchertest.cpp  
 M  +8 -20     kio/CMakeLists.txt  
 M  +3 -4      kio/bookmarks/kbookmark.cc  
 M  +9 -22     kio/bookmarks/kbookmarkimporter_crash.cc  
 M  +25 -20    kio/bookmarks/kbookmarkmanager.cc  
 M  +14 -16    kio/bookmarks/kbookmarkmanager.h  
 M  +14 -10    kio/bookmarks/kbookmarknotifier.h  
 M  +0 -2      kio/kfile/kdirselectdialog.cpp  
 M  +0 -2      kio/kfile/kdirselectdialog.h  
 M  +0 -4      kio/kfile/kencodingfiledialog.cpp  
 M  +0 -2      kio/kfile/kencodingfiledialog.h  
 M  +0 -2      kio/kfile/kfiledialog.cpp  
 M  +0 -2      kio/kfile/kfiledialog.h  
 M  +0 -1      kio/kfile/kfiletreeview.cpp  
 M  +0 -6      kio/kfile/kicondialog.cpp  
 M  +0 -4      kio/kfile/kicondialog.h  
 M  +4 -6      kio/kfile/knotifydialog.cpp  
 M  +0 -1      kio/kfile/kopenwith.cpp  
 M  +3 -10     kio/kfile/kpropertiesdialog.cpp  
 M  +0 -4      kio/kfile/kpropertiesdialog.h  
 M  +0 -4      kio/kpasswdserver/CMakeLists.txt  
 M  +49 -30    kio/kpasswdserver/kpasswdserver.cpp  
 M  +17 -20    kio/kpasswdserver/kpasswdserver.h  
 M  +54 -238   kio/kssl/ksslcertificatecache.cc  
 M  +0 -4      kio/kssl/ksslcertificatecache.h  
 M  +2 -2      kio/kssl/ksslcertificatehome.cc  
 M  +19 -146   kio/kssl/ksslsigners.cc  
 M  +0 -3      kio/kssl/ksslsigners.h  
 M  +1 -6      kio/misc/CMakeLists.txt  
 M  +0 -4      kio/misc/kpac/CMakeLists.txt  
 M  +16 -18    kio/misc/kpac/proxyscout.cpp  
 M  +10 -10    kio/misc/kpac/proxyscout.h  
 M  +0 -4      kio/misc/kssld/CMakeLists.txt  
 M  +85 -22    kio/misc/kssld/kssld.cpp  
 M  +54 -39    kio/misc/kssld/kssld.h  
 M  +0 -4      kio/misc/kwalletd/CMakeLists.txt  
 M  +116 -174  kio/misc/kwalletd/kwalletd.cpp  
 M  +72 -58    kio/misc/kwalletd/kwalletd.h  
 M  +11 -19    kio/misc/uiserver.cpp  
 M  +21 -29    kio/misc/uiserver.h  
 M  +0 -11     kio/tests/CMakeLists.txt  
 M  +1 -1      kio/tests/kacltest.cpp  
 M  +29 -22    kio/tests/karchivetest.cpp  
 M  +1 -1      kio/tests/ksycocatest.cpp  
 M  +1 -1      kio/tests/kurlcompletiontest.cpp  
 M  +2 -0      kioslave/http/CMakeLists.txt  
 M  +18 -50    kioslave/http/http.cc  
 M  +13 -5     kioslave/http/http_cache_cleaner.cpp  
 M  +5 -5      kioslave/http/kcookiejar/CMakeLists.txt  
 M  +20 -36    kioslave/http/kcookiejar/kcookieserver.cpp  
 M  +11 -14    kioslave/http/kcookiejar/kcookieserver.h  
 M  +33 -30    kioslave/http/kcookiejar/kcookiewin.cpp  
 M  +2 -2      kioslave/http/kcookiejar/kcookiewin.h  
 M  +10 -21    kioslave/http/kcookiejar/main.cpp  
 M  +0 -1      kioslave/metainfo/metainfo.cpp  
 M  +1 -1      kjs/JSImmediate.h  
 A             kjsembed/Mainpage.dox   trunk/KDE/kdelibs/kjsembed/Mainpage.dox#548402
 M  +54 -0     kjsembed/TODO-KDE4  
 A             kjsembed/examples/calc (directory)   trunk/KDE/kdelibs/kjsembed/examples/calc#548402
 A             kjsembed/examples/calc/calc.js   trunk/KDE/kdelibs/kjsembed/examples/calc/calc.js#548402
 A             kjsembed/examples/calc/calc.ui   trunk/KDE/kdelibs/kjsembed/examples/calc/calc.ui#548402
 A             kjsembed/examples/docviewer (directory)   trunk/KDE/kdelibs/kjsembed/examples/docviewer#548402
 M  +2 -1      kjsembed/kjsembed/CMakeLists.txt  
 A             kjsembed/kjsembed/bind_qlcdnumber.cpp   trunk/KDE/kdelibs/kjsembed/kjsembed/bind_qlcdnumber.cpp#548402
 A             kjsembed/kjsembed/bind_qlcdnumber.h   trunk/KDE/kdelibs/kjsembed/kjsembed/bind_qlcdnumber.h#548402
 A             kjsembed/kjsembed/bind_qtimer.cpp   trunk/KDE/kdelibs/kjsembed/kjsembed/bind_qtimer.cpp#548402
 A             kjsembed/kjsembed/bind_qtimer.h   trunk/KDE/kdelibs/kjsembed/kjsembed/bind_qtimer.h#548402
 M  +1 -0      kjsembed/kjsembed/jseventmapper.h  
 A             kjsembed/tests/url.js   trunk/KDE/kdelibs/kjsembed/tests/url.js#548402
 M  +2 -0      knotify/CMakeLists.txt  
 M  +0 -6      knotify/daemon/CMakeLists.txt  
 M  +26 -5     knotify/daemon/knotify.cpp  
 M  +22 -6     knotify/daemon/knotify.h  
 M  +4 -4      knotify/daemon/knotifyconfig.cpp  
 M  +0 -4      knotify/daemon/main.cpp  
 M  +2 -2      knotify/daemon/notifybyexecute.cpp  
 M  +1 -1      knotify/daemon/notifybylogfile.cpp  
 M  +2 -2      knotify/daemon/notifybypopup.cpp  
 M  +2 -2      knotify/daemon/notifybysound.cpp  
 M  +1 -1      knotify/daemon/notifybytaskbar.cpp  
 M  +2 -0      kparts/CMakeLists.txt  
 M  +8 -118    kparts/componentfactory.h  
 M  +0 -6      kparts/mainwindow.cpp  
 M  +0 -4      kparts/mainwindow.h  
 M  +2 -3      kparts/part.cpp  
 M  +3 -9      kresources/CMakeLists.txt  
 D             kresources/manageriface.h  
 M  +19 -32    kresources/managerimpl.cpp  
 M  +8 -3      kresources/managerimpl.h  
 M  +4 -12     kspell2/CMakeLists.txt  
 M  +17 -17    kspell2/README  
 M  +7 -7      kspell2/backgroundchecker.cpp  
 M  +3 -3      kspell2/backgroundchecker.h  
 M  +5 -5      kspell2/backgroundengine.cpp  
 M  +5 -5      kspell2/backgroundengine.h  
 M  +6 -6      kspell2/backgroundthread.cpp  
 M  +5 -5      kspell2/backgroundthread.h  
 D             kspell2/broker.cpp  
 D             kspell2/broker.h  
 M  +8 -8      kspell2/defaultdictionary.cpp  
 M  +2 -2      kspell2/defaultdictionary.h  
 M  +2 -2      kspell2/dictionary.h  
 M  +1 -1      kspell2/kcmspellchecking/CMakeLists.txt  
 M  +3 -6      kspell2/kcmspellchecking/spellchecking.cpp  
 A             kspell2/loader.cpp   trunk/KDE/kdelibs/kspell2/loader.cpp#548402
 A             kspell2/loader.h   trunk/KDE/kdelibs/kspell2/loader.h#548402
 M  +8 -8      kspell2/settings.cpp  
 M  +3 -3      kspell2/settings.h  
 M  +26 -45    kspell2/tests/CMakeLists.txt  
 M  +2 -2      kspell2/tests/backgroundtest.cpp  
 M  +5 -5      kspell2/tests/test.cpp  
 M  +4 -4      kspell2/tests/test_configdialog.cpp  
 M  +2 -2      kspell2/tests/test_dialog.cpp  
 M  +2 -2      kspell2/tests/test_dialog.h  
 M  +31 -16    kspell2/tests/test_filter.cpp  
 A             kspell2/tests/test_filter.h   trunk/KDE/kdelibs/kspell2/tests/test_filter.h#548402
 M  +6 -4      kspell2/ui/CMakeLists.txt  
 M  +8 -9      kspell2/ui/configdialog.cpp  
 M  +6 -6      kspell2/ui/configdialog.h  
 M  +22 -22    kspell2/ui/configwidget.cpp  
 M  +4 -4      kspell2/ui/configwidget.h  
 M  +15 -14    kspell2/ui/dialog.cpp  
 M  +3 -3      kspell2/ui/dialog.h  
 M  +11 -11    kspell2/ui/highlighter.cpp  
 M  +3 -2      kutils/CMakeLists.txt  
 M  +50 -74    kutils/kcmoduleproxy.cpp  
 M  +4 -4      kutils/kcmoduleproxy.h  
 M  +35 -27    kutils/kcmoduleproxyIface.h  
 M  +20 -21    kutils/kcmoduleproxyIfaceImpl.cpp  
 M  +6 -8      kutils/kcmoduleproxyIfaceImpl.h  
 M  +2 -2      kutils/kfinddialog.cpp  
 M  +6 -5      kutils/kplugininfo.cpp  
 M  +1 -1      kutils/tests/kfindtest.cpp  
 M  +1 -1      kutils/tests/kreplacetest.cpp  
 M  +2 -4      kwallet/client/CMakeLists.txt  
 M  +164 -212  kwallet/client/kwallet.cc  
 M  +13 -17    kwallet/client/kwallet.h  
 D             kwallet/client/kwallettypes.h  
 M  +12 -3     kwallet/tests/kwalletasync.cpp  
 M  +12 -3     kwallet/tests/kwalletboth.cpp  
 M  +12 -3     kwallet/tests/kwalletsync.cpp  
 M  +8 -8      phonon/CMakeLists.txt  
 M  +1 -1      phonon/Mainpage.dox  
 M  +3 -0      phonon/TODO  
 M  +1 -2      phonon/abstractaudiooutput.cpp  
 M  +0 -4      phonon/abstractaudiooutput.h  
 M  +0 -1      phonon/abstractaudiooutput_p.h  
 M  +69 -120   phonon/abstractmediaproducer.cpp  
 M  +0 -5      phonon/abstractmediaproducer.h  
 M  +5 -11     phonon/abstractmediaproducer_p.h  
 M  +1 -10     phonon/abstractvideooutput.cpp  
 M  +1 -14     phonon/abstractvideooutput.h  
 M  +0 -1      phonon/abstractvideooutput_p.h  
 M  +10 -8     phonon/audiocapturedevice.cpp  
 M  +2 -11     phonon/audiocodec.cpp  
 M  +14 -45    phonon/audiodataoutput.cpp  
 M  +0 -1      phonon/audiodataoutput_p.h  
 M  +17 -23    phonon/audioeffect.cpp  
 M  +0 -14     phonon/audioeffect.h  
 M  +0 -1      phonon/audioeffect_p.h  
 M  +2 -11     phonon/audioeffectdescription.cpp  
 M  +36 -22    phonon/audiooutput.cpp  
 M  +3 -4      phonon/audiooutput.h  
 M  +1 -2      phonon/audiooutput_p.h  
 M  +2 -11     phonon/audiooutputdevice.cpp  
 M  +51 -25    phonon/audiopath.cpp  
 M  +0 -5      phonon/audiopath.h  
 M  +0 -1      phonon/audiopath_p.h  
 M  +25 -17    phonon/avcapture.cpp  
 M  +0 -1      phonon/avcapture_p.h  
 M  +46 -34    phonon/backendcapabilities.cpp  
 M  +8 -2      phonon/base.cpp  
 M  +10 -0     phonon/base.h  
 M  +7 -15     phonon/base_p.h  
 M  +22 -70    phonon/bytestream.cpp  
 M  +2 -3      phonon/bytestream_p.h  
 M  +2 -11     phonon/containerformat.cpp  
 M  +2 -2      phonon/effectparameter.cpp  
 M  +27 -6     phonon/effectparameter.h  
 M  +39 -37    phonon/factory.cpp  
 M  +35 -55    phonon/factory.h  
 D             phonon/ifaces (directory)  
 M  +4 -2      phonon/kcm/backendselection.cpp  
 M  +37 -77    phonon/mediaobject.cpp  
 M  +1 -4      phonon/mediaobject.h  
 M  +2 -27     phonon/mediaobject_p.h  
 D             phonon/mixeriface.h  
 M  +83 -83    phonon/phonondefs.h  
 M  +2 -0      phonon/phononnamespace.cpp  
 M  +5 -1      phonon/phononnamespace.h  
 M  +2 -1      phonon/simpleplayer.cpp  
 M  +1 -1      phonon/simpleplayer.h  
 M  +2 -0      phonon/tests/CMakeLists.txt  
 D             phonon/tests/WhatToTest  
 M  +24 -7     phonon/tests/backendcapabilitiestest.cpp  
 M  +1 -0      phonon/tests/backendcapabilitiestest.h  
 M  +2 -0      phonon/tests/fakebackend/CMakeLists.txt  
 M  +1 -6      phonon/tests/fakebackend/abstractaudiooutput.h  
 M  +14 -16    phonon/tests/fakebackend/abstractmediaproducer.cpp  
 M  +29 -38    phonon/tests/fakebackend/abstractmediaproducer.h  
 M  +1 -0      phonon/tests/fakebackend/abstractvideooutput.h  
 M  +9 -7      phonon/tests/fakebackend/audiodataoutput.h  
 M  +13 -7     phonon/tests/fakebackend/audioeffect.cpp  
 M  +8 -12     phonon/tests/fakebackend/audioeffect.h  
 M  +8 -7      phonon/tests/fakebackend/audiooutput.h  
 M  +9 -9      phonon/tests/fakebackend/audiopath.cpp  
 M  +6 -11     phonon/tests/fakebackend/audiopath.h  
 M  +2 -4      phonon/tests/fakebackend/avcapture.cpp  
 M  +7 -9      phonon/tests/fakebackend/avcapture.h  
 M  +28 -16    phonon/tests/fakebackend/backend.cpp  
 M  +56 -71    phonon/tests/fakebackend/backend.h  
 M  +17 -17    phonon/tests/fakebackend/bytestream.h  
 M  +12 -13    phonon/tests/fakebackend/mediaobject.h  
 M  +6 -8      phonon/tests/fakebackend/ui/backend.cpp  
 M  +5 -12     phonon/tests/fakebackend/ui/backend.h  
 M  +1 -3      phonon/tests/fakebackend/ui/videowidget.cpp  
 M  +3 -11     phonon/tests/fakebackend/ui/videowidget.h  
 M  +12 -15    phonon/tests/fakebackend/videodataoutput.h  
 M  +6 -0      phonon/tests/fakebackend/videoeffect.cpp  
 M  +9 -10     phonon/tests/fakebackend/videoeffect.h  
 M  +9 -10     phonon/tests/fakebackend/videopath.cpp  
 M  +6 -11     phonon/tests/fakebackend/videopath.h  
 M  +4 -5      phonon/tests/fakebackend/visualization.cpp  
 M  +6 -14     phonon/tests/fakebackend/visualization.h  
 M  +8 -8      phonon/tests/fakebackend/volumefadereffect.h  
 M  +14 -3     phonon/tests/mediaobjecttest.cpp  
 A             phonon/tests/methods (directory)   trunk/KDE/kdelibs/phonon/tests/methods#548402
 M  +0 -2      phonon/ui/CMakeLists.txt  
 M  +1 -3      phonon/ui/effectwidget.cpp  
 M  +1 -3      phonon/ui/effectwidget.h  
 M  +1 -3      phonon/ui/effectwidget_p.h  
 M  +22 -23    phonon/ui/factory.cpp  
 M  +14 -28    phonon/ui/factory.h  
 D             phonon/ui/ifaces (directory)  
 M  +1 -3      phonon/ui/mediacontrols.cpp  
 M  +1 -4      phonon/ui/mediacontrols.h  
 M  +5 -7      phonon/ui/seekslider.cpp  
 M  +3 -5      phonon/ui/seekslider.h  
 M  +1 -3      phonon/ui/seekslider_p.h  
 M  +8 -0      phonon/ui/tests/CMakeLists.txt  
 M  +0 -1      phonon/ui/tests/mediaplayer.cpp  
 M  +3 -3      phonon/ui/tests/mediaplayer.h  
 A             phonon/ui/tests/methods (directory)   trunk/KDE/kdelibs/phonon/ui/tests/methods#548402
 M  +0 -1      phonon/ui/tests/seekslider.cpp  
 M  +2 -4      phonon/ui/tests/seekslider.h  
 M  +5 -5      phonon/ui/tests/testwidget.cpp  
 M  +5 -8      phonon/ui/tests/testwidget.h  
 M  +7 -21     phonon/ui/videowidget.cpp  
 M  +1 -8      phonon/ui/videowidget.h  
 M  +1 -13     phonon/ui/videowidget_p.h  
 M  +1 -3      phonon/ui/volumeslider.cpp  
 M  +1 -4      phonon/ui/volumeslider.h  
 M  +10 -8     phonon/videocapturedevice.cpp  
 M  +2 -11     phonon/videocodec.cpp  
 M  +24 -77    phonon/videodataoutput.cpp  
 M  +0 -4      phonon/videodataoutput.h  
 M  +0 -1      phonon/videodataoutput_p.h  
 M  +17 -23    phonon/videoeffect.cpp  
 M  +0 -14     phonon/videoeffect.h  
 M  +0 -1      phonon/videoeffect_p.h  
 M  +2 -11     phonon/videoeffectdescription.cpp  
 M  +2 -11     phonon/videooutputdevice.cpp  
 M  +51 -26    phonon/videopath.cpp  
 M  +0 -5      phonon/videopath.h  
 M  +0 -1      phonon/videopath_p.h  
 M  +28 -13    phonon/visualization.cpp  
 M  +2 -2      phonon/visualization.h  
 M  +0 -1      phonon/visualization_p.h  
 M  +2 -11     phonon/visualizationeffect.cpp  
 M  +11 -35    phonon/volumefadereffect.cpp  
 M  +0 -1      phonon/volumefadereffect_p.h  
 M  +3 -0      win/CMakeLists.txt  
 A             win/examples (directory)   trunk/KDE/kdelibs/win/examples#548402
 A             win/examples/dshow.cpp   trunk/KDE/kdelibs/win/examples/dshow.cpp#548402
 A             win/include/directx (directory)   trunk/KDE/kdelibs/win/include/directx#548402
 A             win/include/directx/audevcod.h   trunk/KDE/kdelibs/win/include/directx/audevcod.h#548402
 A             win/include/directx/axcore.idl   trunk/KDE/kdelibs/win/include/directx/axcore.idl#548402
 A             win/include/directx/axextend.idl   trunk/KDE/kdelibs/win/include/directx/axextend.idl#548402
 A             win/include/directx/basetsd.h   trunk/KDE/kdelibs/win/include/directx/basetsd.h#548402
 A             win/include/directx/comcat.idl   trunk/KDE/kdelibs/win/include/directx/comcat.idl#548402
 A             win/include/directx/control.h   trunk/KDE/kdelibs/win/include/directx/control.h#548402
 A             win/include/directx/control.idl   trunk/KDE/kdelibs/win/include/directx/control.idl#548402
 A             win/include/directx/ddraw.h   trunk/KDE/kdelibs/win/include/directx/ddraw.h#548402
 A             win/include/directx/devenum.idl   trunk/KDE/kdelibs/win/include/directx/devenum.idl#548402
 A             win/include/directx/dshow.h   trunk/KDE/kdelibs/win/include/directx/dshow.h#548402
 A             win/include/directx/dyngraph.idl   trunk/KDE/kdelibs/win/include/directx/dyngraph.idl#548402
 A             win/include/directx/errors.h   trunk/KDE/kdelibs/win/include/directx/errors.h#548402
 A             win/include/directx/guiddef.h   trunk/KDE/kdelibs/win/include/directx/guiddef.h#548402
 A             win/include/directx/oaidl.idl   trunk/KDE/kdelibs/win/include/directx/oaidl.idl#548402
 A             win/include/directx/objidl.idl   trunk/KDE/kdelibs/win/include/directx/objidl.idl#548402
 A             win/include/directx/oleidl.idl   trunk/KDE/kdelibs/win/include/directx/oleidl.idl#548402
 A             win/include/directx/servprov.idl   trunk/KDE/kdelibs/win/include/directx/servprov.idl#548402
 A             win/include/directx/shldisp.idl   trunk/KDE/kdelibs/win/include/directx/shldisp.idl#548402
 A             win/include/directx/shtypes.idl   trunk/KDE/kdelibs/win/include/directx/shtypes.idl#548402
 A             win/include/directx/strmif.h   trunk/KDE/kdelibs/win/include/directx/strmif.h#548402
 A             win/include/directx/strmif.idl   trunk/KDE/kdelibs/win/include/directx/strmif.idl#548402
 A             win/include/directx/unknwn.idl   trunk/KDE/kdelibs/win/include/directx/unknwn.idl#548402
 A             win/include/directx/uuids.h   trunk/KDE/kdelibs/win/include/directx/uuids.h#548402
 A             win/include/directx/vfwmsgs.h   trunk/KDE/kdelibs/win/include/directx/vfwmsgs.h#548402
 A             win/include/directx/windef.h   trunk/KDE/kdelibs/win/include/directx/windef.h#548402
 A             win/include/directx/wtypes.idl   trunk/KDE/kdelibs/win/include/directx/wtypes.idl#548402
 M  +5 -0      win/include/fixwinh.h  
 M  +3 -0      win/include/msvc/math.h  
 M  +3 -1      win/include/msvc/unistd.h  
 M  +2 -1      win/src/unistd.c