Bug 121878

Summary: can't move mail to shared folder (append)
Product: [Applications] kmail Reporter: Martin Zdila <zdila>
Component: IMAPAssignee: Christian Mollekopf <mollekopf>
Status: RESOLVED FIXED    
Severity: normal CC: chrigi_1, emgaron+kde, vanmeeuwen
Priority: NOR    
Version: 1.8.3   
Target Milestone: ---   
Platform: Debian testing   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Martin Zdila 2006-02-13 12:29:38 UTC
Version:           1.8.3 (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages
OS:                Linux

server settings:
Cyrus IMAP 2.1.18
altnamespace: no
unixhierarchysep: yes

In KMail I can't move (or copy) email to shared folders. Folders have permission of "anyone lrsip" (in KMail I see: "anyone Append"). I've tried it with drag'n'drop and context_menu->"Move To". I can read emails from those shared folders. Flagging of messages is possible, but lost after KMail restart.
Comment 1 Carsten Burghardt 2006-02-13 20:16:13 UTC
Do you get any error messages? Does it work when you grant write access?
Comment 2 Martin Zdila 2006-02-15 12:01:03 UTC
No error messages. If I grant write access, it works.
Comment 3 Philippe Cloutier 2006-04-28 04:30:50 UTC
Note that this was reported downstream against 3.3.1 as Debian #297050, using Cyrus IMAP.
Comment 4 T. Ribbrock 2008-06-03 18:07:20 UTC
I can confirm this bug for several versions of KMail (as part of Kontact). I first encountered it with KMail as part of the proko2 version of Kontact (from kolab.org - Kontact proko2.1.5 on SuSE 10.0, KDE 3.4.2, Qt 3.3.4) more than a year ago. This bug was reported then to the Kolab developer team as issue1578 (https://www.intevation.de/roundup/kolab/issue1578), but I was referred to kde.org.

This issue still persists with the Kontact Enterprise version we are currently running:

kontact --version
Qt: 3.3.8b
KDE: 3.5.9
Kontact: 1.2.9 (enterprise 20080509.805827)

kmail --version
Qt: 3.3.8b
KDE: 3.5.9
KMail: 1.9.9 (enterprise 20080509.805827)

This is the version I got from kolab.org and rebuilt for Kubuntu 8.04.

The problem was reproducible 100% in all versions I have used in between and manifests itself in exactly the way the original poster describes. The folders will become accessible for mail copy/move when I add "write" permissions. Unfortunately, adding "write" also allows other users to delete mails in that folder, which is not what I want.

In a DIMAP (cached IMAP) account, shared folders with "append" permissions work exactly like they should, i.e. other users can add mail, but not delete.

As a server, we use Kolab 2.1, which includes cyrus 2.2.12, release 2.5.0_kolab2.
Comment 5 Jeroen van Meeuwen (Kolab Systems) 2012-06-08 12:49:57 UTC
Christian, please confirm/deny this issue could still be current, and act accordingly.
Comment 6 Christian Mollekopf 2012-06-08 14:04:58 UTC
Tested with kontact 4.8.1