Bug 117726

Summary: Kontact crashes (SIGSEGV) on startup with Bogofilter installed
Product: [Applications] kontact Reporter: Fran├žois Obada <francois.obada>
Component: mailAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Fran├žois Obada 2005-12-05 16:09:28 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Ubuntu Packages
OS:                Linux

This bug happens with the Kontact shipped in KDE 3.5 on Kubuntu Breezy. It is cleary a duplicate of the bug #97230 which has not been resolved although it has been marked as such !

- installed : Bogofilter 0.95.2-1ubuntu1

- backtrace :
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1240742208 (LWP 10347)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#4  0xb5771388 in KMFilterActionExtFilter::processAsync ()
   from /usr/lib/libkmailprivate.so
#5  0xb5742b03 in KMail::ActionScheduler::actionMessage ()
   from /usr/lib/libkmailprivate.so
#6  0xb5743299 in KMail::ActionScheduler::filterMessage ()
   from /usr/lib/libkmailprivate.so
#7  0xb5743516 in KMail::ActionScheduler::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#8  0xb70eb929 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#9  0xb70ec3c4 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#10 0xb744cf9a in QTimer::timeout () from /usr/lib/libqt-mt.so.3
#11 0xb7110c19 in QTimer::event () from /usr/lib/libqt-mt.so.3
#12 0xb7082f80 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#13 0xb7083172 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#14 0xb7745c3c in KApplication::notify () from /usr/lib/libkdecore.so.4
#15 0xb7013db7 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#16 0xb707499b in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#17 0xb7027a84 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#18 0xb709acfb in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#19 0xb709ac1e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#20 0xb7081c13 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#21 0x0805aa4d in ?? ()
#22 0xbf8ca4f0 in ?? ()
#23 0x00000001 in ?? ()
#24 0x00000001 in ?? ()
#25 0x00000000 in ?? ()
#26 0x00000015 in ?? ()
#27 0x0804ea9b in ?? ()
#28 0x00000008 in ?? ()
#29 0x00000004 in ?? ()
#30 0xb7a2bcd0 in ?? () from /usr/lib/libstdc++.so.6
#31 0xb791e908 in __malloc_initialize_hook ()
   from /lib/tls/i686/cmov/libc.so.6
#32 0x00000002 in ?? ()
#33 0x00000015 in ?? ()
#34 0x08065248 in vtable for QGList ()
#35 0xb7fb7160 in ?? ()
#36 0x080bb6e0 in ?? ()
#37 0x00000000 in ?? ()
#38 0x080bb438 in ?? ()
#39 0x0816f8f0 in ?? ()
#40 0x0816e2e0 in ?? ()
#41 0x0817f9d8 in ?? ()
#42 0x00000000 in ?? ()
#43 0x00000000 in ?? ()
#44 0x00000001 in ?? ()
#45 0x08079ad0 in ?? ()
#46 0x00000000 in ?? ()
#47 0x00000000 in ?? ()
#48 0x0817f678 in ?? ()
#49 0x08093bd0 in ?? ()
#50 0x08156288 in ?? ()
#51 0x08058700 in ?? ()
#52 0x080652cc in vtable for QGList ()
#53 0x08157f28 in ?? ()
#54 0x08157d88 in ?? ()
#55 0x08177690 in ?? ()
#56 0xb757e4e0 in vtable for QCString () from /usr/lib/libqt-mt.so.3
#57 0x08078608 in ?? ()
#58 0xbf8ca5d4 in ?? ()
#59 0x08157848 in ?? ()
#60 0x0807a368 in ?? ()
#61 0x00000132 in ?? ()
#62 0x000001ff in ?? ()
#63 0xb6e55ecc in ?? () from /usr/lib/libqt-mt.so.3
#64 0x00000000 in ?? ()
#65 0x0806d6a8 in ?? ()
#66 0x08058701 in ?? ()
#67 0x081974e0 in ?? ()
#68 0x08197940 in ?? ()
#69 0xb77fe9fc in ?? () from /lib/tls/i686/cmov/libc.so.6
#70 0xb77f632c in ?? () from /lib/tls/i686/cmov/libc.so.6
#71 0x08077340 in ?? ()
#72 0x00000049 in ?? ()
#73 0xb7561460 in ?? () from /usr/lib/libqt-mt.so.3
#74 0x00000000 in ?? ()
#75 0xb7fcdca0 in _rtld_global () from /lib/ld-linux.so.2
#76 0xbf8ca5b8 in ?? ()
#77 0xb70dbc5f in QAsciiDict<void>::insert () from /usr/lib/libqt-mt.so.3
#78 0xb7807ea2 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#79 0x08058561 in ?? ()

- how to reproduce this bug :
1. Configure Kontact with Bogofilter as an antispam plugin with the relevant wizard.
2. Start Kontact again and it always crashes when Kmail is the default module.

- expected behavior : it should work like a charm and without crashing.
Comment 1 Stephan Binner 2005-12-06 07:32:20 UTC
This happens only when running Kontact, not KMail?
Comment 2 Andreas Gungl 2005-12-06 08:27:10 UTC
It should happen both in KMail and Kontact.

It's been fixed in the KDE 3.5 branch, however AFAIK there are no official packages out yet which contain this fix.

*** This bug has been marked as a duplicate of 113730 ***