<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<!DOCTYPE bugzilla SYSTEM "https://bugs.kde.org/page.cgi?id=bugzilla.dtd">

<bugzilla version="5.0.6"
          urlbase="https://bugs.kde.org/"
          
          maintainer="sysadmin@kde.org"
>

    <bug>
          <bug_id>311528</bug_id>
          
          <creation_ts>2012-12-11 15:29:13 +0000</creation_ts>
          <short_desc>Renew-Subscription spam in /var/log/cups/access_log</short_desc>
          <delta_ts>2012-12-14 14:55:42 +0000</delta_ts>
          <reporter_accessible>1</reporter_accessible>
          <cclist_accessible>1</cclist_accessible>
          <classification_id>3</classification_id>
          <classification>Frameworks and Libraries</classification>
          <product>print-manager</product>
          <component>general</component>
          <version>unspecified</version>
          <rep_platform>Fedora RPMs</rep_platform>
          <op_sys>Linux</op_sys>
          <bug_status>RESOLVED</bug_status>
          <resolution>FIXED</resolution>
          
          
          <bug_file_loc>https://bugzilla.redhat.com/show_bug.cgi?id=885541</bug_file_loc>
          <status_whiteboard></status_whiteboard>
          <keywords></keywords>
          <priority>NOR</priority>
          <bug_severity>normal</bug_severity>
          <target_milestone>---</target_milestone>
          
          
          <everconfirmed>0</everconfirmed>
          <reporter name="nucleo">nucleo</reporter>
          <assigned_to name="Daniel Nicoletti">dantti12</assigned_to>
          <cc>kevin.kofler</cc>
    
    <cc>rdieter</cc>
          
          <cf_commitlink></cf_commitlink>
          <cf_versionfixedin></cf_versionfixedin>
          <cf_sentryurl></cf_sentryurl>
          <votes>0</votes>

      

      

      

          <comment_sort_order>oldest_to_newest</comment_sort_order>  
          <long_desc isprivate="0" >
    <commentid>1322979</commentid>
    <comment_count>0</comment_count>
    <who name="nucleo">nucleo</who>
    <bug_when>2012-12-11 15:29:13 +0000</bug_when>
    <thetext>There are a lot messages in /var/log/cups/access_log every 3-4 seconds &quot;Renew-Subscription successful-ok&quot; when kde-print-manager installed.

Reproducible: Always

Steps to Reproduce:
Just start KDE with installed kde-print-manager-0.2.0.
Actual Results:  
 /var/log/cups/access_log:

localhost - - [10/Dec/2012:04:38:02 +0200] &quot;POST / HTTP/1.1&quot; 200 437 Create-Printer-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:05 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:09 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:12 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:16 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:19 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:23 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:26 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:30 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:33 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:37 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:40 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:44 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:47 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:51 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:54 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:38:58 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok
localhost - - [10/Dec/2012:04:39:01 +0200] &quot;POST / HTTP/1.1&quot; 200 183 Renew-Subscription successful-ok


If cups disabled there is spam in .xsession-errors:

plasma-desktop(1659) KCupsConnection::renewDBusSubscription: Request failed 1280 
plasma-desktop(1659) KCupsConnection::renewDBusSubscription: Request failed 1280 
plasma-desktop(1659) KCupsConnection::renewDBusSubscription: Request failed 1280 
plasma-desktop(1659) KCupsConnection::renewDBusSubscription: Request failed 1280 
plasma-desktop(1659) KCupsConnection::renewDBusSubscription: Request failed 1280 
plasma-desktop(1659) KCupsConnection::renewDBusSubscription: Request failed 1280 
plasma-desktop(1659) KCupsConnection::renewDBusSubscription: Request failed 1280 
plasma-desktop(1659) KCupsConnection::renewDBusSubscription: Request failed 1280 
plasma-desktop(1659) KCupsConnection::renewDBusSubscription: Request failed 1280 
plasma-desktop(1659) KCupsConnection::renewDBusSubscription: Request failed 1280

Expected Results:  
no spam</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>1323737</commentid>
    <comment_count>1</comment_count>
    <who name="Rex Dieter">rdieter</who>
    <bug_when>2012-12-14 14:55:42 +0000</bug_when>
    <thetext>http://commits.kde.org/print-manager/868ac8ed9ca1f31a9bff698867a80187d87cf4c4</thetext>
  </long_desc>
      
      

    </bug>

</bugzilla>