<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<!DOCTYPE bugzilla SYSTEM "https://bugs.kde.org/page.cgi?id=bugzilla.dtd">

<bugzilla version="5.0.6"
          urlbase="https://bugs.kde.org/"
          
          maintainer="sysadmin@kde.org"
>

    <bug>
          <bug_id>307575</bug_id>
          
          <creation_ts>2012-09-29 13:35:26 +0000</creation_ts>
          <short_desc>Table import fails with error &quot;Unable to create table&quot;</short_desc>
          <delta_ts>2021-03-09 23:43:34 +0000</delta_ts>
          <reporter_accessible>1</reporter_accessible>
          <cclist_accessible>1</cclist_accessible>
          <classification_id>2</classification_id>
          <classification>Applications</classification>
          <product>KEXI</product>
          <component>Migration/Import/Export</component>
          <version>2.5.2</version>
          <rep_platform>openSUSE</rep_platform>
          <op_sys>Linux</op_sys>
          <bug_status>CONFIRMED</bug_status>
          <resolution></resolution>
          
          
          <bug_file_loc></bug_file_loc>
          <status_whiteboard></status_whiteboard>
          <keywords></keywords>
          <priority>NOR</priority>
          <bug_severity>normal</bug_severity>
          <target_milestone>---</target_milestone>
          
          
          <everconfirmed>1</everconfirmed>
          <reporter name="Guido Schmidt">guido</reporter>
          <assigned_to name="Kexi Bugs">kexi-bugs</assigned_to>
          
          
          <cf_commitlink></cf_commitlink>
          <cf_versionfixedin></cf_versionfixedin>
          <cf_sentryurl></cf_sentryurl>
          <votes>0</votes>

      

      

      

          <comment_sort_order>oldest_to_newest</comment_sort_order>  
          <long_desc isprivate="0" >
    <commentid>1301505</commentid>
    <comment_count>0</comment_count>
    <who name="Guido Schmidt">guido</who>
    <bug_when>2012-09-29 13:35:26 +0000</bug_when>
    <thetext>I&apos;m trying to import the tables from a MySQL-db with foreign key constraints into an empty Kexi-db (stored on the same MySQL-server). It only works with some of them. You can find an SQL-file with it&apos;s structure attached to bug #307571.

Reproducible: Always

Steps to Reproduce:
1. Open the table-import-assistant
2. Select source-location and database.
3. Select one of the tables. (&quot;Auftragsstatus&quot; for instance triggers the error while &quot;Bearbeiter&quot; doesn&apos;t)
4. Don&apos;t change anything in the &quot;Alter the Detected Design&quot;-Dialog
5. Start the import.

Actual Results:  
A Dialog with the error &quot;Unable to create table&quot; appears. After pressing OK the import-assistant claims &quot;Success&quot;. The table has not been created.

Expected Results:  
Have the selected table imported.
If that&apos;s not possible give more information about what did&apos;t work.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>1302107</commentid>
    <comment_count>1</comment_count>
    <who name="Jarosław Staniek">staniek</who>
    <bug_when>2012-10-01 22:17:39 +0000</bug_when>
    <thetext>Thanks for the valuable report, I&apos;ll investigate it as soon as possible.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>2013255</commentid>
    <comment_count>2</comment_count>
    <who name="Justin Zobel">justin.zobel</who>
    <bug_when>2021-03-09 23:43:34 +0000</bug_when>
    <thetext>Thank you for the bug report.

As this report hasn&apos;t seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.</thetext>
  </long_desc>
      
      

    </bug>

</bugzilla>